• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight Nano USB interface
#51
How did you connect the sender/receiver to the Arduino Nano?
 
Reply
#52
Code for the nano contains a bug, see: https://github.com/pilight/pilight-usb-nano/pull/1
 
Reply
#53
will there be also support for gpio pins on the arduino?

i want to place some relay's 1.5 meter away from my raspberry and want to connect that to the arduino?
 
Reply
#54
Eventually yes. I first need feedback on the current implementation.
 
Reply
#55
The Arduino Nano connected to Win7 is working fine: now I also have a spare RF-sender.
pilight via Nano/Windows controls my lightning in the same way as via the raspberry.
Cool
 
Reply
#56
Thanks for letting me know!
 
Reply
#57
Hi Curlymo

I'm trying to get this up and running.

I have pilight-nightly version 6.0, commit v6.0-109-gad5f475
And latest pilight-usb-nano
a chinese Nano Clone
433Mhz tranmitter on D5

Using Randy Simons RemoteSwitch library on the nano, I can control my Byron RS63 using Kaku protocol fine, it works great. However after transposing the unit/id codes (L,1 = 11,0), and configuring pilight I'm not having any luck.

When I operate the switch in GUI, the following is printed onto my terminal (ssh'd into the pc connected to the nano).

335 1005 1005 335 335 1005 1005 335 335 1005 335 1005 335 1005 1005 335 335 1005 335 1005 335 1005 335 1005 335 1005 335 1005 335 1005 335 1005 335 1005 335 1005 335 1005 1005 335 335 1005 1005 335 335 1005 1005 335 335 11390

Finding it pretty weird that this is showing up, is this supposed to happen?

No errors in log file, flashing the nano was fine.
 
Reply
#58
So everything works except the terminal output?
 
Reply
#59
(04-21-2015, 07:55 AM)curlymo Wrote: So everything works except the terminal output?

No the switches aren't toggling.

I think either

1) the signal isn't transmitted (perhaps explaining why all that text appears on the terminal)

or

2) the protocol is different to the one that's being sent via the Arduino library
 
Reply
#60
How do you know kaku works with your devices?
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  hardware info lost after pilight restart Rschnauzer 3 199 03-17-2021, 11:44 AM
Last Post: Rschnauzer
Question pilight stopped working sl4m01 3 882 11-26-2020, 09:17 PM
Last Post: PPacman
  pilight-raw changes output format from 7 to 8 Rschnauzer 1 604 11-26-2020, 01:52 PM
Last Post: curlymo
Question pilight nightly webgui offline after some hours fleisch 4 620 10-26-2020, 05:19 PM
Last Post: fleisch
  pilight bugs Ascenion 1 624 03-23-2020, 06:29 PM
Last Post: curlymo
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 4,252 12-21-2019, 09:46 AM
Last Post: curlymo
  pilight-control modify values coolinx 16 3,452 11-13-2019, 08:02 PM
Last Post: curlymo
  Bug: double free or corruption in pilight-send blackzombie 12 2,979 10-07-2019, 08:15 PM
Last Post: blackzombie
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 949 08-13-2019, 05:43 PM
Last Post: curlymo
  problems compiling pilight on Odroid C2 WitchDoctor 101 28,453 03-14-2019, 09:01 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)