• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight Nano USB interface
Yes, see attachment.

Attached Files
.jpg   asset.JPG (Size: 248.46 KB / Downloads: 16)
.jpg   asset (1).JPG (Size: 211.37 KB / Downloads: 13)
Have you checked the USB port, USB cable etc? This chip should be detected by windows.
Yes, I checked two different cables. It was "somehow" detected in Linux but I could not flash it in linux. Then I have put it into the windows machine and got no reaction.
Looks wierd. I never had a failing Arduino Nano... If you are sure that you've tried everything, the only thing we can try is a different nano.
Shall I send it back and you check it?
No, i will have to reship. Can you send me a mail again with your information?
Thanks curlymo, new nano arrived and works out of the box!
Hi CurlyMo,
you did write that the delivery from china was delayed. Do you have a status now? I ordered on 14th and 16th of march.

Thanks for replying :-)
The supplier forgot to ship it the first time. It was now shipped on the 25th of March so it should arrive this or next week.
I got some Nano clones with Atmega328P and CH340 Chip. I tried to flash pilight_usb_nano.hex using this command line:

pilight-flash -f pilight_usb_nano.hex -p /dev/ttyUSB0

I tried it on a RPi 3+ and on a RPi 2, both failed with different errors like this one:

# pilight-flash -f pilight_usb_nano.hex -p /dev/ttyUSB0 
[Apr 24 22:15:36:401571] pilight-flash: INFO: **** START UPD. FW ****
[Apr 24 22:15:36:401829] pilight-flash: INFO: Indentifying microprocessor
[Apr 24 22:15:36:413013] pilight-flash: INFO: Checking for an ATMega328P @115200
[Apr 24 22:15:38:215461] pilight-flash: ERROR: stk500_getsync() attempt 1 of 1: not in sync: resp=0xff

Sometimes it even hangs after the "INFO: Checking for an ATMega328P @115200" line (waited for minutes). Filename and COM port are correct, they are bash-autocompleted. Then I tried flashing on my laptop running Ubuntu 17.10 and it worked on the first try. Same cable, same nano. The nanos are completely "nude", no pins and no 433MHz receiver or sender connected. Also the Blink example of Arduino studio worked - so the nano(s) seem to be alright.

Anybody else having issues when flashing pilight_usb_nano.hex to an USB Nano on a Pi?

EDIT: Whop, nearly shutdown and went to bed, then I had an idea: I swapped my /etc/pilight/config.json on the Pi with the original one which has just the bare minimum, as this was the only difference between the newly setup Pi and my laptop. And it worked. Then I tried playing around with starting and stopping the plight service and swapping the configs. It works with the original minimum config, no matter if the pilight service is started. With my config.json, it also works if the service is stopped, but not if it's started. Is this "working as expected"?

Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight start/stop loop Rschnauzer 1 222 10-27-2022, 10:28 PM
Last Post: Rschnauzer
  pilight on raspbian bullseye ChristianK 3 1,544 07-29-2022, 10:18 PM
Last Post: Henkehh
  pilight-raw changes output format from 7 to 8 Rschnauzer 2 1,609 05-04-2022, 01:32 PM
Last Post: youradultworld
Question pilight stopped working sl4m01 5 2,442 09-16-2021, 01:34 PM
Last Post: orlo11
  how to compile pilight with custom protocol code? am i missing something? stanwebber 2 980 07-05-2021, 03:49 AM
Last Post: stanwebber
  hardware info lost after pilight restart Rschnauzer 3 1,227 03-17-2021, 11:44 AM
Last Post: Rschnauzer
Question pilight nightly webgui offline after some hours fleisch 4 1,695 10-26-2020, 05:19 PM
Last Post: fleisch
  pilight bugs Ascenion 1 1,220 03-23-2020, 06:29 PM
Last Post: curlymo
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 7,487 12-21-2019, 09:46 AM
Last Post: curlymo
  pilight-control modify values coolinx 16 6,013 11-13-2019, 08:02 PM
Last Post: curlymo

Forum Jump:

Browsing: 1 Guest(s)