• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
8.1.5 quietly stops working
I updated from 8.1.4 to 8.1.5 yesterday.  I can happily confirm that multiple devices can be controlled simultaneously, which is a huge improvement, but I just experienced a weird issue this morning:

All of my pilight-send commands executed without error, but no signals were being transmitted.  I tried a dozen different commands and nothing worked.  I suppose I didn't check the exit codes from the commands.  I should have done that.

Status was good:

sudo service pilight status
● pilight.service - pilight
   Loaded: loaded (/etc/systemd/system/pilight.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2019-12-17 21:02:52 EST; 11h ago
  Process: 615 ExecStart=/usr/local/sbin/pilight-daemon (code=exited, status=0/SUCCESS)
Main PID: 669 (pilight-daemon)
    Tasks: 14 (limit: 4915)
   CGroup: /system.slice/pilight.service
           └─669 /usr/local/sbin/pilight-daemon

Dec 17 21:02:50 raspberrypi systemd[1]: Starting pilight...
Dec 17 21:02:52 raspberrypi systemd[1]: Started pilight.

I did a `sudo service pilight restart`, which took an unusually long time (47 seconds according to the time I have set in my prompt).  After restarting, all pilight-send commands were working.

I could chalk this up to a fluke and see if it happens again, but I never experienced anything like this in 8.1.4.  Are there any changes that could have caused this?
Have you tried the latest nightly to see if it's fixed.
(12-18-2019, 06:55 PM)curlymo Wrote: Have you tried the latest nightly to see if it's fixed.

I had updated yesterday evening and discovered the issue this morning before heading out to work.  All I did was restart the daemon, which appears to have addressed the issue in the short-term.  So no, I have not tried the latest nightly.

I logged in around noon-ish and poked around in the logs.  I was surprised the current log only had 35 entries starting around 1:50pm (it appears that the times reported in the log are roughly 2 hours in the future, so 11:50am real time).  My restart had been maybe around 9am.

The .old log similarly did not go all the way back to yesterday evening, though I'll admit, I don't know whether that's normal logging behavior.  It started with entries at about 2:03am (i.e. midnight, real-time) where it appears to daemonize.  I had expected to see entries at least since I started up the new version yesterday evening.  I suppose it must have crashed and auto-restarted around midnight (real time)?  It goes to about "1:48pm" (11:48am real time) and the current log shows daemonization at "1:49pm" (11:49am real time).

There is nothing in the .err log from  yesterday evening onward.
Please try the latest nightly?
OK. It happened again, so I just added the nightly. I was still facing the silent failure issue, but eventually, after trying lots of things, I got it to work. We'll see if it happens again.

Incidentally, this time seemed to have been triggered by (or coincided with) some broader network issue. My 5Ghz network was not working (though my 2.5Ghz network still was working). Initially, I was unable to ssh into the pi. I was getting `ssh: Could not resolve hostname raspberrypi.local: nodename nor servname provided, or not known`. After rebooting my wireless access point, I was able to ssh and encountered the silent non-working pilight issue I'd described before. Restarting both the pilight service and the entire pi didn't resolve the issue. After installing the nightly, I was still seeing the issue. I don't know what I did that actually fixed it. Here are the settings I updated numerous times until it started working...

First, I stopped the pilight service:

sudo service pilight stop

After the nightly install, I edited the config and made these updates:

sudo nano /etc/pilight/config.json

"standalone": 0,
"gpio-platform": "raspberrypi3"
"hardware": {
"433gpio": {
"sender": 0,
"receiver": 2

I changed this file a few times (using settings that had worked in the past) and settled on the following:

sudo nano /etc/systemd/system/pilight.service




I don't know if this was necessary, but I also did this:

sudo systemctl enable pilight.service
sudo systemctl daemon-reload
sudo systemctl restart pilight.service

I didn't end up changing this file, but I'd had to make changes in the past to get pilight working:

sudo nano /etc/network/interfaces

auto lo
iface lo inet loopback
allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

I'd also had to do this in the past, so I had rerun these commands:

sudo su
iptables -A INPUT -s -j ACCEPT

sudo su -c 'iptables-save > /etc/iptables/rules.v4'
sudo su -c 'ip6tables-save > /etc/iptables/rules.v6'

Then I started things up:

sudo service pilight start
sudo service pilight status

It worked, so I rebooted and confirmed it still worked after reboot.

sudo shutdown -r now

What should be the minimum I need to do after updating pilight to get things working again? My guess would have been the config.json, but that was the first thing I'd tried (after stopping pilight, I made the edits, and restarted) and it still silently failed.

Possibly Related Threads...
Thread Author Replies Views Last Post
  After upgrading 7.0 to 8.1.5 my flamingo SF-501P switches stopped working. gerrit312 12 701 03-14-2020, 02:21 PM
Last Post: gerrit312
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 203 03-08-2020, 12:14 AM
Last Post: beejayf
  filter stopped working after update to pilight 8.1.5 zlin50 19 833 01-03-2020, 02:15 PM
Last Post: curlymo
  [Fixed] RaspberryPi4 pilight 8.1.5 - Send isn't working DominikB1993 4 725 10-18-2019, 10:25 PM
Last Post: DominikB1993
  pilight-receive Filteroption not working Alex 2 897 07-14-2019, 08:35 AM
Last Post: Alex
  pilight-flash not working danny 9 1,003 04-27-2019, 09:02 PM
Last Post: curlymo
  pilight not working with fresh Openhab 2 image habitoti 2 655 01-24-2019, 08:44 PM
Last Post: habitoti
  The switches working only in one special order Pikeman 4 688 10-13-2018, 04:35 PM
Last Post: Pikeman
  pilight 8.1 and switch with date and time not working Pikeman 7 1,391 06-30-2018, 11:28 PM
Last Post: curlymo
  tfa30 temperature-offset not working wseifert 0 446 04-29-2018, 06:12 PM
Last Post: wseifert

Forum Jump:

Browsing: 1 Guest(s)