• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] No ssdp connection found
(03-23-2015, 03:06 PM)pilino1234 Wrote: @takaze Have you tried the nightly version?

ok, I tried really everything, but didn't check the v6 nightly... Angel

After a 60 min test period it seems to work fine now Big Grin I will observe the status and give you an update Wink
 
Reply
Ok nice Smile
 
Reply
--- UPDATE ---

The problem is still there Crying I can't figure out the cause of this problem..
If I run the pilight deamon in foreground
Code:
pilight-daemon -D
I can't see any error message like high Cpu and suchlike before it stops..

The daemon itself is running without errors, but pilight doesn't send the code Surprised

In addition I compiled both, the actual nightly and stable, but nothing seems to get pilight working correctly Unsure

I also tried it on my second Pi, but I got the same problem (both Pi Model B)
 
Reply
I had the very same problem.
For me, the solutions was adding "--server=127.0.0.1" to my pilight-send command.
This comes with having "standalone": 1 in the config.json.
It is documented in the manual, section "Disabling SSDP completely" however I didn't see it at first.

http://manual.pilight.org/en/faq#pf2
Quote:Add the standalone setting in the config.json and set it to 1. However, because all pilight clients use SSDP
to find the main pilight daemon, you need to pass the server and port arguments when you want to control
this standalone running daemon.
 
Reply
I have the same problem but cannot get it fixed. Installed version 7 on a brand new raspberry pi model B+, but always get the error "no ssdp connections found" . When i start or stop pilight i do not get a message like "OK pilight stopped" or OK pilight is running". I also downloaded an recompiled pilight from github, same result. I did have it working on a previous pilight version . When my SD card crashed i installed the newest version. I also tried another raspberry pi model B, same result. Tried to stop SSDP altogether with manual port settings, still the same errors. When i list processes with the PS command, i do not see any pilight process running. Whats wrong? Please help me out
 
Reply
Try running pilight in debug mode, it will print lots of information about what is going on:
Code:
sudo service pilight stop
sudo pilight-daemon -D
You can stop it by pressing Ctrl+C. Then you can copy the output into a file and post it on here so we can have a look.
 
Reply
I solved this issue by adding sudo infront of the start-stop-daemon in the pilight init.d script.

Code:
#! /bin/sh
### BEGIN INIT INFO
# Provides:          pilight-daemon
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Starts pilight-daemon
# Description:       Starts pilight-daemon
#                  
### END INIT INFO
# Author: sweet pi & CurlyMo

# Do NOT "set -e"

# PATH should only include /usr/* if it runs after the mountnfs.sh script
PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/bin:/usr/local/sbin
NAME=pilight
DAEMON=/usr/local/sbin/pilight-daemon
#Should be the same as in: /etc/pilight/config.json
if [ -f /etc/pilight/config.json ] && [ $(grep -c pid-file /etc/pilight/config.json) -ge 1 ]; then
    PIDFILE=$(sed -ne 's/\(.*\)"pid-file":[\ ]\{0,\}"\(.*\)",/\2/p' /etc/pilight/config.json);
else
    PIDFILE="/var/run/pilight.pid"
fi
DAEMON_ARGS=
SCRIPTNAME=/etc/init.d/$NAME
# Exit if the package is not installed
[ -x "$DAEMON" ] || exit 0

# Read configuration variable file if it is present
# [ -r /etc/default/$NAME ] && . /etc/default/$NAME

# Load the VERBOSE setting and other rcS variables
. /lib/init/vars.sh

# Define LSB log_* functions.
# Depend on lsb-base (>= 3.2-14) to ensure that this file is present
# and status_of_proc is working.
. /lib/lsb/init-functions
VERBOSE=yes

#
# Function that starts the daemon/service
#
do_start()
{
    # Return
    #   0 if daemon has been started
    #   1 if daemon was already running
    #   2 if daemon could not be started
    sudo start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON --test > /dev/null \
        || return 1
    sudo start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON $DAEMON_ARGS \
        || return 2
    # Add code here, if necessary, that waits for the process to be ready
    # to handle requests from services started subsequently which depend
    # on this one.  As a last resort, sleep for some time.
}

#
# Function that stops the daemon/service
#
do_stop()
{
    # Return
    #   0 if daemon has been stopped
    #   1 if daemon was already stopped
    #   2 if daemon could not be stopped
    #   other if a failure occurred
    sudo start-stop-daemon --stop --quiet --retry=TERM/30/KILL/5 --pidfile $PIDFILE
    RETVAL="$?"
    # Many daemons don't delete their pidfiles when they exit.
    rm -f $PIDFILE
    return "$RETVAL"
}

case "$1" in
  start)
    if [ $(pkill -0 pilight-daemon 2>/dev/null; echo $?) -gt 0 ]; then
        [ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC" "$NAME"
        do_start
        case "$?" in
            0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
            2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
        esac
    else
        status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
    fi
    ;;
  stop)
    [ "$VERBOSE" != no ] && log_daemon_msg "Stopping $DESC" "$NAME"
    do_stop
    case "$?" in
        0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
        2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
    esac
    ;;
  status)
    status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
    ;;
  restart|force-reload)
    #
    # If the "reload" option is implemented then remove the
    # 'force-reload' alias
    #
    log_daemon_msg "Restarting "$NAME""
    do_stop
    case "$?" in
      0|1)
        do_start
        case "$?" in
            0) log_end_msg 0 ;;
            1) log_end_msg 1 ;; # Old process is still running
            *) log_end_msg 1 ;; # Failed to start
        esac
        ;;
      *)
        # Failed to stop
        log_end_msg 1
        ;;
    esac
    ;;
  *)
    echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
    exit 3
    ;;
esac

:
Just copy it into /etc/init.d and replace the old one and reboot.
 
Reply
That script should be run by root at startup, so sudo shouldn't be necessary… And pilight requires root privileges to run, otherwise it should warn you when you try to start the pilight-daemon as non-root.
 
Reply
[Nov 21 18:00:16:273419] pilight-daemon: NOTICE: no pilight ssdp connections fou nd
[Nov 21 18:00:16:275917] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 41298
[Nov 21 18:00:16:277121] pilight-daemon: DEBUG: client fd: 13
[Nov 21 18:00:16:278543] pilight-daemon: DEBUG: client id: 2
[Nov 21 18:00:16:280434] pilight-daemon: DEBUG: socket write succeeded: {"action ":"identify","options":{"config":1},"media":"all"}

[Nov 21 18:00:16:281670] pilight-daemon: DEBUG: socket recv: {"action":"identify ","options":{"config":1},"media":"all"}
[Nov 21 18:00:16:283691] pilight-daemon: DEBUG: socket write succeeded: {"status ":"success"}

[Nov 21 18:00:16:293399] pilight-daemon: NOTICE: no pilight ssdp connections fou nd
[Nov 21 18:00:16:295986] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 41299
[Nov 21 18:00:16:297540] pilight-daemon: DEBUG: client fd: 14
[Nov 21 18:00:16:298701] pilight-daemon: DEBUG: client id: 3
[Nov 21 18:00:16:300160] pilight-daemon: DEBUG: socket write succeeded: {"action ":"identify","options":{"config":1,"core":1},"media":"web"}

[Nov 21 18:00:16:301587] pilight-daemon: DEBUG: socket recv: {"action":"identify ","options":{"config":1,"core":1},"media":"web"}
[Nov 21 18:00:16:302875] pilight-daemon: DEBUG: socket write succeeded: {"status ":"success"}

[Nov 21 18:00:19:198732] pilight-daemon: DEBUG: cpu: 0.194778%, ram: 0.657912%
[Nov 21 18:00:19:200651] pilight-daemon: DEBUG: socket write succeeded: {"values":{"cpu":0.1947776695717574,"ram":0.6579124760697819},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-74c0de"}

[Nov 21 18:00:19:202801] pilight-daemon: DEBUG: broadcasted: {"values":{"cpu":0.1947776695717574,"ram":0.6579124760697819},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-74c0de"}
[Nov 21 18:00:22:208495] pilight-daemon: DEBUG: cpu: 0.177861%, ram: 0.657912%
[Nov 21 18:00:22:210352] pilight-daemon: DEBUG: socket write succeeded: {"values":{"cpu":0.1778611727416803,"ram":0.6579124760697819},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-74c0de"}

[Nov 21 18:00:22:211675] pilight-daemon: DEBUG: broadcasted: {"values":{"cpu":0.1778611727416803,"ram":0.6579124760697819},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-74c0de"}
[Nov 21 18:00:25:217235] pilight-daemon: DEBUG: cpu: 0.177661%, ram: 0.657912%
[Nov 21 18:00:25:218979] pilight-daemon: DEBUG: socket write succeeded: {"values":{"cpu":0.1776608910251042,"ram":0.6579124760697819},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-74c0de"}

[Nov 21 18:00:25:220306] pilight-daemon: DEBUG: broadcasted: {"values":{"cpu":0.1776608910251042,"ram":0.6579124760697819},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-74c0de"}
[Nov 21 18:00:28:225832] pilight-daemon: DEBUG: cpu: 0.194121%, ram: 0.657912%
[Nov 21 18:00:28:227588] pilight-daemon: DEBUG: socket write succeeded: {"values":{"cpu":0.1941214277092501,"ram":0.6579124760697819},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-74c0de"}

[Nov 21 18:00:28:228936] pilight-daemon: DEBUG: broadcasted: {"values":{"cpu":0.1941214277092501,"ram":0.6579124760697819},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-74c0de"}
[Nov 21 18:00:31:234421] pilight-daemon: DEBUG: cpu: 0.178261%, ram: 0.657912%
[Nov 21 18:00:31:236167] pilight-daemon: DEBUG: socket write succeeded: {"values":{"cpu":0.1782614852297055,"ram":0.6579124760697819},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-74c0de"}

i still see:

pi@raspberrypi ~ $ sudo service pilight start
pi@raspberrypi ~ $ pilight-receive
[Nov 21 18:03:55:753565] pilight-receive: NOTICE: no pilight ssdp connections found
pi@raspberrypi ~ $
 
Reply
Please use code tags to format terminal outputs and code to make it easier to read on here.

How many nodes do you have in your setup? Can you stop all of them, only start one, and then start another one using the -S xx.xx.xx.xx -P yyyy parameters to define the location of the main daemon?
You need to set the port in the config.json of your master node first, see the manual.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Connection lost, trying to reconnect — loop apartmedia 5 498 03-16-2019, 09:41 AM
Last Post: curlymo
  [solved] Webgui 404-Error PT-Biker 2 926 11-11-2017, 09:49 AM
Last Post: PT-Biker
  [solved] Hardware not compatible ccc.ggg73 1 1,430 06-10-2017, 09:10 AM
Last Post: curlymo
  Standalone but SSDP brenner23 6 2,355 04-16-2017, 11:34 PM
Last Post: brenner23
  [Solved] pilight ssdp celle 6 8,005 02-23-2017, 03:22 PM
Last Post: gneandr
  Raspbian jessie - pilight 7 - no pilight ssdp connections found shirocko 20 15,978 01-29-2017, 10:23 PM
Last Post: gneandr
  [solved] No signal with raw data andies 6 2,885 12-25-2016, 09:11 AM
Last Post: andies
  pilight without internet connection terrar 5 3,150 08-12-2016, 09:47 PM
Last Post: terrar
  ssdp discovery clach04 5 4,737 05-23-2016, 04:23 PM
Last Post: pilino1234
  Found Bug? boukehaarsma 8 3,940 01-27-2016, 11:07 PM
Last Post: boukehaarsma

Forum Jump:


Browsing: 1 Guest(s)