The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 895 - File: showthread.php PHP 7.3.14-1~deb10u1 (Linux)
File Line Function
/showthread.php 895 errorHandler->error



  • 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problem with alecto_wx500 protocol (pilight V7)
#1
I have a problem with the alecto_wx500 protocol (pilight v7.0).
if the Temperature goes under 0.00°C i get output of 204.7°C ...


Temp .. <-- binary --> .. dec. . pilight
+3.0 := 0000 0001 1110 =.. 30 . . . 3.0
+2.9 := 0000 0001 1101 =.. 29 . . . 2.9
+1.0 := 0000 0000 1010 =.. 10 . . . 1.0
+0.2 := 0000 0000 0010 =... 2 . . . 0.2
+0.1 := 0000 0000 0001 =... 1 . . . 0.1
+0.0 := 0000 0000 0000 =... 0 . . . 0.0
-0.1 := 1111 1111 1111 = 4096 . . 204.7
-0.2 := 1111 1111 1110 = 4094 . . 204.6
-1.0 := 1111 1111 0110 = 4086 . . 203.8
-1.1 := 1111 1111 0101 = 4085 . . 203.7
-2.0 := 1111 1110 1100 = 4076 . . 202.8


Sorry for the dots in the list. Just trying to align the data with the heading..

According to the this document "This 12 bits wide 2's complement signed binary number represents the actual temperature value in 0.1 °C units".

It looks like only 11 bits are used and there is no awareness of the negative numbers.. (flipping the bits and add one).

Can someone confirm this (and hopefully fix this for pilight v8.0!)?
 
Reply
  


Messages In This Thread
problem with alecto_wx500 protocol (pilight V7) - by TheWheel - 03-08-2016, 01:22 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight-control TML 13 295 05-27-2020, 07:51 AM
Last Post: curlymo
  API Requests by HTTP from other devices fore use in pilight scootermacro 2 140 05-10-2020, 08:19 AM
Last Post: scootermacro
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 1,989 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 486 03-08-2020, 12:14 AM
Last Post: beejayf
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 513 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 636 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 429 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 1,308 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 502 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 1,393 12-18-2019, 11:09 AM
Last Post: vanillaice30

Forum Jump:


Browsing: 1 Guest(s)