• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
webserver-authentication problem with some browsers
#1
Hi,

thanks for implementing pilight, it is a great tool and i love to use it for my home automation. I use the RPI2 with pilight 7.0

After reading this thread SMTP Password in web response I tried the webserver-authentication.
It works fine, but only on with some browsers. Some other browsers always show "connection lost, touch to reload". Touching (clicking) on the GUI reloads the screen without asking for the password again, but always brings up the "connection lost" screen.

I tried the following browsers:
Firefox (windows) - OK
Chrome (Windows) - OK
Chrome (android mobile) - OK
Native Browser (android mobile) - Connection lost
Native Browser (RasbPi 2 using debian jessie) - Connection lost. <-- localhost adress was used.

Without the webserver authentification the gui is displayed in everey browser.

Any idea, what could be wrong?

[UPDATE]
I found the following log entries, it seems, that it tries to reconnect 10 times using different ports before it says "connection lost"
Code:
<< Clicked to connect >>
[Mar 22 11:41:47:821182] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34890
[Mar 22 11:41:48:578267] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34896
[Mar 22 11:41:48:583740] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34897
[Mar 22 11:41:48:586140] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34898
[Mar 22 11:41:48:587933] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34899
[Mar 22 11:41:48:598831] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34900
[Mar 22 11:41:48:663117] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34902
[Mar 22 11:41:48:699734] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34904
[Mar 22 11:41:49:441432] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34907
[Mar 22 11:41:49:449543] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34908
<< Clicked to connect >>
[ Mar 22 11:43:18:24087] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34908
[Mar 22 11:43:18:487212] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34907
[Mar 22 11:43:18:529524] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34915
[Mar 22 11:43:18:531722] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34916
[Mar 22 11:43:18:533805] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34917
[Mar 22 11:43:18:536020] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34918
[Mar 22 11:43:18:885113] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34920
[Mar 22 11:43:18:923087] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34922
[Mar 22 11:43:19:663407] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34925
[Mar 22 11:43:19:667554] pilight-daemon: INFO: client connected, ip 127.0.0.1, port 34926
 
Reply
  


Messages In This Thread
webserver-authentication problem with some browsers - by MorfelPi - 03-22-2016, 11:22 AM

Possibly Related Threads...
Thread Author Replies Views Last Post
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 1,377 12-18-2019, 11:09 AM
Last Post: vanillaice30
  [Already fixed in 8.1.2] Loss of webserver-connection Ulrich.Arnold 34 4,775 08-02-2019, 02:25 PM
Last Post: curlymo
  REST API problem kaku_screen_old / elro_800_switch with pilight 8.1.4 pisperate 4 916 12-20-2018, 09:26 PM
Last Post: pisperate
  problem with alecto_wx500 protocol (pilight V7) TheWheel 18 6,678 04-12-2018, 06:38 PM
Last Post: NevelS
  Problem with Protocol gpio_switch engel035 15 3,739 03-19-2018, 06:46 PM
Last Post: curlymo
  433MHz sender - receiver problem EndruK 1 1,026 02-17-2018, 02:24 PM
Last Post: EndruK
  Webserver (REST API) - POST TopdRob 7 2,225 10-25-2017, 11:17 PM
Last Post: curlymo
  Problem installing pilight gwaag 2 2,156 10-16-2017, 06:23 AM
Last Post: curlymo
  Problem with sending after plight (or raspberry?) update _Jens_ 5 2,548 09-08-2017, 03:14 PM
Last Post: pilino1234
  EV1527 Problem Alex 6 2,580 04-30-2017, 06:25 PM
Last Post: Alex

Forum Jump:


Browsing: 1 Guest(s)