• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
config device #1 "living", missing protocol
#1
Hello,
I'm starting with pilight.
I've run pilight-receive and I received my neighboor temperature device as follow :


Code:
{
        "message": {
                "id": 227,
                "temperature": 2.61,
                "humidity": 93.00,
                "battery": 1,
                "channel": 1
        },
        "origin": "receiver",
        "protocol": "tfa",
        "uuid": "0000-b8-27-eb-c15c94",
        "repeats": 4
}

So I would like to add this as a new device.

In the conf.json I've added :


Code:
"devices": {
  "living": {
  "name": "Living",
  "weather": {
       "name": "Weather",
    "protocol": ["tfa"],
    "id": [{
    "id": 227,
    "channel": 1
  }],
  "temperature": 189,
  "humidity": 410,
  "battery": 1
  }
}
}


But I have the following error (in /var/log/pilight.err) when I run pilight service:

[Nov 08 00:18:18:225149] pilight-daemon: ERROR: config device #1 "living", missing protocol

What's wrong ?
Thanks in advance.
 
Reply
  


Messages In This Thread
config device #1 "living", missing protocol - by jjlf - 11-08-2016, 12:24 AM

Possibly Related Threads...
Thread Author Replies Views Last Post
  Compile with Optimization fails / timedate missing fourty2 6 309 04-29-2019, 12:27 PM
Last Post: fourty2
  Protocol Program PID AdHoc-Client Bigmama 12 717 01-26-2019, 07:36 PM
Last Post: Bigmama
  Config migration from pilight 7 .0 to 8.1.3 "Rules" Nonaamee 4 726 11-17-2018, 08:35 PM
Last Post: Nonaamee
Exclamation pilight detect wrong protocol quigg_gt9000 is not quigg_gt1000 PCT 1 753 08-12-2018, 11:13 AM
Last Post: Niek
  need some help with program protocol charlesjacob4695 1 400 05-15-2018, 05:58 PM
Last Post: curlymo
  problem with alecto_wx500 protocol (pilight V7) TheWheel 18 5,006 04-12-2018, 06:38 PM
Last Post: NevelS
  deleyCON remote plug socket (arctec_screen_old protocol) itsMe 6 1,075 04-01-2018, 08:35 PM
Last Post: itsMe
  Problem with Protocol gpio_switch engel035 15 2,806 03-19-2018, 06:46 PM
Last Post: curlymo
  arctech_contact protocol missing open/close signals Niek 2 578 12-23-2017, 07:16 PM
Last Post: Niek
  Extend generic protocol mickey.lm 6 1,029 11-20-2017, 10:51 PM
Last Post: mickey.lm

Forum Jump:


Browsing: 1 Guest(s)