• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WebSocket connection failed: One or more reserved bits
#6
(02-16-2018, 10:43 AM)curlymo Wrote: How can i trigger the issue myself?

That is a good question, i'm not yet sure.
Seems to happen quite random at loading the webgui in the browser.
When it stucks then a few times pressed refresh can help, but sometimes
it is also good for triggering the issue. The most often i get it on Android devices,
seems to happen less on desktop.

To trigger the issue, you need to route pilight on proxy. I'm using a Apache/Debian server configured to proxy the subdomain to pilight. Https of pilight is not used, Apache is doing the job.

Here is the Apache config:
Code:
<VirtualHost *:80>
   ServerName subdomain.example.com

   # Tell search engines not to index or follow.
   Header set X-Robots-Tag "noindex, nofollow"

   # Redirect everything to HTTPS
    Redirect 301 / https://subdomain.example.com
</VirtualHost>

<VirtualHost *:443>
   ServerName subdomain.example.com

   # Tell search engines not to index or follow.
   Header set X-Robots-Tag "noindex, nofollow"

   SSLCertificateFile /etc/letsencrypt/live/example.com/cert.pem
   SSLCertificateKeyFile /etc/letsencrypt/live/example.com/privkey.pem
   SSLCertificateChainFile /etc/letsencrypt/live/example.com/fullchain.pem

   SSLProxyEngine On

   ProxyPreserveHost On
   ProxyPass /websocket ws://localhost:5001/websocket/
   ProxyPassReverse /websocket ws://localhost:5001/websocket/
   ProxyPass / http://localhost:5001/
   ProxyPassReverse / http://localhost:5001/
</VirtualHost>

So far it was good to achieve Https and to put it on a subdomain.
 
Reply
  


Messages In This Thread
RE: WebSocket connection failed: One or more reserved bits - by gregnau - 02-16-2018, 04:00 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  [Already fixed in 8.1.2] Loss of webserver-connection Ulrich.Arnold 34 2,484 08-02-2019, 02:25 PM
Last Post: curlymo
Thumbs Up Newbie problems, usbnano connection and rsl366 pukington 1 473 02-14-2018, 07:36 PM
Last Post: pukington
  Windows HTTP connection andbehtls 1 1,056 01-14-2018, 02:24 PM
Last Post: bnk72
  Upgrade to jessie+pilight+kernel failed witty 10 1,827 01-04-2018, 12:27 PM
Last Post: witty
  Illumina, cannot obtain connection hansrijn2 5 1,300 05-31-2017, 04:29 PM
Last Post: hansrijn2
  [solved] another pilight ssdp missed connection on RPI segalion 2 2,957 08-24-2016, 10:51 PM
Last Post: Hauke
  [Solved] pilight 7.0 LAN interact connection - 2 Raspberrys mvasi90 4 1,905 07-10-2016, 03:50 PM
Last Post: mvasi90
  pilight-receive: NOTICE: no pilight ssdp connection found bumtheduke 10 12,370 03-29-2016, 10:58 AM
Last Post: pilino1234
  Using API webserver send page "message":"failed" fips 1 1,513 01-08-2016, 09:21 AM
Last Post: fips
  API - Curl.... {message:failed} joho 0 1,291 12-04-2015, 01:29 PM
Last Post: joho

Forum Jump:


Browsing: 1 Guest(s)