• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pushover no longer working
#5
C´mon Curlymo,

I´m running on Nightly´s since day one, because there where always room and hope for improvement, wether in rule handling or in protocol developement. But to be honest, after a complete rebuild in early 2018, I thought, I was running the main branch… Obviously not.

You don´t know About strange rule behavior?

https://forum.pilight.org/showthread.php?tid=3397
https://forum.pilight.org/showthread.php?tid=3371

You don´t know About Syntax changes?

- changin IS to == (or is it vice versa?)
- changing SECOND to 'Second'
I have a ruleset of about 25 rules. This means unexpected work (finding out changes and correcting them)

It´s not the first time, that you remove protocols for devices, I use a long time (e.g. AMST-606)

And, to be honest again, I´m a simple user with very limited time. Curios but time-limited. I´m having trouble with pilight behavior, try to update and get new Problems with no time to fix them. 

So, for me it seems, that leaving pilight is the best Option.

Simple Example:

Not working, never switches to on (while home is a simple generic button switched to on):
Code:
"nachtlicht": {
                        "rule": "IF sonne.sun == set AND home.state == on THEN switch DEVICE Nachtlicht TO on",
                        "active": 1
                },

Working:
Code:
"nachtlicht-aus": {
                        "rule": "IF sonne.sun == rise THEN switch DEVICE Nachtlicht TO off",
                        "active": 1
                },

Not working, switches to on but never switches to off:
Code:
"keller_morgens_kino": {
                        "rule": "IF ((zeit.hour == 7 AND zeit.minute == 0 AND zeit.second == 0) AND weather1.temperature < sensor_kino.temperature) THEN switch DEVICE keller_kino TO on FOR '20 MINUTE'",
                        "active": 1
                },

Working:
Code:
"aqluft_frueh": {
                        "rule": "IF (zeit.hour == 7 AND zeit.minute == 0 AND zeit.second == 0) THEN switch DEVICE aqluft TO on FOR '10 MINUTE'",
                        "active": 1
                },
 
Reply
  


Messages In This Thread
Pushover no longer working - by Alex - 07-07-2018, 09:02 AM
RE: Pushover no longer working - by curlymo - 07-07-2018, 09:51 AM
RE: Pushover no longer working - by Alex - 07-07-2018, 10:15 AM
RE: Pushover no longer working - by curlymo - 07-07-2018, 01:29 PM
RE: Pushover no longer working - by Alex - 07-07-2018, 04:02 PM
RE: Pushover no longer working - by curlymo - 07-07-2018, 05:33 PM
RE: Pushover no longer working - by curlymo - 07-09-2018, 06:25 AM

Possibly Related Threads...
Thread Author Replies Views Last Post
  Rule with&without device. One working not the other... Tamadite 9 1,946 07-24-2018, 08:55 AM
Last Post: curlymo
  action: pushover Niek 36 21,503 12-03-2017, 11:13 AM
Last Post: Alex
  Pushover unformatted timestamp Pik 2 1,820 05-08-2016, 08:48 AM
Last Post: Pik
  help needed: ping rule not working meloen 4 3,719 02-25-2015, 12:55 AM
Last Post: meloen

Forum Jump:


Browsing: 1 Guest(s)