• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Triggering generic_switch leads to segfault
#5
(10-09-2019, 06:40 PM)curlymo Wrote: Please install the pilight-dbg version before testing?

Hi!

I did the following:

apt-get update
apt-get install pilight-dbg
gdb --args pilight-daemon -D

This gets:
Code:
Thread 1 "pilight-daemon" received signal SIGSEGV, Segmentation fault.
strlen () at ../sysdeps/arm/armv6/strlen.S:26
26    ../sysdeps/arm/armv6/strlen.S: Datei oder Verzeichnis nicht gefunden.
(gdb)


(gdb) backtrace
#0  strlen () at ../sysdeps/arm/armv6/strlen.S:26
#1  0x7657dba8 in lua_getfield ()
  from /usr/lib/arm-linux-gnueabihf/libluajit-5.1.so.2
#2  0x768278e4 in timer_callback (req=<optimized out>)
   at /home/pilight/source/daemon-dev/libs/pilight/lua_c/async/timer.c:387
#3  0x7678e8a8 in uv__run_timers (
   loop=loop@entry=0x76f9d598 <default_loop_struct>)
   at /home/pilight/source/daemon-dev/libs/libuv/unix/timer.c:165
#4  0x7677fd54 in uv_run (loop=0x76f9d598 <default_loop_struct>,
   mode=mode@entry=UV_RUN_DEFAULT)
   at /home/pilight/source/daemon-dev/libs/libuv/unix/core.c:353
#5  0x0000b898 in main (argc=<optimized out>, argv=<optimized out>)
   at /home/pilight/source/daemon-dev/daemon.c:3512
(gdb)

I hope that helps

Uli
 
Reply
  


Messages In This Thread
RE: Triggering generic_switch leads to segfault - by Ulrich.Arnold - 10-10-2019, 11:38 AM
RE: Shelly device - by curlymo - 10-08-2019, 09:34 PM
RE: Shelly device - by Ulrich.Arnold - 10-09-2019, 01:18 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  ][solved]Segfault when retrieving big chunked http message Niek 21 6,625 11-29-2018, 03:17 PM
Last Post: curlymo
  http code 301 causes segfault Niek 3 3,514 08-14-2018, 06:57 PM
Last Post: curlymo
  Long label text causes segfault Niek 10 1,690 06-29-2018, 02:18 PM
Last Post: Niek
  [Solved] config.json not updated Niek 6 1,769 12-31-2017, 03:19 PM
Last Post: curlymo
  [Solved] callback not executing when dns lookup fails Niek 1 876 10-08-2017, 11:44 AM
Last Post: curlymo
  [Solved] Rules switching state based on another device state not working apartmedia 6 2,746 09-27-2017, 01:41 PM
Last Post: apartmedia
  [Solved] connection to main pilight daemon lost TopdRob 20 4,930 09-17-2017, 04:30 PM
Last Post: curlymo
  [Solved] dimmer protocol kaku_dimmer does not react on dimmervalue apartmedia 25 4,841 09-16-2017, 10:29 PM
Last Post: apartmedia
  [Solved] Webgui not working in IE Ulrich.Arnold 7 2,105 09-12-2017, 05:22 PM
Last Post: Ulrich.Arnold
  [Solved] Sunriseset v7 fails after update and gives negative values PPacman 7 1,933 09-06-2017, 06:25 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)