The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 895 - File: showthread.php PHP 7.3.14-1~deb10u1 (Linux)
File Line Function
/showthread.php 895 errorHandler->error



  • 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't send or receive on Raspberry Pi Zero W
#1
Hello,
I already use pilight some years on a RPi2B and RPi3. Now I want to use it on a Raspberry Pi Zero W. I installed it yesterday with the latest stable version and I did the steps from the pilight manual.

But somehow I can't receive something (not so bad for me) and I can't switch a plug on or off with the same code like on the RPi3:
Code:
pilight-send -p elro_800_switch -s 31 -u 1 -t


Here's my configuration file:
Code:
{
    "devices": {},
    "rules": {},
    "gui": {},
    "settings": {
        "log-level": 4,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "webserver-enable": 0,
        "webserver-root": "/usr/local/share/pilight/",
        "webserver-http-port": 80,
        "webserver-cache": 1,
        "standalone": 1,
        "gpio-platform": "raspberrypizero"
    },
    "hardware": {
        "433gpio": {
            "sender": 0,
            "receiver": 1
        }
    },
    "registry": {
        "pilight": {
            "version": {
                "current": "8.1.5"
            }
        },
        "webserver": {
            "ssl": {
                "certificate": {
                    "location": "/etc/pilight/pilight.pem"
                }
            }
        },
        "hardware": {
            "RF433": {
                "mingaplen": 4420,
                "maxgaplen": 72900,
                "minrawlen": 26,
                "maxrawlen": 400
            }
        }
    }
}

I used "raspberrypizero" because there is no suggestion for a Zero W. Is this a problem?

Here are further information for my system:
Code:
sudo pilight-daemon -D
-------------------------

(/home/pilight/source/daemon-dev/daemon.c #2846) [Apr 03 14:49:31:217428] NOTICE: pilight-daemon is already running (369)
(/home/pilight/source/daemon-dev/libs/pilight/events/operator.c #381) [Apr 03 14:49:31:221909] DEBUG: garbage collected event operator library
(/home/pilight/source/daemon-dev/libs/pilight/events/action.c #517) [Apr 03 14:49:31:222659] DEBUG: garbage collected event action library
(/home/pilight/source/daemon-dev/libs/pilight/events/function.c #296) [Apr 03 14:49:31:223284] DEBUG: garbage collected event function library
(/home/pilight/source/daemon-dev/libs/pilight/events/events.c #252) [Apr 03 14:49:31:223885] DEBUG: garbage collected events library
(/home/pilight/source/daemon-dev/libs/pilight/core/sha256cache.c #34) [Apr 03 14:49:31:224711] DEBUG: garbage collected sha256cache library
(/home/pilight/source/daemon-dev/libs/pilight/core/webserver.c #240) [Apr 03 14:49:31:225329] DEBUG: garbage collected webserver library
(/home/pilight/source/daemon-dev/libs/pilight/core/datetime.c #1172) [Apr 03 14:49:31:225924] DEBUG: garbage collected datetime library
(/home/pilight/source/daemon-dev/libs/pilight/core/ssdp.c #80) [Apr 03 14:49:31:227022] DEBUG: garbage collected ssdp library
(/home/pilight/source/daemon-dev/libs/pilight/core/options.c #23) [Apr 03 14:49:31:238113] DEBUG: garbage collected options library
(/home/pilight/source/daemon-dev/libs/pilight/core/socket.c #92) [Apr 03 14:49:31:238309] DEBUG: garbage collected socket library
(/home/pilight/source/daemon-dev/libs/pilight/hardware/hardware.c #43) [Apr 03 14:49:31:238468] DEBUG: garbage collected config hardware library
(/home/pilight/source/daemon-dev/libs/pilight/config/devices.c #1759) [Apr 03 14:49:31:238682] DEBUG: garbage collected config devices library
(/home/pilight/source/daemon-dev/libs/pilight/config/rules.c #255) [Apr 03 14:49:31:238824] DEBUG: garbage collected config rules library
(/home/pilight/source/daemon-dev/libs/pilight/config/gui.c #113) [Apr 03 14:49:31:238960] DEBUG: garbage collected config gui library
(/home/pilight/source/daemon-dev/libs/pilight/config/config.c #443) [Apr 03 14:49:31:239082] DEBUG: garbage collected storage library
(/home/pilight/source/daemon-dev/libs/pilight/protocols/protocol.c #383) [Apr 03 14:49:31:239232] DEBUG: protocol process
(/home/pilight/source/daemon-dev/libs/pilight/protocols/protocol.c #416) [Apr 03 14:49:31:240108] DEBUG: garbage collected protocol library
(/home/pilight/source/daemon-dev/libs/pilight/core/threads.c #313) [Apr 03 14:49:31:240311] DEBUG: garbage collected threads library
(/home/pilight/source/daemon-dev/libs/pilight/core/dso.c #99) [Apr 03 14:49:31:240479] DEBUG: garbage collected dso library
DEBUG: garbage collected log library

Code:
uname -a
-------------------------

Linux raspberrypi 4.19.97+ #1294 Thu Jan 30 13:10:54 GMT 2020 armv6l GNU/Linux


Code:
pilight-daemon -V
---------------------

pilight-daemon version v8.1.5


I hope someone can help me because I already tried a lot and have no further idea. I also used different hardware for transmitter and receiver and all of them work on my RPi3.
 
Reply
  


Messages In This Thread
Can't send or receive on Raspberry Pi Zero W - by ChristophH - 04-03-2020, 04:00 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  Failed pilight-send that say they succeeded hepcat72 2 192 12-05-2020, 05:30 PM
Last Post: hepcat72
  pilight for Raspbian Buster (raspberry pi 4) ? starob 32 11,963 08-10-2020, 09:12 AM
Last Post: simanuel
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 5,640 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 1,530 03-08-2020, 12:14 AM
Last Post: beejayf
  raspberry pi 4 config.json Stefan 2 932 02-02-2020, 09:59 AM
Last Post: Stefan
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 2,731 12-18-2019, 11:09 AM
Last Post: vanillaice30
  Raspberry 4B installation error royw 3 1,039 12-05-2019, 10:58 AM
Last Post: royw
  NOTICE: 433gpio send buffer full HuberDe 3 840 10-31-2019, 12:10 PM
Last Post: curlymo
  [Fixed] RaspberryPi4 pilight 8.1.5 - Send isn't working DominikB1993 4 1,540 10-18-2019, 10:25 PM
Last Post: DominikB1993
  pilight-receive Filteroption not working Alex 2 1,314 07-14-2019, 08:35 AM
Last Post: Alex

Forum Jump:


Browsing: 1 Guest(s)