• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


[Fully Supported] Elro 800 Series
#21
Hi,

I bought this devices :

http://www.elro.eu/en/products/cat/home-...-keychain1

http://www.elro.eu/en/products/cat/home-...-in-switch

Work perfectly, but i cant "clone" signal from transmitter.

When i press button on HE841 pilight-receive gives :

Code:
root@raspberrypi:/etc/pilight# pilight-receive
{
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "pollin",
    "uuid": "0000-00-00-9c-572f3c",
    "repeats": 1
}
{
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "pollin",
    "uuid": "0000-00-00-9c-572f3c",
    "repeats": 2
}
{
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "pollin",
    "uuid": "0000-00-00-9c-572f3c",
    "repeats": 3
}
{
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "pollin",
    "uuid": "0000-00-00-9c-572f3c",
    "repeats": 4
}

When I use pilight-send with options :

Quote:sudo pilight-send -p pollin -s 14 -u 11 -t

pilight-recieve gives :

Code:
{
    "origin": "sender",
    "protocol": "pollin",
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "repeat": 1,
    "uuid": "0000-00-00-9c-572f3c"
}

What I'm doing wrong ? "Origin" makes a difference ? So how I can change it from sender to receiver ? Maybe number of repeats ? But in setting.json I have a line :

Quote:"send-repeats": 10,

I appreciate any answer !
 
Reply
#22
If you want to know how to interpret the origin field. Read this page:
http://pilight.org/development/api
 
Reply
#23
Thank You curlymo, And now I understand what it's orogin...

My pilight-debug with "ON" button from HE841 :

Code:
time:        Fri Jun 13 19:54:29 2014
hardware:    433gpio
pulse:        3
rawlen:        50
binlen:        12
pulselen:    305

Raw code:
305 915 915 305 305 915 305 915 305 915 305 915 305 915 305 915 305 915 915 305 305 915 305 915 305 915 305 915 305 915 915 305 305 915 305 915 305 915 915 305 305 915 915 305 305 915 915 305 305 10370
Binary code:
011101101000

Anyone any idea ?
 
Reply
#24
Can you try again after installing:
Code:
sudo apt-get install pilight-protocol-elro-he
From the development pilight repository?
 
Reply
#25
Okay, after installing this protocol I get something new in receiver, when I push the button :
Code:
{
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "elro_he",
    "uuid": "0000-00-00-9c-572f3c",
    "repeats": 3
}
{
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "pollin",
    "uuid": "0000-00-00-9c-572f3c",
    "repeats": 3
}
{
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "pollin",
    "uuid": "0000-00-00-9c-572f3c",
    "repeats": 4
}
{
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "pollin",
    "uuid": "0000-00-00-9c-572f3c",
    "repeats": 5
}

So, I use protocol elro_he to send signal, and received :

Code:
{
    "origin": "sender",
    "protocol": "elro_he",
    "code": {
        "systemcode": 14,
        "unitcode": 11,
        "state": "on"
    },
    "repeat": 1,
    "uuid": "0000-00-00-9c-572f3c"
}

Socket still stay turned OFF. I also try pollin protocol again, but without any effect.

Now i realized it must be a problem with my transmitter. Origin in deamon clearly say "sender", it means signal was received by deamon inside RPi, not via 433MHz ... So i unpluged transmitter, and of course "pilight-receiver" still working, even without transmitter.

Before I tried RCSwitch library, and there connection between transmitter, and receiver work correctly, but now Im confused... In Hardware.json file :

Code:
{
    "433gpio": {
        "sender": 0,
        "receiver": 1
    }
}

It's fine according to wiringPi ... Any advice how to check compatibility my transmitter with pilight ? It is even possible ?

Maybe I missed something in settings.json ?

Code:
{
    "log-level": 4,
    "pid-file": "/var/run/pilight.pid",
    "config-file": "",
    "hardware-file": "/etc/pilight/hardware.json",
    "log-file": "/var/log/pilight.log",
    "send-repeats": 10,
    "receive-repeats": 3,
    "webserver-enable": 1,
    "webserver-root": "/usr/local/share/pilight/",
    "webserver-port": 5001,
    "webserver-cache": 1,
    "whitelist": "",
    "update-check": 1,
    "firmware-update": 0
}
 
Reply
#26
Furthermore, can you try the suggestions given in this thread:
http://forum.pilight.org/Thread-Elro-Hom...815S--1039
 
Reply
#27
@curlymo,
i've updated the Wiki "supportd devices" with the workaround. When i found more time, i will provide all the debug information, but this could take some time Angel


lcd4linux
 
Reply
#28
Can you also add it to the protocol description page?
 
Reply
#29
OK i have a solution :

1. We need, as is suggested before, pair the same socket again with our's RPi transmitter (even if we use the same code).
2. Single command pilight-send -p ... is too short for pairing with socket, so I wrote simple loop in bash :

Code:
#!/bin/bash
for i in {1..15}
do
   pilight-send -p elro_he -u 11 -s 14 -t
done

And it works ! According to elro_he protocol we change last parameter "-t" (ON) to "-f", and we can turn OFF our socket.

Very Big thanks for curlymo !
 
Reply
#30
and to lcd4linux.

You can also change the send-repeats in the settings.json.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
Lightbulb [Fully Supported] Kaku Door sensor (AMST-606) geerttttt 53 25,526 10-19-2019, 06:26 PM
Last Post: curlymo
  [Partially Supported] TFA / Conrad Weather Yves 184 14,942 03-31-2019, 05:22 PM
Last Post: curlymo
  [Fully Supported] DHT22 IcedEarth 86 33,214 11-18-2018, 09:33 AM
Last Post: curlymo
  [Fully Supported] Arctech Old Martin 111 37,246 03-27-2018, 04:43 PM
Last Post: genfersee
  [Fully Supported] Clarus Switches Marcin 69 25,891 01-30-2018, 07:10 PM
Last Post: Niek
  [Fully Supported] Remote Control Socket (RC101-U/RC201) Sean 18 11,182 01-04-2018, 06:18 AM
Last Post: ettman8
  Elro/Flamingo FA20RF Smoke detector meloen 76 39,239 12-16-2017, 07:07 PM
Last Post: pilino1234
  [Fully Supported] LM75 and LM76 temperature sensor horst_dieter 64 26,110 11-19-2017, 08:54 PM
Last Post: edepi
  [Fully Supported] No-brand temp/humidity sensor (alecto_ws1700) meloen 57 36,566 12-25-2016, 09:53 PM
Last Post: creamers
  [Fully Supported] Impuls/SelectRemote Bram 113 49,296 05-28-2016, 02:53 PM
Last Post: Puuu

Forum Jump:


Browsing: 1 Guest(s)