• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] pilight ssdp
#1
Hey
I try to run pilight on my raspberry pi. But I have a problem with ssdp server.
It always told me
pilight-send: ERROR: no pilight ssdp connections found

What did I do?
Added -A INPUT -s 127.0.01 -j ACCEPT to my iptables. Installed lsb-base and lsb-release.
Checked my network interfaces and turned off my webserver and webserver-cache. But it still doesn't work.

I know it must be a problem with my iptables. Why? I crashed my iptables like this
-A INPUT -ü 127.0.01 -j ACCEPT
Iptables didn't boot because it has an error. And now I tried
sudo pilight-send -p kaku_switch_old -i 1 -u 0 -f
and it worked fine. So this must me a fault on the iptables. But I don't know what is wrong.
I want to remember that i added 127.0.0.1 to my iptables.

Someone has an idea?

Edit:
Found the Problem. Checked ports via sudo netstat -lpn | grep udp .Saw port from pilight-daemon. Added it to iptables. Now its woking.
 
Reply
#2
Can you maybe add this to the wiki.
 
Reply
#3
Lightbulb 
That is not the problem.
localhost is always available on each port and protocol.
The problem is the early start of pilight-daemon. The start level in the /etc/init.d/pilight script must be at least 3. See my post:
https://forum.pilight.org/Thread-Raspbia...?pid=19876 and https://forum.pilight.org/Thread-pilight-7-0?pid=19863

MfG Angie
 
Reply
#4
hi folks,

i'm one of the confused users.. I cannot solve the SSDP issue with all the recommendations posted somewhere in the forum..

I have followed instructions of both posts:
Quote:That is not the problem.
localhost is always available on each port and protocol.
The problem is the early start of pilight-daemon. The start level in the /etc/init.d/pilight script must be at least 3. See my post:
https://forum.pilight.org/Thread-Raspbia...?pid=19876 and https://forum.pilight.org/Thread-pilight-7-0?pid=19863

But neither with the start script(/etc/systemd/system/pilight.service
) nor with the changes on /etc/init.d/pilight i managed to get rid of the issue..

Below's my configuration of /etc/init.d/pilight
Code:
### BEGIN INIT INFO
# Provides:          pilight-daemon
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     3 4 5
# Default-Stop:      0 1 2 6
# Short-Description: Starts pilight-daemon
# Description:       Starts pilight-daemon
#
### END INIT INFO
# Author: sweet pi & CurlyMo

# Do NOT "set -e"

# PATH should only include /usr/* if it runs after the mountnfs.sh script
My Iptables contains of one line:
Code:
-A INPUT -s 127.0.01 -j ACCEPT

I'm running a rasp. 3 with the newest version of Raspian and pilight 7 core branch.

What else could i do to resolve the issue?
 
Reply
#5
Do you have a loopback network adapter?
 
Reply
#6
Not sure what "loopback network adapter" means, but my Pi is connected via WIFI and does have a static IP adress, assigned by the router..

Code:
pi@openhab:~ $ sudo nano /etc/network/interfaces
  GNU nano 2.2.6                  Datei: /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual

Code:
pi@openhab:~ $ sudo nano /etc/dhcpcd.conf
  GNU nano 2.2.6                    Datei: /etc/dhcpcd.conf

#option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
nohook lookup-hostname


interface wlan0

static ip_address=192.168.1.9
static routers=192.168.1.1
static domain_name_servers=192.168.1.1
 
Reply
#7
@shanoviachan
Maybe there is some help for you:

https://forum.pilight.org/Thread-pilight...Networking
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight-control modify values coolinx 16 267 11-13-2019, 08:02 PM
Last Post: curlymo
  Bug: double free or corruption in pilight-send blackzombie 12 304 10-07-2019, 08:15 PM
Last Post: blackzombie
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 190 08-13-2019, 05:43 PM
Last Post: curlymo
  pilight Nano USB interface curlymo 228 100,251 07-10-2019, 06:14 PM
Last Post: curlymo
  problems compiling pilight on Odroid C2 WitchDoctor 101 10,866 03-14-2019, 09:01 PM
Last Post: curlymo
  pilight 8 what chages for custom protocols? polo 11 3,151 02-15-2019, 06:22 PM
Last Post: polo
  pilight-debug shows nothing minhdomanh 3 608 10-18-2018, 07:01 AM
Last Post: felfert
  pilight-send and pilight-daemon DieterK 0 610 06-20-2018, 12:44 AM
Last Post: DieterK
  Lights not switched on or off by rules in pilight 8.1.0 rorie 22 2,753 06-12-2018, 03:56 PM
Last Post: curlymo
  check API in pilight 8 stratege-0815 4 1,497 02-11-2018, 09:34 AM
Last Post: stratege-0815

Forum Jump:


Browsing: 1 Guest(s)