• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help needed, webgui not loading -Solved-
#1
I updated fro v3 to v5 and the webgui is not loading anymore. I have the same config file. I have tried IE, Chrome, Safari and cleared all caches. IE is showing that "this page cannot be displayed" and Chrome gives an error "ERR_CONNECTION_REFUSED".

I read the blogpost from the frontpage "Configuring the web interface" and checked that everything is the same.

pilight-daemon -D is not showing anything when the browser is trying to connect the webserver. Android apps AndPiLi and Illumina are working ok.

I don't now what to do, please help?
 
Reply
#2
I assume you used the right port like "http://192.168.1.24:5001/" ?
 
Reply
#3
Yes, I'm usng the right port. In settings webserver at port 5001.

When I try to connect port 5000(pilight-daemon). In Chrome I get blank page but in IE I get big pilight logo and link that the pilight webgui is located at "http://192.168.0.121:5001". When I click the link I get same error as I described in my first post.
 
Reply
#4
try removing de default webroot en reinstall pilight so it gets reinstalled. Otherwise rethink to reinstall OS and pilght. Maybe try new sd card to test it out.

Send from tapatalk phone...
 
Reply
#5
Yesterday I tried removing and reinstalling pilight. No help.

I will try reinstalling the OS and pilight.
 
Reply
#6
oke good luck. Lett us know what the results are.
Also take a look at faq for firewall settings! (you had a connection refused error)

Send from tapatalk phone...
 
Reply
#7
Did you check the /etc/pilight/settings.json for a valid config file ?
 
Reply
#8
Yes, I believe it's valid because illumina and AndPili are showing all the switches and all of them are working OK.

I did not try reinstalling the OS again. But I Trier removing pilight and then updating and upgrading the OS. After that installed pilight again. This did not help. I will reinstall the OS again some day next week and report back.
 
Reply
#9
Can you please post your settings.json file ?
Do you have the loopback adapter (127.0.0.0) defined in your network settings ?
Do you have any restrictions in your firewall settings with regard to the pilight webserver addresses used ?
 
Reply
#10
Here is my settings.json
Code:
{
        "port": 5000,
        "log-level": 4,
        "pid-file": "/var/run/pilight.pid",
        "config-file": "/etc/pilight/config.json",
        "hardware-file": "/etc/pilight/hardware.json",
        "log-file": "/var/log/pilight.log",
        "send-repeats": 10,
        "receive-repeats": 1,
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight",
        "webserver-port": 5001,
    "webgui-template": "default",
        "webserver-cache": 1,
        "whitelist": "",
        "update-check": 1,
    
}

I have the "iface lo inet loopback" in my /etc/network/interfaces. Are you referring to that?

I have opened ports 5000 & 5001 on my firewall. So I can connect the pilight from outside of my house. Illumina & AndPiLi are working ok outside my house. These settings are the same as before I updated from v3 to v5.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  WebGUI emtpy since 8.0.8 Dergo 14 2,136 02-24-2018, 01:09 PM
Last Post: Dergo
  CONTACT devices | Webgui wupperpi 2 647 01-18-2018, 03:37 PM
Last Post: wupperpi
  [Solved] No ssdp connection found Hexcode 145 142,760 12-23-2017, 02:10 PM
Last Post: HuberDe
  [solved] Webgui 404-Error PT-Biker 2 892 11-11-2017, 09:49 AM
Last Post: PT-Biker
  [solved] Hardware not compatible ccc.ggg73 1 1,391 06-10-2017, 09:10 AM
Last Post: curlymo
  [Solved] pilight ssdp celle 6 7,918 02-23-2017, 03:22 PM
Last Post: gneandr
  [solved] No signal with raw data andies 6 2,828 12-25-2016, 09:11 AM
Last Post: andies
  pilight doesn't show the right status in webgui jurkla 8 2,377 11-17-2016, 09:41 AM
Last Post: gregnau
  pilight WebGui not working after reboot Frank_a 7 4,523 02-04-2016, 09:11 AM
Last Post: wo_rasp
Question [SOLVED]pilight-daemon: ERROR: config is not in a valid json format herrmeier 4 7,105 11-28-2015, 11:28 PM
Last Post: herrmeier

Forum Jump:


Browsing: 1 Guest(s)