• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
radxa support
#1
Question 
Hi!

I tested pilight the last 2 weeks and like it very much!
Easy configuration, does most time what it should, easy intrgration into my python files, ...

But i am not very happy with the performance of the Raspberry PI.

Would it be very difficult to get pilight running on a Radxa Rock Board with linaro 14?
There is a software existing, called pyRock to manage the GPIOs and
it would be much faster.
Radxa Rock has everything on board what is needed.
(Wlan, RTC, GPIO, bluetooth, ...)
Only the onboard 433Mhz RF link is missing (like RPi) ;-)

best regards
Manfred
 
Reply
#2
You can asked them to create a wiringx module. Then pilight will have support as well and other projects can have native multiplatform support also.
 
Reply
#3
Thank you for this information.

Unfortunately is my knowledge about how this works not the best.
Do you mean something like this https://github.com/radxa/pyRock ?

Or am i completely wrong?

Maybe you can give me some example code, so i can try it myselve?

best regards
Manfred
 
Reply
#4
Can you post the output of:
Code:
cat /proc/cpuinfo
 
Reply
#5
Code:
rock@radxa:~$ cat /proc/cpuinfo
Processor    : ARMv7 Processor rev 0 (v7l)
processor    : 0
BogoMIPS    : 3214.95

processor    : 1
BogoMIPS    : 3214.95

processor    : 2
BogoMIPS    : 3214.95

processor    : 3
BogoMIPS    : 3214.95

Features    : swp half thumb fastmult vfp edsp neon vfpv3
CPU implementer    : 0x41
CPU architecture: 7
CPU variant    : 0x3
CPU part    : 0xc09
CPU revision    : 0

Hardware    : RK30board
Revision    : 0000
Serial        : 0000000000000000

If neded here are some Informations about the GPIOs from the Radxa Board:
http://radxa.com/Rock/extension_header#O...ion_header
 
Reply
#6
Can you test the examples from the wiringX library as found here: https://github.com/pilight/wiringX

Do make sure you change the pin numbers in each source to something that is supported by the radxa. For both read and interrupt you need a jumper between the two different pins as you define them in the source, for blink, you need a LED connected to the defined pin.
 
Reply
#7
I tested all GPIO ports of the Radxa with on, off and blinking.

Here the result:
the green ones work, the red do not

see attachment


Attached Files
.pdf   GPIO-Radxa.pdf (Size: 26.99 KB / Downloads: 14)
 
Reply
#8
I've added the Radxa module to pilight. Can you test sending. Receiving probably won't work due to the interrupt issue.
 
Reply
#9
Hi!

I got help because of the trigger problem "both" on the Radxa Board.
A new kernel has to be flashed.

Quote:the interrupt trigger "both" is supported in the mainline kernel, you should try it if you need this trigger.

http://wiki.radxa.com/Rock/Linux_Mainline

I will give this a try next week.
 
Reply
#10
Hi!

I have some troubles building an boot image from mainline-kernel 3.17 (still not done).

Unfortunately i crashed my radxa-system while trying so and had to flash the system image new.

After this i installed wiringX from github without problems and installed pilight with apt-get.
This all worked without error messages.

But now as soon as the pilight service gets started all 4 cpu cores rise up to 100% and stay there. The system freezes and the web-gui also wont work.

If i am fast enough to stop the service before the system freezes i can work with the system normally.

Any idea why this is so?

pilight.log does not show an error:
Code:
[Nov 04 15:40:40:363785] pilight-daemon: INFO: version 5.0, commit v5.0
[Nov 04 15:40:40:458682] pilight-daemon: NOTICE: no pilight daemon found, daemonizing
[Nov 04 15:40:40:460375] pilight-daemon: INFO: daemon listening to port: 46329
[Nov 04 15:40:40:462081] pilight-daemon: INFO: daemon started with pid: 1833
[Nov 04 15:40:40:464827] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 45888
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Windows Support curlymo 35 18,476 06-10-2018, 04:40 PM
Last Post: Leo
  Odroid C2 support on Kernel 4.14 Jojo 5 667 06-01-2018, 03:19 PM
Last Post: curlymo
  Mac OS X support andies 4 1,937 12-01-2016, 09:48 PM
Last Post: andies
  Odroid-C1 support terrar 51 20,355 05-31-2016, 11:08 AM
Last Post: Jojo
  Ububtu 14.4 64 bit support terrar 30 12,217 05-09-2015, 11:40 PM
Last Post: curlymo
  [Solved] Disabled PHP support error lvdp 4 5,451 02-18-2014, 12:02 AM
Last Post: meloen
  Node support changed? koffie 19 9,189 01-12-2014, 05:44 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)