• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


OpenWeatherMap
#21
Fixed. I gave you write access to the pilight repo so you can these small fixes yourself. Keep using PR's for bigger additions.
 
Reply
#22
Please post in the pilight 7.0 or pilight nightly thread:
http://forum.pilight.org/Thread-v7-0-v-E...st-nightly

I'm also no fortune teller you need to give some additional information for me to know what's going wrong.
 
Reply
#23
@pilino1234
@temp

I moved here from thread: [Questions]Some issues with configuration

More and more strange, today sunrise and sunset are again more or less correct (sunday 14.06 they were 3.31 and 19.16) but now the temperature is incorrect.
Code:
Bellinzona, Switzerland
+----------+-----------+----------------+
|   Data   |  pilight  | openweathermap |
+----------+-----------+----------------+
| Temp     | 23.0      | 26.9           |
| Humidity | 53        | 53             |
| Sunrise  | 5.31      | 5:33           |
| Sunset   | 21.18     | 21:19          |
+----------+-----------+----------------+
 
Reply
#24
I have found the answer about the discrepancy between API and website.
I asked the question directly to OpenWeatherMap and this is the answer:

Quote:The information is updated faster on our web site. The API can be cached (on the server side) for about 3 hours during peak load times (and the load is almost always very high as there are too many free users now). Please consider upgrading to a developer subscription in case you need reliable access to up-to-date weather information. We can’t afford offering too high quality for free nowadays. Sorry for inconvenience and thank you for reporting.
 
Reply
#25
How should i enter "Den Haag" in the config? I mean with space, or maybe with other char?
Seems like whenever i enter a city name without space in the name, it's just works.
But not for "den haag" or "den_haag" or "denhaag".
 
Reply
#26
@gregnau
I suppose you mean The Hague in the Netherlands.
Simply enter haag (lowercase) without Den, should work.

[Image: Duck_Emoticon_by_ceethree.gif]
 
Reply
#27
(07-07-2015, 04:41 PM)troccolo Wrote: @gregnau
I suppose you mean The Hague in the Netherlands.
Simply enter haag (lowercase) without Den, should work.

[Image: Duck_Emoticon_by_ceethree.gif]

It's working like that, thanks!
 
Reply
#28
Hi all,

I am currently having issues configuring the look of my openweathermap device. I am running pilight v7.0

Following configuration is working in the devices section:
Code:
"weather": {
          "protocol": [ "openweathermap" ],
          "id": [{
                    "location": "berlin",
                    "country": "de"
           }],
           "humidity": 41.00,
           "temperature": 25.24,
           "sunrise": 5.33,
           "sunset": 21.18,
           "sun": "rise",
           "update": 0
}


I am trying to hide some parameters from being displayed in the GUI. And according to this page this should work:
Code:
"weather": {
          "protocol": [ "openweathermap" ],
          "id": [{
                    "location": "berlin",
                    "country": "de"
           }],
           "humidity": 41.00,
           "temperature": 25.24,
           "sunrise": 5.33,
           "sunset": 21.18,
           "sun": "rise",
           "update": 0,
           "gui-show-humidity": 0
}

Unfortunately is is not working and I am getting a config validation error.

Does anyone experience the same? Any solution?
 
Reply
#29
Wrong place für configuring GUI-Elements:

Code:
"gui": {
    "weather": {
        "name": "Temperature",
        "group": [ "Outside" ],
        "media": [ "all" ],              
        "show-humidity": 0
    }
}
 
Reply
#30
Hi Alex,

thanks for your response. With the correct syntax in the right section it is working. I am pretty new in this project but I think now I understand how the syntax works.
 
Reply
  


Forum Jump:


Browsing: 2 Guest(s)