• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Datetime
#11
That explains a lot, so I removed the quotes and is starts. Unfortunatly shortly after starting it segfaults.
I've attached the strace (in a zip otherwise it was too big) for your information. I hope you can help out.
For your info I used today's nightly.

Best regards and Merry Christmas,

Netopyr


Attached Files
.zip   strace.zip (Size: 35.5 KB / Downloads: 5)
 
Reply
#12
Can you post gdb output?
 
Reply
#13
CurlyMo, Thnx, please find it attached.

Best regards,

Netopyr


Attached Files
.txt   gdb.txt (Size: 970 bytes / Downloads: 9)
 
Reply
#14
Please post the debug log as described on the pilight mainpage.
 
Reply
#15
Offcourse... why else would you've written it down Angel
Here you go...
Code:
(gdb) backtrace
#0  0x00000000 in ?? ()
#1  0xb6c896a8 in programParse () from /usr/local/lib/pilight/protocols/program.so
#2  0xb6e31bfc in start_thread () from /lib/arm-linux-gnueabihf/libpthread.so.0
#3  0xb6d8f968 in ?? () from /lib/arm-linux-gnueabihf/libc.so.6
#4  0xb6d8f968 in ?? () from /lib/arm-linux-gnueabihf/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb)

Regards,

Netopyr
 
Reply
#16
Did the frame 1 command show anymore info?
 
Reply
#17
Hey, I have updated pilight to newest version last night:
Code:
pilight-daemon version 5.0, commit v5.0-135-g9247a0e
I've updated pilight-protocol-datetime as well, but now I am unable to start the pilight service:
Code:
root@homepi:/etc/pilight# service pilight start
[....] Starting : pilight[Dec 26 15:33:28:866146] pilight-daemon: ERROR: config device setting #2 "id" of "zeitdatum", invalid
failed!
The config setting is:
Code:
"zeitdatum": {
                        "protocol": [ "datetime" ],
                        "id": [{
                                "longtitude": "8.53031",
                                "latitude": "50.15403",
                                "ntpserver": "0.europe.pool.ntp.org"
                        }],
                        "year": 2014,
                        "second": 54,
                        "minute": 33,
                        "hour": 23,
                        "day": 23,
                        "month": 12
                },
which I did not change. Am I missing something? Or has the protocol changed?
 
Reply
#18
I think you forgot the second-level-indented heading, as well as a name for the device in the GUI. Right now it looks like "zeitdatum" (at the very top) is your room identifier, but you also need to define a name for the room, as well as a device identifier and name, like shown in the wiki.

Here is my quick fix, with some suggestions as for room and device identifier etc. Should work, did not test with pilight, but JSONLint says its good Wink
Code:
--------"RoomName": {
                "name": "Room Name",
                "zeitdatum": {
                        "name": "Zeit & Datum",
                        "protocol": [ "datetime" ],
                        "id": [{
                                "longtitude": "8.53031",
                                "latitude": "50.15403",
                                "ntpserver": "0.europe.pool.ntp.org"
                        }],
                        "year": 2014,
                        "second": 54,
                        "minute": 33,
                        "hour": 23,
                        "day": 23,
                        "month": 12
                }
        }
Remove the dashes in the beginning, they are only there to get the indent formatting right Smile you can replace them with a tab afterwards.

Add necessary commas by either of the last two curly braces if needed to add further devices or rooms below Smile
 
Reply
#19
(12-26-2014, 06:18 PM)pilino1234 Wrote: I think you forgot the second-level-indented heading, as well as a name for the device in the GUI. Right now it looks like "zeitdatum" (at the very top) is your room identifier, but you also need to define a name for the room, as well as a device identifier and name, like shown in the wiki.

Here is my quick fix, with some suggestions as for room and device identifier etc. Should work, did not test with pilight, but JSONLint says its good Wink
Code:
--------"RoomName": {
                "name": "Room Name",
                "zeitdatum": {
                        "name": "Zeit & Datum",
                        "protocol": [ "datetime" ],
                        "id": [{
                                "longtitude": "8.53031",
                                "latitude": "50.15403",
                                "ntpserver": "0.europe.pool.ntp.org"
                        }],
                        "year": 2014,
                        "second": 54,
                        "minute": 33,
                        "hour": 23,
                        "day": 23,
                        "month": 12
                }
        }
Remove the dashes in the beginning, they are only there to get the indent formatting right Smile you can replace them with a tab afterwards.

Add necessary commas by either of the last two curly braces if needed to add further devices or rooms below Smile
Thank you, but the thing is, I am using the nightly build and the config.json is a bit different - the sections are devices, rules and gui. This is the device setting ..
I will check the indent.. thanks though Smile
 
Reply
#20
I reinstalled today, and I also have the problem with ID 2.... I'm also using the nightly...
 
Reply
  


Forum Jump:


Browsing: 1 Guest(s)