• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Datetime
#31
(12-27-2014, 04:32 AM)diman87 Wrote: Try backing up /usr/local/lib/pilight/protocols/datetime.so and removing it. Worked for me, please test for you and report if working.


There is no protocols dir with my nightly....


Remove the "" at the numbers ( leave them at the long en lat words....)

Thats worked for me!!!
 
Reply
#32
Wink 
(12-27-2014, 10:22 AM)terrar Wrote: Set the ID as number (removing the "") worked for me.

Thats also worked for me Cool
 
Reply
#33
After removal of the protocols it does not longer segfaults but ofcourse this prevents a lot of my events from working.

fvandenreek, After I removed the quotes pilight started to segfault here. I am using a plain raspbian dedicated for pilight which is up to date. Also after the today's update I still got the same if the datetime and program protocols are in my config.json it segfaults immidiatly after start. I don't need to remove them completely only a config removal is enough.
 
Reply
#34
@diman87, i was saying that this thread was opened right before you guys starting to ask the same questions Wink
 
Reply
#35
@Netopyr, this line tells us you are indeed using an older version of the datetime protocols:
Code:
#1  0xb6c89658 in datetimeParse () from /usr/local/lib/pilight/protocols/datetime.so
 
Reply
#36
Well, the spelling matters - I was searching the forum for "datetime" and found only this thread Smile But after I've sorted this out on my Pi I was browsing the forum and found it .. yeah .. ^^
 
Reply
#37
Ok, you're right. Didn't see that that user didn't spell Datetime right Smile
 
Reply
#38
Sorry for the typing error guys Confused

@CurlyMo

Code:
The following NEW packages will be installed:
  pilight-protocol-datetime
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.5 kB of archives.
After this operation, 33.8 kB of additional disk space will be used.
Get:1 http://apt.pilight.org/ nightly/main pilight-protocol-datetime armhf 1.3 [16.5 kB]
Fetched 16.5 kB in 0s (150 kB/s)              
Selecting previously unselected package pilight-protocol-datetime.
(Reading database ... 76780 files and directories currently installed.)
Unpacking pilight-protocol-datetime (from .../pilight-protocol-datetime_1.3_armhf.deb) ...
Setting up pilight-protocol-datetime (1.3) ...

My version of pilight is pilight_5.0.140-gc3079a9_armhf.deb


This all gives me this:
Code:
(gdb) backtrace
#0  0x00000000 in ?? ()
#1  0xb6c7c658 in datetimeParse () from /usr/local/lib/pilight/protocols/datetime.so
#2  0xb6e2fbfc in start_thread () from /lib/arm-linux-gnueabihf/libpthread.so.0
#3  0xb6d8d968 in ?? () from /lib/arm-linux-gnueabihf/libc.so.6
#4  0xb6d8d968 in ?? () from /lib/arm-linux-gnueabihf/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb)

Which versions do I need to get it working?
 
Reply
#39
The one included in the nightly.
 
Reply
#40
I have just started working with rules.
It is working fine, but in my case I want to switch devices on and off at times that depend on the day of the week. E.g. switch devices off at a later time during the weekend than during working days.

Would it be possible to add a "weekday" property to the Datetime protocol?
 
Reply
  


Forum Jump:


Browsing: 1 Guest(s)