• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
new install fails - dev/nightly
#1
To update my RPI/pilight installation I tried to use a brand new SDCard, installed following the pilight instructions on http://www.pilight.org/getting-started/installation/

At #9 it failed with this
Code:
root@raspberrypi:/home/pi# apt-get install pilight
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
pilight : Hängt ab von: libunwind8 ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
root@raspberrypi:/home/pi

Hope for help ..
 
Reply
#2
Please search topic was discussed here several times it's also in the FAQ.
Install the library
 
Reply
#3
Sorry, no sucess!

And yes the FAQ describes a search for it (which shows noting on the new installed RPI) and asks to install .. I did with this result:
Code:
pi@raspberrypi ~ $ sudo apt-get install libunwind-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
E: Paket libunwind-dev kann nicht gefunden werden.
pi@raspberrypi ~ $ sudo apt-get install libunwind
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.        
Statusinformationen werden eingelesen.... Fertig
Paket libunwind ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Für Paket »libunwind« existiert kein Installationskandidat.

Also any further search on the net doesn't give an idea how to solve this.
I need to pilight nightly because I've to use the new JSON structure!

Hope for more help.



Note: To be sure to have the lastest pilight stuff I did a new install right now, but with the same message about missing libunwind8
And here is the used /etc/apt/sources.list

Quote:deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://mirror.ox.ac.uk/sites/archive.ras.../raspbian/ wheezy main contrib n$
#deb http://apt.pilight.org/ development main
deb http://apt.pilight.org/ nightly main

EDIT: Just found:
https://bugs.launchpad.net/raspbian/+bug/1403245
but it seems not being solved ??
 
Reply
#4
Please read this:

http://www.pilight.org/nightly/

Quote:Please be aware that libunwind isn't available on Debian Wheezy. If you install the latest nightlies on these version, make sure you also enable the pilight stable apt repository.

Modbreak, i've make the important part even more clear then it already is Wink
 
Reply
#5
Maybe this could help ... but my understanding how to "configure" and get it running for an installation is too limited. Any further help?

Code:
https://github.com/rpi-openwrt/rpi-packages/blob/master/libs/libunwind/Makefile

@terrar
Thanks! Yes, the addition of the "stable" did the job! That easy Surprised

@curlymo .. and ...
But a general word: Also I'm aware running / installing nightly has some risks, I would applause for a better docu/communication of pilight. Not it's not there, but it's hard to follow the updates. So a push to registrated users/testers .. or page "Change log" or similar would be very helpful here!

I just didn't recognized the "Nightly" page got changes on Jan.16th (which also described the solution with the libunwind).

The notification for new forum postings only works every now and them ONLY! (I'm on web.de right now, maybe other services do better .. for that I'll switch to gmail, will see).

Günter

PS: And yes pilight is running on the new card now! And waits for some more steps with piScheduler
Wink

On http://www.pilight.org/getting-started/i...stable_apt
the following ....
Quote:If you want to use the developmental or nightly repository you can just follow all steps, but except just adding the stable repository in the /etc/apt/sources.list you add:
1 deb http://apt.pilight.org/ development main
2 deb http://apt.pilight.org/ nightly main

should be changed ....
Quote:If you want to use the developmental or nightly repository you can just follow all steps, but
you need to have in the /etc/apt/sources.list all these lines:
1 deb http://apt.pilight.org/ stable main
2 deb http://apt.pilight.org/ development main
3 deb http://apt.pilight.org/ nightly main

(are both lines 2 and 3 required to run "nightly"?) or is that alternatively .. not clear (for me) from the current wording!
 
Reply
#6
@curlymo:

Can you please add a hint for installing libpcap-dev to the needed packages here:
http://www.pilight.org/get-started/installation/

This is only listed in the nightly section and also needed for manually compiling the dev version.
Terrarium:  RPi Model B Rev 2 / pilight 8.1.2 / stretch
Aquarium: RPi Model B Plus Rev 1.2 / pilight 8.0.6 / jessie
 
Reply
#7
I tried to do a fresh installation of raspbian and the development version of pilight. Exactly following the wiki/manual, I added the stable, development and nightly repositories to /etc/apt/sources.list:
Code:
deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ wheezy main contrib non-free rpi
deb http://apt.pilight.org/ stable main
deb http://apt.pilight.org/ development main
deb http://apt.pilight.org/ nightly main

But when I do apt-get update, I get this error:

Code:
Fout http://apt.pilight.org development/main armhf Packages
  404  Not Found

Looking at apt.pilight.org/dists, I only see the /stable and /nightly, folders so /development isn't there indeed.

When I try to build pilight, I get the famous libunwind-dev not found error. I assume that is because the development repository wasn't found?

Did something change that I missed?
 
Reply
#8
When there are no development packages, development is not there. That's currently the case.
 
Reply
#9
Is there another way to get libunwind-dev on my system?

edit: managed to install libunwind-dev via
Code:
apt-get install libunwind*
 
Reply
#10
What repo did that libunwind-dev come from that you installed? Just curious Smile
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight fails starting on boot Alex 5 467 06-09-2019, 06:02 PM
Last Post: curlymo
  Compile with Optimization fails / timedate missing fourty2 6 338 04-29-2019, 12:27 PM
Last Post: fourty2
  hardware module issues in nightly apartmedia 17 853 04-05-2019, 06:59 PM
Last Post: curlymo
  Update to v8.0.10-nightly-a1279212 Ulrich.Arnold 3 1,094 06-04-2018, 08:31 PM
Last Post: curlymo
  apt pilight org INSTALL.md outdated sirtet 4 663 03-26-2018, 08:00 PM
Last Post: sirtet
  Updates for nightly Ulrich.Arnold 1 480 01-26-2018, 07:31 PM
Last Post: curlymo
  [solved] First install of pilight Zentia 19 7,535 11-07-2017, 08:01 AM
Last Post: Zentia
  receiver only collects on first install Thuurke 4 916 09-04-2017, 06:53 PM
Last Post: curlymo
  rule fails with ping state pinu 1 888 06-09-2017, 10:14 AM
Last Post: Niek
  Pizero install buldogwtf 0 727 08-14-2016, 07:50 PM
Last Post: buldogwtf

Forum Jump:


Browsing: 1 Guest(s)