• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
piScheduler -- A pilight extension for the daily switch plan

piSchedule correctly determines area but not the village within the area. As a result sunset/sunrise are a +/-5min off.

I tried changing piSchedule.prefs.json:
- corrected name of village
- corrected long/lat
- corrected sunrise/sunset time

After restarting piSchedule sunrrise/sunset have reverted back to the original values. Name and lat/long still are my corrected values though.

Any way to correct this permanently?

At the moment the location data is retrieved each time you update for the schedule file.
As an alternative the service could be disabled once the location was found. And would be retrieved only after a restart.
Maybe for the next version.
(Q: Is 5min +/- that important here with switching light?)
Ok, solved, other site (http://wap.pet-grub.com/sunrise_sunset/city/nlvsm) calculates sunrise/sunset differently than piScheduler.
Hi all,

Having trouble starting piSchedule.
[....] Starting system piSchedule daemon:Starting /home/pi/piSchedule7/piSchedule.py...
Detaching to start /home/pi/piSchedule7/piSchedule.py...done.
. ok
[ ok ] /home/pi/piSchedule7/piSchedule.py is running.
Traceback (most recent call last):
  File "/home/pi/piSchedule7/piPrefs.py", line 58, in main
    if fprefs['port'] == "":
TypeError: list indices must be integers, not str

What do I do?

Thanks, Don
not sure what causes the problem. Please re-do a new setup using the documentation page with link for "Setup" (I made some minor changes, hope it helps here also!)

The method for the geo-coordinates has been changed! I have added a method 'fix'. This have two advantages:
-- you can set the coordinates in the piSchedule.prefs.json
-- the coordinates are not retrieved from the online service, so it's faster

Please see the docu for details (same link as above, sorry the English docu isn't uptodate)
The new version runs on OSMC
But any attempt to add (add job) displays an error

Error: 500 Internal Server Error

Sorry, the requested URL '' Caused an error:

Internal Server Error
It could be also a problem with encoding.

Do you use pure ascii characters for the description of the "switches"? If not, for a test please change for that.
Example: "bathroom" would translate to --> "Łazienka", for that use "Lazienka"
(01-08-2016, 05:18 PM)gneandr Wrote: @kniazio
It could be also a problem with encoding.

Do you use pure ascii characters for the description of the "switches"? If not, for a test please change for that.
Example: "bathroom" would translate to --> "Łazienka", for that use "Lazienka"

There was only one entry "Łukasz" and that in the gui
I changed to Lukasz but it did not help.
I noticed that the file piSchedule.prefs.json is my location "Biłgoraj" but changed to "Bi \ u0142goraj"

{"piScheduleHome": "/root/piSchedule73", "pilightVersion": "7.0", "locale": "EN", "pilightPort": 5001, "switchTime": 0, "port": 5005, "sunrise": "2016-01-08 07:28:36", "piScheduleDoc": "piSchedule7", "iniFile": "piSchedule.ini", "version": "", "location": "Bi\u0142goraj", "latitude": "50.55", "pilightExpected": "7.0", "status": 0, "locationDefault": "Kassel", "newsDate": "2016-01-07", "geo": "ip", "longitude": "22.7", "server": "", "sunset": "2016-01-08 15:42:45", "weekSchedule": {"Monday": "kniazio.ini", "Tuesday": "--", "Friday": "--", "Wednesday": "--", "Thursday": "--", "Sunday": "--", "Saturday": "--"}, "piDBox": "dl.dropboxusercontent.com/u/35444930/"}
Would be great to get a all log files which are written with the /edit?addJob call.
See ../piSchedule73/logs/*.
Please send a PN message.
Hi gneandr, thx for the geo changes, sorry for not responding sooner. I think just one thread for all the posts on piSchedule is a bit confusing. Quite a few different things intersperse. It should be a seperate forum under addons if you ask me.

Anyway, the problem that was first reported on 7/22/2014 about send command not working hits me as well. I cannot be 100% sure but I think it started happening after I upgraded pilight to the development edition for some reason (i cannot remember why right now). Puzzled me for a long time. I saw the commands being fired in the logs but nothing happening. Then started to issue the piSchedule commands directly from the browser{%22actio...2:%22on%22}}
resulting in {"message":"failed"}.

And as also described, this works just fine.

The response from curlymo around that date is: fixed in 5.0.

If I read well it has something todo with authorizations. Can you enlighten me what auth settings I need to change?

Thanks a bunch!

Possibly Related Threads...
Thread Author Replies Views Last Post
  Connect pilight to your hue bridge hannemann 4 3,612 10-26-2020, 02:08 PM
Last Post: Michelebup
  Does piSchedule work with pilight 8.1.1-nightly Peter S 0 2,181 06-29-2018, 07:57 PM
Last Post: Peter S
  pilight-console - an LCD / keypad interface for pilight frenchie71 3 2,058 11-21-2017, 11:15 PM
Last Post: curlymo
Wink PHP class using pilight socket connection Dan 0 1,904 11-03-2016, 11:41 AM
Last Post: Dan
  Controlling a RGB Led Strip over pilight mightyuhu 2 3,029 08-06-2016, 09:10 PM
Last Post: JohannK
  HomeBridge with pilight on raspbian Jurre 10 14,563 04-06-2016, 07:45 AM
Last Post: tomtom
  pilight voice commands kniazio 11 7,701 01-29-2016, 07:51 PM
Last Post: sral
  Python Ping pilight detect mobilephone Cryptomaster 0 2,600 01-10-2016, 04:17 PM
Last Post: Cryptomaster
  pilight config editor ktams 16 10,301 01-06-2016, 02:42 PM
Last Post: ktams
  command processing between pilight and openhab royhofman1989 3 3,413 07-13-2015, 11:26 AM
Last Post: curlymo

Forum Jump:

Browsing: 2 Guest(s)