• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Web GUI working, pilight-send not for elro_he
Hi guys,

I'm using pilight to switch my lights which are connected with 433 MHz devices. I found the protocols, ids, units and systemcodes using pilight-receive. All devices are working if I switch them in the web GUI. But the devices using the elro_he protocol are not working if I use pilight-send on the command line. One example:

"lichtfenster": {
        "name": "Licht Fenster",
        "protocol": [ "elro_he" ],
        "id": [{
                "systemcode": 15,
                "unitcode": 1
        "state": "on"

The equivalent pilight-send command should be:

pilight-send -p elro_he -s 15 -u 1 -t

But the pilight-send command is not working. Nothing happens, doesn't matter if I try to switch it on (-t) or off (-f). There is no error thrown, the command just silently runs and does nothing. I have another device which uses the kaku_switch_old protocol, and this works using pilight-send.

Do I need to use another protocol? Is there another needed option for the pilight-send command?
Can you try the latest nightly version?
I tried the nightly and it works when I use the elro_he_switch protocol. I think I'll give the nightly a shot because eventing seems to be a useful feature. It just seemed a bit buggy, I had some troubles saving the config. It was twice reset back to the nearly empty default when I started the pilight service. Maybe it's not buggy and I just fucked it up. But if I downgrade back to stable, is there a way to use the new elro_he_switch protocol with the stable version?
No, the nightly is consider far more stable then the current stable. Ironic right Wink
At least that ELRO devices seem to be some quiet nasty stuff. I have one device which I switched on and off using elro_he, systemcode 15, unitcode 2. For the nightly I changed elro_he to elro_he_switch. Now I only could switch this device on, but not off. Switch it off just worked when I used unitcode 0 instead of 2. But unitcode 0 could not switch it on. So I would need unitcode 2 for on, and 0 for off. The other two devices from the triple set of those nasty ELROs work fine, one with unitcode 1, and the other with unitcode 4. I couldn't believe that and after some experimenting and changing the unitcode between 2 and 0 for the faulty device it suddenly just worked again with unitcode 2 - on and off.
I also tried the other protocols and codes which were printed by pilight-receive when switching the device with the hand-held transmitter, none worked. Just elro_he_switch does the job.

It feels a little bit like when I used Arch Linux for about 5 years: http://www.team-firestorm.net/intern/ima...tpilot.jpg

One thing that bugged me: The nightly configuration article (http://www.pilight.org/nightly/nightlyconfiguration/) looks like you just need one config.json, nothing else, because the hardware and settings section are included in the example. But without a settings.json file the service won't start because it wants a settings.json. I don't need a hardware.json, just the settings.json.

Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight bugs Ascenion 1 122 03-23-2020, 06:29 PM
Last Post: curlymo
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 1,200 12-21-2019, 09:46 AM
Last Post: curlymo
  pilight-control modify values coolinx 16 1,093 11-13-2019, 08:02 PM
Last Post: curlymo
  Bug: double free or corruption in pilight-send blackzombie 12 1,016 10-07-2019, 08:15 PM
Last Post: blackzombie
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 426 08-13-2019, 05:43 PM
Last Post: curlymo
  pilight Nano USB interface curlymo 228 112,034 07-10-2019, 06:14 PM
Last Post: curlymo
  problems compiling pilight on Odroid C2 WitchDoctor 101 15,481 03-14-2019, 09:01 PM
Last Post: curlymo
  Issue send actions over Socket API in AdHoc network ggtrts 10 1,531 03-13-2019, 06:32 AM
Last Post: curlymo
  Send pulsestream via API Phunkafizer 19 2,142 02-27-2019, 09:54 PM
Last Post: curlymo
  pilight 8 what chages for custom protocols? polo 11 4,049 02-15-2019, 06:22 PM
Last Post: polo

Forum Jump:

Browsing: 1 Guest(s)