• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
High cpu usage in 433gpio thread after rpi-update
#1
I did a clean Wheezy install on my Raspberry Pi with nothing but pilight installed. Everything was working fine.
After doing a system update using rip-update to the latest version, pilight starts, but after a few seconds the watchdog recognizes high cpu usage in 433gpio thread and kills the pilight daemon. This is reproducible at every new start of pilight.
The version i'm using is 5.0.

Anyone else having these issues?
 
Reply
#2
Yes, read this:
https://github.com/raspberrypi/linux/issues/653

It's also not recommended to use rpi-update.

This is fixed ages ago in the nightly version of pilight.
 
Reply
#3
Ok, i tried the nightly build and it works now. I like the rules engine!
 
Reply
#4
Can anybody tell me is it possible to downgrade the rpi to work with the current stable of pilight? I have the same problem with 100% cpu load after a rpi update
 
Reply
#5
Another solution would be to install the latest nightly.
 
Reply
#6
(02-07-2015, 07:12 PM)curlymo Wrote: Another solution would be to install the latest nightly.

Same problem with 100% CPU load here.
Upgraded Raspbian from build Dec24 2014 to newest updates (in preparation for SD-Card-transfer to new RaspberryPi 2).
pilight goes to 100% on start.

To upgrade from stable to nightly, can I just "apt-get update && upgrade" after adding these 2 sources
Code:
deb http://apt.pilight.org/ development main
deb http://apt.pilight.org/ nightly main

and after manually installing
Code:
libunwind8
libpcap0.8

Do I add both sources or just the nightly one.
Or can I have a 3 sources at the same time in my sources.list?

Heiko
 
Reply
#7
Angry

Hey Guys,

since yesterday I cant start pilight.
Even the new installation has brought no improvement.

What do I do?

Code:
[Feb 09 10:01:05:356041] pilight-daemon: ERROR: cpu usage way too high 96.116255
[Feb 09 10:01:05:356310] pilight-daemon: ERROR: checking again in 10 seconds
[Feb 09 10:01:16:358363] pilight-daemon: ERROR: ----- Thread Profiling -----
[Feb 09 10:01:16:358720] pilight-daemon: ERROR: - thread lirc: 0.008544%
[Feb 09 10:01:16:359014] pilight-daemon: ERROR: - thread socket: 0.010911%
[Feb 09 10:01:16:359292] pilight-daemon: ERROR: - thread ssdp: 0.000000%
[Feb 09 10:01:16:359550] pilight-daemon: ERROR: - thread sender: 0.000000%
[Feb 09 10:01:16:359806] pilight-daemon: ERROR: - thread broadcaster: 0.000000%
[Feb 09 10:01:16:360056] pilight-daemon: ERROR: - thread updater: 0.023037%
[Feb 09 10:01:16:360333] pilight-daemon: ERROR: - thread 433gpio: 94.781244%
[Feb 09 10:01:16:360737] pilight-daemon: ERROR: - thread receive parser: 0.005034%
[Feb 09 10:01:16:361038] pilight-daemon: ERROR: - thread webserver worker #0: 0.009467%
[Feb 09 10:01:17:312012] pilight-daemon: ERROR: - thread webserver client: 0.000000%
[Feb 09 10:01:17:312399] pilight-daemon: ERROR: - thread webserver broadcast: 0.000000%
[Feb 09 10:01:17:312663] pilight-daemon: ERROR: - thread firmware upgrader: 0.006055%
[Feb 09 10:01:17:312953] pilight-daemon: ERROR: ----- Thread Profiling -----
[Feb 09 10:01:17:313295] pilight-daemon: ERROR: cpu usage still way too high 94.881569%, exiting
 
Reply
#8
Do you use protocol "cpu_temp" (old: rpi_temp) in your config?
I also have some troubles with high cpu but after removing this protocol (who needs) the other protocols work fine.

If so please confirm my expectation about "cpu_temp" if it helps.
 
Reply
#9
(02-09-2015, 11:56 AM)terrar Wrote: Do you use protocol "cpu_temp" (old: rpi_temp) in your config?
I also have some troubles with high cpu but after removing this protocol (who needs) the other protocols work fine.

If so please confirm my expectation about "cpu_temp" if it helps.
How do you mean?
Where can I change this?

Regards,
n3ro
 
Reply
#10
If you show the CPU-Temp in your webgui you have integrated protocol "cpu_temp" in your config.json at "devices" and "gui".
For me it helped removing it and resign to "cpu_temp" in my config.
If you dont use this protocol in your config forget my post.
Then the error is anywhere other where i dont know.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 174 08-13-2019, 05:43 PM
Last Post: curlymo
  Increased CPU usage with version 8.1.5 wimThoelke 13 539 08-07-2019, 08:38 PM
Last Post: curlymo
  High cpu usage Dergo 1 306 02-23-2019, 04:31 PM
Last Post: curlymo
  Update to 8.1.3-18-gab88dcf3 Traeumer 10 1,384 11-01-2018, 10:42 PM
Last Post: Oliver
  Update Error latest Nightly Alex 13 4,162 09-11-2016, 02:51 PM
Last Post: Alex
  pilight Error : default_sa_restorer_v2 & CPU High Tommybear1979 5 2,597 06-30-2016, 07:36 AM
Last Post: pilino1234
Bug Bug report: gpio_switch does not accept high pin numbers woutput 2 2,408 10-12-2015, 03:54 PM
Last Post: woutput
Question pilight-send or pilight-control --> update config.json terrar 3 3,284 10-23-2014, 07:52 PM
Last Post: curlymo
  webgui/ssh very slow .. high cpu usage gneandr 1 2,453 10-01-2014, 06:43 PM
Last Post: creamers
  [Fixed] usage of log-level rien 3 3,684 05-15-2014, 02:52 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)