• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
High cpu usage in 433gpio thread after rpi-update
#31
(02-27-2015, 09:17 PM)Ikarisan Wrote: I was wondering if >20% CPU load are normal or not.
I had about 0.3% of CPU utilization with V5 - and similar utilization with V6. For me it looks uggly to have >20% CPU load.

Regarding the high CPU usage issue with V5 and the current kernel - I just upgraded to V6 and the current kernel 3.18.8+ - and the cpu usage is 0.3% again and pilight works like a charm now again.

Unfortunately I detected some switches I used before with V5 are no longer supported in V6 (ElroHome switches) Confused
 
Reply
#32
The protocols were renamed, check the wiki for the new names
 
Reply
#33
Thank you very much for pointing this out. I now tried the elro_400 and elro_800 protocols and still fail. Will investigate on this in more detail the next couple of days and create a new thread for this if needed.
 
Reply
#34
There is also an elro_300 protocol, and the 800 one is called elro_800_switch
Check the back of the remote for the type number
 
Reply
#35
I created a new thread for the elro issue because it's OT in this thread.
 
Reply
#36
I have also CPU usage 25-30% on an Raspery Pi 2.
- latest Kernel 3.18.11-v7+
- pilight 6.0 (latest)

I use only one entry to get the temp from alecto_ws1700 (Pearl Outdoor)

What does curlymo means with: "If you aren't using a filter yes."

This is my config:

Code:
{
        "devices": {
                "OutsideTemp1": {
                        "protocol": [ "alecto_ws1700" ],
                        "id": [{
                                "id": 1490
                        }],
                        "temperature": 17.0,
                        "humidity": 18.0,
                        "battery": 1
                }
        },
        "rules": {},
        "gui": {
                "OutsideTemp1": {
                        "name": "Weather Station 1",
                        "group": [ "Outside" ],
                        "media": [ "all" ]
                }
        },
        "settings": {
                "log-level": 4,
                "pid-file": "/var/run/pilight.pid",
                "log-file": "/var/log/pilight.log",
                "send-repeats": 1,
                "receive-repeats": 1,
                "webserver-enable": 1,
                "webserver-root": "/usr/local/share/pilight/",
                "webserver-port": 5001,
                "webserver-cache": 0,
                "firmware-update": 0
        },
        "hardware": {
                "433gpio": {
                        "sender": 0,
                        "receiver": 1
                }
        },
        "registry": {
                "pilight": {
                        "firmware": {
                                "version": 32768,
                                "lpf": 215170,
                                "hpf": 216510
                        },
                        "version": {
                                "current": "6.0"
                        }
                }
        }
 
Reply
#37
Welcome to the forums, thomas.cristo Smile
First of all, please format your post using code tags to make it more readable and read the rules you got in the PM.

What curlymo meant, is the Low-Pass Filter that has been developed here for filtering out noise that the receiver picks up, reducing the CPU load by the pilight-daemon
 
Reply
#38
Sorry, pilino1234, I don't understand what you mean. Can I something configure, to reduce the CPU load? Or I have to live with it?
Can I disable the filter to reduce the CPU load?
 
Reply
#39
The filter is an additional piece of hardware, an ATTiny chip that is programmed to remove weak signals. It is wired between the receiver and the Raspberry Pi GPIO pin. You can buy a kit from the pilight shop or build one yourself.

With the filter it reduces the CPU load, because the filter is external from the RPi Smile
 
Reply
#40
@pilino1234I took a look into the filter thread and is possible that could to be the problem. I was wondering, because framp wrote, that he had the same problem. But he updates the kernel to 3.18.8+ and the usage is 0.3%. @framp Or you use the hardware filter to?
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 133 08-13-2019, 05:43 PM
Last Post: curlymo
  Increased CPU usage with version 8.1.5 wimThoelke 13 408 08-07-2019, 08:38 PM
Last Post: curlymo
  High cpu usage Dergo 1 269 02-23-2019, 04:31 PM
Last Post: curlymo
  Update to 8.1.3-18-gab88dcf3 Traeumer 10 1,248 11-01-2018, 10:42 PM
Last Post: Oliver
  Update Error latest Nightly Alex 13 4,034 09-11-2016, 02:51 PM
Last Post: Alex
  pilight Error : default_sa_restorer_v2 & CPU High Tommybear1979 5 2,534 06-30-2016, 07:36 AM
Last Post: pilino1234
Bug Bug report: gpio_switch does not accept high pin numbers woutput 2 2,367 10-12-2015, 03:54 PM
Last Post: woutput
Question pilight-send or pilight-control --> update config.json terrar 3 3,233 10-23-2014, 07:52 PM
Last Post: curlymo
  webgui/ssh very slow .. high cpu usage gneandr 1 2,423 10-01-2014, 06:43 PM
Last Post: creamers
  [Fixed] usage of log-level rien 3 3,631 05-15-2014, 02:52 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)