• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight 6.0
#21
Ok, I changed it and after install I have no files in the protocols dir.
Maybe still the stable is running, how can I see which one runs?
I'm a Linuxnoob, sorry for that Angel
 
Reply
#22
That's why we created all documentation for you.
Frontpage FAQ point 1.
 
Reply
#23
@kilson
Please, use code tags.

Also, post the output of pilght-daemon -D
 
Reply
#24
@kilson

see post #13 / #14
 
Reply
#25
Hi all,

Installed pilight v6 stable with apt-get.

Everything worked fine. Had to change some PHP code in my own program's
Code:
"message": "identify"
should read:
Code:
"action": "identify"
and the reply from pilight-daemon is:
Code:
"status": "succes"

After changing some code to connect to the daemon everything worked fine (well, pilight itself is still running fine).

My PHP program's however are in a sudden stuck while reguesting the configuration.. (I do get the "succes" reply after identifying)
Code:
"action": "request config"
It worked before but now it hangs while waiting for data.

The only thing I changed on my RPI is that I have installed the "at" package..

I already --reinstalled pilight

This is the pilight.log:
Code:
[Feb 27 14:24:26:647704] pilight-daemon: INFO: version 6.0, commit v6.0
[Feb 27 14:24:26:740413] pilight-daemon: NOTICE: no pilight daemon found, daemonizing
[Feb 27 14:24:26:741538] pilight-daemon: INFO: daemon listening to port: 5055
[Feb 27 14:24:26:840956] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 35112
[Feb 27 14:24:26:967686] pilight-daemon: INFO: new client, ip: 10.0.0.155, port: 40683
[Feb 27 14:24:26:968159] pilight-daemon: INFO: new client, ip: 10.0.0.155, port: 40684
[Feb 27 14:24:27:883879] pilight-daemon: ERROR: cpu usage too high 72.610996%
[Feb 27 14:24:27:913283] pilight-daemon: ERROR: checking again in 10 seconds
[ Feb 27 14:24:33:59076] pilight-daemon: INFO: datetime 5.210610:52.345090 adjusted by -5 seconds
[  Feb 27 14:24:48:5356] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 35115
[Feb 27 14:25:44:866007] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 35116
[Feb 27 14:26:03:614694] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 35117

The "port" is set to "5055" (it worked with "5002" for some time but I changed it when it stopped working), but it seems pilight is using random ports when the client connects.

How can I figure out whats going wrong?
 
Reply
#26
Check the source for pilight-control for proper API syntax?
 
Reply
#27
Code:
root@raspberrypi:/home/pi# apt-get install pilight
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package pilight is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  pilight-webgui

I don't know what's better, laughing or crying? ...
 
Reply
#28
@curlymo
Quote:Check the source for pilight-control for proper API syntax?

Pretty sure the used syntax is the same as used by pilight-control.
I also do get the "status": "succes" reply after "identifying".
Then I do send the correct message "action": "request config" to pilight-daemon after which noting more happens.

Strange is that I setup the correct port (5055) and use that port. In the log the client gets connected by random ports (much higer range).

The greatest riddle is that is worked a few hours ago.

Also I now have the problem that I get every second a log entry
Code:
invalid ntp host
Never had that message before...

-------------------------------------
Ok solved (partial)
Code:
"ntpserver": "0.nl.pool.ntp.org"
The invalid ntp host takes so much time that pilight-daemon does not have time to serve other clients. I removed the datetime device and now the rest works (again). Still strange that a perfectly valid ntp host is not recognised by pilight...
 
Reply
#29
@TheWheel The defined port is the one your script connects to on the pilight-daemon, the high port that you see is where you are connecting from on the machine that the script is running on.
Also, as far as I remember socket programming, a server runs on a specified port, but when a client connects, that "conversation"/stream is moved to a different port (because there can only be one connection per port) so that new clients can still connect to the server.
For the invalid ntp host, I would assume that you have a datetime protocol in your config. Have you double-checked the address/ip of the ntp-server?

@dutchandre Post the contents of /etc/apt/sources.list and run sudo apt-get update
 
Reply
#30
(02-27-2015, 03:40 PM)pilino1234 Wrote: @TheWheel The defined port is the one your script connects to on the pilight-daemon, the high port that you see is where you are connecting from on the machine that the script is running on.
Yes, your correct. Now I have removed the datetime device I can see in the log that the client connects to a different port.
Quote:For the invalid ntp host, I would assume that you have a datetime protocol in your config. Have you double-checked the address/ip of the ntp-server?
The address of the ntp host is correct. Checkt a few others also but the problem is still there...

Thanks for your reply pilono1234!
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
Tongue pilight 8.1.5-1-gc0a175e0 Chrashes fleisch 4 143 08-17-2019, 01:04 PM
Last Post: curlymo
  pilight for Raspbian Buster (raspberry pi 4) ? starob 29 1,579 07-15-2019, 08:45 PM
Last Post: curlymo
  pilight-receive Filteroption not working Alex 2 357 07-14-2019, 08:35 AM
Last Post: Alex
  pilight usb nano format conversion ettman8 2 249 07-14-2019, 08:32 AM
Last Post: curlymo
  pilight 8.1.4 crashes after some hours Ulrich.Arnold 47 2,039 06-29-2019, 08:58 PM
Last Post: curlymo
  Raspberry PI, gpio-ir-tx and pilight not starting lordslash 5 554 06-11-2019, 05:19 PM
Last Post: curlymo
  pilight fails starting on boot Alex 5 481 06-09-2019, 06:02 PM
Last Post: curlymo
  Google Assistant coupled to pilight hansrijn2 4 928 05-29-2019, 06:54 PM
Last Post: curlymo
  pilight-send does not stop (terminate) va13 3 474 05-15-2019, 06:06 PM
Last Post: curlymo
  oom_reaper: reaped process pilight-daemon va13 4 538 05-15-2019, 08:03 AM
Last Post: va13

Forum Jump:


Browsing: 1 Guest(s)