• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight Nano USB interface
#41
i will try it tomorrow since the pi isn't easy to reach
 
Reply
#42
(04-02-2015, 08:12 PM)koos147 Wrote: ...
I also see some people that have a cheap usb device for about 3 euro
does someone have a link where i can get one of them?
ebay - google: ebay arduino nano
 
Reply
#43
(04-02-2015, 08:22 PM)curlymo Wrote: Can you check if it works when you flash it from your Pi?

I copied the hex file to my pi
Code:
pilight-flash -f /etc/pilight/pilight_usb_nano.hex
[Apr 03 16:40:17:286938] pilight-flash: ERROR: config hardware module #1 "433nano" does not exist


Code:
{
    "devices": {},
    "rules": {},
    "gui": {},
"settings": {
    "port": 5000,
    "standalone": 0,
    "log-level": 4,
    "pid-file": "/tmp/pilight.pid",
    "log-file": "/var/log/pilight.log",
    "send-repeats": 10,
    "receive-repeats": 1,
    "webserver-enable": 1,
    "webserver-root": "/usr/local/share/pilight/",
    "webserver-port": 5001,
    "webgui-template": "default",
    "webgui-websockets": 1,
    "webserver-cache": 1,
    "whitelist": "",
    "protocol-root": "/usr/local/lib/pilight/protocols",
    "hardware-root": "/usr/local/lib/pilight/hardware",
    "action-root": "/usr/local/lib/pilight/action",
    "operator-root": "/usr/local/lib/pilight/operator",
    "firmware-update": 1,

    "watchdog-enable": 1
},
    "hardware": {
                "433nano": {
            "comport": "/dev/ttyACM0"
        }    },
    "registry": {
        "pilight": {
            "version": {
                "current": "6.0"
            }
        }
    }
}
 
Reply
#44
Did you install the latest nightly?
 
Reply
#45
No i run a the stable version
how "stable" is the nightly?
can i just upgrade my stable to the nightly (and back is the nightly isn't working as expected?)
 
Reply
#46
Ofc
 
Reply
#47
I tried to get this working on a arduino uno (figured the nano was much like the uno, only ftdi chip for serial), but couldn't get it working.

I programmed the atmega328p on the arduino using a stk500 via ISP.
Installed the nightly of pilight on my linux server, connected the arduino uno via usb.

I connected both a 433mhz sender & receiver (I confirmed both to be working devices), I don't receive anything and I can't send anything aswell. I send switch commands from a pilight installation on a RPi, the switch turns on/off correctly but nothing is received by pilight-receive through the arduino uno.
Sending is nog working either, connected a led to pin D5 to see if it is doing anything, but nothing happens. I can see the Rx led light up on the arduino, so pilight is sending something, it just doesn't get processed or something.

I just flashed the arduino bootloader back on the chip and programmed it using the arduino protocol instead of using the stk500, but that didn't help either. Haven't really looked into your usb-nano code yet (no time Smile)
 
Reply
#48
hi,
after some time I came back to this project. I tested the 433nano code on an Arduino UNO clone and pilight running on xubuntu 14.04.
First, I also got these errors when trying to upload my code with avrdude:
stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
But I could solve them by removing the "-b 57600" for the upload.

Now it works well for sending via the webinterface, but I do not receive anything.

The sender and receiver do work on a raspberry pi (without bandpass filter).
I did try with an Attiny85 pre-filter but then it also did not receive anything anymore on the raspberry pi, but that is maybe off topic.

I use a China RXB6 receiver. Any ideas why nothing is received?
 
Reply
#49
Are the connections right and the config ok?
 
Reply
#50
The connections are correct, a LED connected to D2 also lights up. I use the same cables that I usually run to the raspberry pi, for which it works.
Config is pretty simple at the moment:
Code:
{
    "devices": {
        "stalamphoek": {
            "protocol": [ "kaku_switch" ],
            "id": [{
                "id": 5961954,
                "unit": 1
            }],
            "state": "off"
        },
        "tvlicht": {
            "protocol": [ "kaku_switch" ],
            "id": [{
                "id": 5961954,
                "unit": 2
            }],
            "state": "off"
        },
        "lamptelefoonkast": {
            "protocol": [ "kaku_switch" ],
            "id": [{
                "id": 5961954,
                "unit": 0
            }],
            "state": "off"
        }
    },
    "rules": {},
    "gui": {
        "lamptelefoonkast": {
            "name": "Lamp Telefoonkast",
            "group": [ "Boven" ],
            "media": [ "web" ]
        },
        "stalamphoek": {
            "name": "Stalamp Hoek",
            "group": [ "Boven" ],
            "media": [ "web" ]
        },
        "tvlicht": {
            "name": "Lamp Televisie",
            "group": [ "Boven" ],
            "media": [ "web" ]
        }
    },
    "settings": {
        "log-level": 4,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight/",
        "webserver-port": 5001,
        "webserver-cache": 1
    },
    "hardware": {
        "433nano": {
            "comport": "/dev/ttyACM1"
        }
    },
    "registry": {
        "pilight": {
            "version": {
                "current": "6.0"
            }
        }
    }
As I said sending does work, and the same wiring works when using the GPIO ports from the raspberrypi, I just reroute the outgoing wires from the breadboard, either to the raspberry pi or to the Arduino.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  how to compile pilight with custom protocol code? am i missing something? stanwebber 2 65 07-05-2021, 03:49 AM
Last Post: stanwebber
  hardware info lost after pilight restart Rschnauzer 3 240 03-17-2021, 11:44 AM
Last Post: Rschnauzer
Question pilight stopped working sl4m01 3 937 11-26-2020, 09:17 PM
Last Post: PPacman
  pilight-raw changes output format from 7 to 8 Rschnauzer 1 631 11-26-2020, 01:52 PM
Last Post: curlymo
Question pilight nightly webgui offline after some hours fleisch 4 687 10-26-2020, 05:19 PM
Last Post: fleisch
  pilight bugs Ascenion 1 652 03-23-2020, 06:29 PM
Last Post: curlymo
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 4,471 12-21-2019, 09:46 AM
Last Post: curlymo
  pilight-control modify values coolinx 16 3,594 11-13-2019, 08:02 PM
Last Post: curlymo
  Bug: double free or corruption in pilight-send blackzombie 12 3,077 10-07-2019, 08:15 PM
Last Post: blackzombie
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 980 08-13-2019, 05:43 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)