• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight Nano USB interface
#81
Quigg not working is as expected. Could be due to the optimalization i talked about earlier (will lookup that post later). Arctech protocol implemented wrongly is hard to believe. We have loads of debug output from the original remotes...
 
Reply
#82
Looking at the Logic Analyser pulses it is indeed curious that it is working. But if a device is not analysing pulse durations but using flank detection instead, combined with low speed hardware, not recognizing unexpected pulses ?
All I can tell so far is that my Intertechno and Brennenstuhl devices do work well with the original remote, and work well with pilight on small distances, but I am monitoring failures on larger distances and sometimes multiple switches react, but only one should.

As debugging with pilight-raw is a bit nasty, i changed receiveOOK such that it prints all raw pulses that may belong to one pulsetrain in one row, and print the number of pulses that may belong to that pulsetrain at the end:
Code:
void *receiveOOK(void *param) {
   int duration = 0;
   int iLoop = 0;

   struct hardware_t *hw = (hardware_t *)param;
   while(main_loop && hw->receiveOOK) {
      duration = hw->receiveOOK();
      iLoop++;
      if(duration > 0) {
// Footer criteria deteted
         if (duration>5100) {
// Add number of pulses at the end and reset counter value
            printf(" %d -#: %d\n%s: ",duration, iLoop, hw->id);
            iLoop = 0;
         } else {
            printf(" %d", duration);
         }
      }
   };
   return NULL;
}
The benefit is that it is:
- far easier to read raw data pulsetrains
- capture raw data and copy them back into pilight-send
- compare pulsetrains with each other
 
Reply
#83
Hi guys.

Some good news!

I have these devices working perfectly on my pi using archtech_switch_old and both the release and nightly packages.

So the problem is definitely in the firmware for the nano.

Like I said a while ago: you can see by the capture that the nano isn't transmitting any long high pulses. That must be where the problem is to be solved.

I had a good look through the nano firmware, and it all seemed pretty sane to me.
I'll see if I can debug what's happening there.
 
Reply
#84
Back on my list.
 
Reply
#85
I take it I can open up a terminal and send things like

c:102020202020202020220202020020202200202200202020202020220020202203;p:279,2511,1395,9486;r:5@

to the nano direct right?
 
Reply
#86
Hi,

Found the problem. Was a strange assumption on protocol syntax in the nano firmware.

Have submitted 2 PRs, fix needed in pilight core too.

[ps I think pilight is great, I only just discovered it while looking for something modern but much leaner than OpenHAB. Hopefully I can hack on other parts of it]
 
Reply
#87
Yes, that's the whole point of pilight. Having community together to create a great project.
 
Reply
#88
agreed Smile
 
Reply
#89
Also @wo_rasp, this is where i have explained the optimalization that is bugging with some protocols:
http://forum.pilight.org/Thread-Arduino-...9#pid11409

Also, i consider all modules not "core". Everything I create is as modular as possible. So it's merely a wrong assumption in the hardware driver instead of an issue with the "core" Wink
 
Reply
#90
OK the nano hardware module.

BTW speaking of which, I'm still getting the raw code dumped onto any ssh terminal when a command is sent. Would be good to figure out why that is happening.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  how to compile pilight with custom protocol code? am i missing something? stanwebber 2 90 07-05-2021, 03:49 AM
Last Post: stanwebber
  hardware info lost after pilight restart Rschnauzer 3 259 03-17-2021, 11:44 AM
Last Post: Rschnauzer
Question pilight stopped working sl4m01 3 957 11-26-2020, 09:17 PM
Last Post: PPacman
  pilight-raw changes output format from 7 to 8 Rschnauzer 1 641 11-26-2020, 01:52 PM
Last Post: curlymo
Question pilight nightly webgui offline after some hours fleisch 4 694 10-26-2020, 05:19 PM
Last Post: fleisch
  pilight bugs Ascenion 1 664 03-23-2020, 06:29 PM
Last Post: curlymo
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 4,521 12-21-2019, 09:46 AM
Last Post: curlymo
  pilight-control modify values coolinx 16 3,631 11-13-2019, 08:02 PM
Last Post: curlymo
  Bug: double free or corruption in pilight-send blackzombie 12 3,105 10-07-2019, 08:15 PM
Last Post: blackzombie
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 986 08-13-2019, 05:43 PM
Last Post: curlymo

Forum Jump:


Browsing: 3 Guest(s)