• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight 7.0
#1
Please post your experiences with pilight v7.0 here.
 
Reply
#2
Great work again!

Installation was without any errors (coming from development v6).
Had to change some settings for devices in the config file.
 
Reply
#3
Was there a change in log-levels?
I'm using log-level 4 and I now see much less messages in the log than with V6.
For instance pilight version is no longer logged and the connection of webclients isn't there anymore also. The latter is an improvement actually because there were lots of those messages before.

--------------

Edit: I think loglevel 4 in V6 is the same as loglevel 6 in V7. Using loglevel 6 however results in a segfault. I've set it back to 4 and do a debug later.
 
Reply
#4
A crash with loglevel 6 should not happen Crying Loglevel 6 is indeed the old 4.
 
Reply
#5
I retried several times but could not reproduce the crash so I think you can ignore until it occurs again.
 
Reply
#6
Had some problems with repeat-values which I cleaned out quick.
What took me longer was the webcam setting which worked well in v6 but unsupported in v7.

Currently my system controls a water pump for the pool, pumping the water through black hoses.
I grab every ten minutes the current UV values for my area from a weather page in the Internet.
A bash script runs in a shell and reads this UV value. Depending on that I defined some conditions: low sun strength turns the pump for 30sec then waits 7min until the water is warm again. With higher UV the water is exchanged earlier.
That system helps me to heat the pool very power saving and raises the temperature around 3 degrees Celsius per day.
 
Reply
#7
Very cool idea/setup!

Can you just explain what the problem is? Which webcam setting?
 
Reply
#8
problem for me was this part:
Code:
    "devices": {
        "webcam": {
            "protocol": [ "generic_webcam" ],
            "id": [{
                "id": 100
            }],
            "url": "http://10.0.0.19/snapshot.cgi?user=*****&pwd=*******"
        },
The services started, but I didn't get the web page. (Of course I had to remove also the GUI entry)
 
Reply
#9
Can someone using the webcam protocol confirm?
 
Reply
#10
works fine with me:

devices:
Code:
"Webcam": {
                        "protocol": [ "generic_webcam" ],
                        "id": [{
                                "id": 100
                        }],
                        "url": "http://192.168.2.99:99/snapshot.cgi?user=pi&pwd=raspberry",
                        "poll-interval": 1000
                },

gui:

Code:
"Webcam": {
                        "name": "Webcam",
                        "group": [ "Camera" ]
                },

(seems missing komma after the url?)
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight-control TML 13 320 05-27-2020, 07:51 AM
Last Post: curlymo
  API Requests by HTTP from other devices fore use in pilight scootermacro 2 155 05-10-2020, 08:19 AM
Last Post: scootermacro
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 2,009 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 505 03-08-2020, 12:14 AM
Last Post: beejayf
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 521 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 645 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 438 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 1,346 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 530 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 1,413 12-18-2019, 11:09 AM
Last Post: vanillaice30

Forum Jump:


Browsing: 1 Guest(s)