• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight 7.0
#11
Hello,

how can i set the "send-repeats" property in pilight 7.0?

I've already read this in the documentation: "Support for send-repeats ends with pilight V6 and is replaced with individual protocol settings."

But with this setting it doesn't work:

Code:
"light": {
           "protocol": [ "kaku_switch_old" ],
            "id": [{
                      "id": 23,
                      "unit": 14
              }],
              "state": "off",
              "send-repeats": 10
}

The log says: "config device setting #4 "send-repeats" of "light", invalid"
 
Reply
#12
The send-repeats is part of the code of each protocol. So hardcoded in pilight and not adjustable anymore.
 
Reply
#13
Unless you compile manually... But then the protocol may not work any more.
 
Reply
#14
Hi,

I have encountered some strange behaviour with pilight 7.0 on my RPiB+ the last couple of days. Every now and then the program crashes after receiving a signal. So far, I have not been able to trace back the exact reason. The strange thing is, that the daemon is still running and the gui is still up, however no signal is sent when changing the state of one of the switches on the gui. Also it shows no CPU and RAM values.

My config is the following:

Code:
{
    "devices": {
        "tueroeffner1": {
            "protocol": [ "cleverwatts" ],
            "id": [{
                "id": 1234567,
                "unit": 3
            }],
            "state": "off"
        },
        "tueroeffner2": {
            "protocol": [ "cleverwatts" ],
            "id": [{
                "id": 2345678,
                "unit": 3
            }],
            "state": "on"
        },
        "tuerschloss1": {
            "protocol": [ "ehome" ],
            "id": [{
                "id": 456
            }],
            "state": "on"
        },
        "stehlamper": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 0,
                "unit": 13
            }],
            "state": "off"
        },
        "stehlampel": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 1,
                "unit": 13
            }],
            "state": "off"
        },
        "schirmlampek": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 2,
                "unit": 13
            }],
            "state": "off"
        },
        "schirmlampef": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 3,
                "unit": 13
            }],
            "state": "off"
        },
        "allelampen": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 15,
                "unit": 13
            }],
            "state": "on"
        },
        "tueroeffner1script": {
            "protocol": [ "program" ],
            "id": [{
                "name": "tueroeffner_haustuer"
            }],
            "program": "/bin/bash",
            "arguments": "/var/www/hausautomation/tueroeffner_haustuer.sh",
            "stop-command": "",
            "start-command": "/var/www/hausautomation/tueroeffner_haustuer.sh &",
            "state": "stopped",
            "pid": 0
        },
        "tueroeffner2script": {
            "protocol": [ "program" ],
            "id": [{
                "name": "tueroeffner_terrasse"
            }],
            "program": "/bin/bash",
            "arguments": "/var/www/hausautomation/tueroeffner_terrasse.sh",
            "stop-command": "",
            "start-command": "/var/www/hausautomation/tueroeffner_terrasse.sh &",
            "state": "stopped",
            "pid": 0
        },
        "tuerschloss1script": {
            "protocol": [ "program" ],
            "id": [{
                "name": "tuerschloss_haustuer"
            }],
            "program": "/bin/bash",
            "arguments": "/var/www/hausautomation/tuerschloss_haustuer.sh",
            "stop-command": "",
            "start-command": "/var/www/hausautomation/tuerschloss_haustuer.sh &",
            "state": "stopped",
            "pid": 0
        },
        "allelampenonscript": {
            "protocol": [ "program" ],
            "id": [{
                "name": "allelampen_on"
            }],
            "program": "/bin/bash",
            "arguments": "/var/www/hausautomation/allelampen_on.sh",
            "stop-command": "",
            "start-command": "/var/www/hausautomation/allelampen_on.sh &",
            "state": "stopped",
            "pid": 0
        },
        "allelampenoffscript": {
            "protocol": [ "program" ],
            "id": [{
                "name": "allelampen_off"
            }],
            "program": "/bin/bash",
            "arguments": "/var/www/hausautomation/allelampen_off.sh",
            "stop-command": "",
            "start-command": "/var/www/hausautomation/allelampen_off.sh &",
            "state": "stopped",
            "pid": 0
        }
    },
    "rules": {
        "regel1": {
            "rule": "IF tueroeffner1.state IS on THEN switch DEVICE tueroeffner1script TO running",
            "active": 1
        },
        "regel2": {
            "rule": "IF tueroeffner1.state IS on THEN switch DEVICE tueroeffner1 TO off",
            "active": 1
        },
        "regel3": {
            "rule": "IF tueroeffner2.state IS on THEN switch DEVICE tueroeffner2script TO running",
            "active": 1
        },
        "regel4": {
            "rule": "IF tueroeffner2.state IS on THEN switch DEVICE tueroeffner2 TO off",
            "active": 1
        },
        "regel5": {
            "rule": "IF tuerschloss1.state IS off THEN switch DEVICE tuerschloss1script TO running",
            "active": 1
        },
        "regel6": {
            "rule": "IF tuerschloss1.state IS off THEN switch DEVICE tuerschloss1 TO on",
            "active": 1
        },
        "regel7": {
            "rule": "IF allelampen.state IS on THEN switch DEVICE allelampenonscript TO running",
            "active": 1
        },
        "regel8": {
            "rule": "IF allelampen.state IS off THEN switch DEVICE allelampenoffscript TO running",
            "active": 1
        }
    },
    "gui": {
        "tueroeffner1": {
            "name": "tueroeffner1",
            "group": [ "Technik" ]
        },
        "tueroeffner2": {
            "name": "tueroeffner2",
            "group": [ "Technik" ]
        },
        "tuerschloss1": {
            "name": "tuerschloss1",
            "group": [ "Technik" ]
        },
        "tueroeffner1script": {
            "name": "tueroeffner1script",
            "group": [ "Technik" ]
        },
        "tueroeffner2script": {
            "name": "tueroeffner2script",
            "group": [ "Technik" ]
        },
        "tuerschloss1script": {
            "name": "tuerschloss1script",
            "group": [ "Technik" ]
        },
        "allelampenonscript": {
            "name": "allelampenonscript",
            "group": [ "Technik" ]
        },
        "allelampenoffscript": {
            "name": "allelampenoffscript",
            "group": [ "Technik" ]
        },
        "stehlamper": {
            "name": "Stehlampe rechts",
            "group": [ "Lampen" ]
        },
        "stehlampel": {
            "name": "Stehlampe links",
            "group": [ "Lampen" ]
        },
        "schirmlampek": {
            "name": "Schirmlampe Kommode",
            "group": [ "Lampen" ]
        },
        "schirmlampef": {
            "name": "Schirmlampe Fernseher",
            "group": [ "Lampen" ]
        },
        "allelampen": {
            "name": "Alle Lampen",
            "group": [ "Lampen" ]
        }
    },
    "settings": {
        "log-level": 6,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight/",
        "webserver-http-port": 5001,
        "webserver-cache": 1
    },
    "hardware": {
        "433gpio": {
            "sender": 2,
            "receiver": 5
        }
    },
    "registry": {
        "pilight": {
            "firmware": {
                "version": 3,
                "lpf": 80,
                "hpf": 16000
            },
            "version": {
                "current": "7.0"
            }
        }
    }
}

Any idea what might be the reason? The log and err files show no unusual entry.

Teddy
 
Reply
#15
Can you follow the debug guide from the pilight manual? You need a manually compiled version for it.
 
Reply
#16
Will do!
One question: Do I have to uninstall pilight (apt) before installing the manually compiled version?
 
Reply
#17
Yes, better do. Also make sure you compile the master branch, not the development.
 
Reply
#18
apt version of pilight uninstalled, manually compiled version and all the debug tools installed. Provoked the crash (shell script started after receiving a signal). But now the same happens: the daemon is still running, showing received signals as if nothing happened. But the webgui is not reacting anymore. It shows that the script has been started but didn't come to an end, which it normally does. Also, I can't send signals via the pilight-send command (script) from a php website. I can only end this by restarting the daemon.
 
Reply
#19
Can you provide me a step by step guide to reproduce this?
 
Reply
#20
1. Started pilight-daemon -D via gdb
2. Set off door contact (link), which sends a burst of different protocols, one of which is a "cleverwatts" protocol (see my config post above - "tueroeffner2")
3. This sets off rule "regel3", starting a bash script "tueroeffner_terrasse.sh". What this script essentially does is sending an encrypted telegram message (link) to my cellphone "Backdoor has been opened!". After sending the message, the script usually stops.
4. Since the door contact only sends a signal when the door is opened, I have to switch the state back to "off" by triggering the rule "regel4".
5. When repeating this about 3-4 times, the webgui shows that the script is not stopping anymore ("Running ..."). All the other switches on the webgui can be toggled but nothing happens (no signals are sent). The daemon is still running in debug mode, showing no unusual behavior. Signals from remote are still received and show up in the terminal. When terminating the gdb session I was not able to stop the daemon with the normal "service pilight stop" command, I had to reboot.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight-control TML 13 320 05-27-2020, 07:51 AM
Last Post: curlymo
  API Requests by HTTP from other devices fore use in pilight scootermacro 2 155 05-10-2020, 08:19 AM
Last Post: scootermacro
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 2,009 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 505 03-08-2020, 12:14 AM
Last Post: beejayf
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 521 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 645 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 438 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 1,346 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 530 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 1,413 12-18-2019, 11:09 AM
Last Post: vanillaice30

Forum Jump:


Browsing: 1 Guest(s)