• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[v7.0 > v...] Errors with the latest nightly
For all nightly related errors and bugs.
I use nightly and I got this error:

"pilight-daemon: ERROR: config device #2 "outside", missing protocol"

I saw openweathermap during the compile so I dont understand what is wrong. It worked with Pilight6.

Config file:
"outside": {
    "name": "outside",
    "temperature": {
        "name": "Temperature",
        "protocol": [
        "id": [
                "location": "london",
                "country": "uk"
        "humidity": 7600,
        "temperature": 700,
        "sunrise": 1,
        "sunset": 700,
        "sun": "set"
The format of the config JSON has been changed a bit, you need to redefine your device. Devices also no longer have a "name" key, this is defined in the "gui" section.
This also didn't work in pilight 6 because the config change was already implemented back then.
Yesterday I tried to compile on my Raspberry Pi 2 pilight version e70b92c and today version 884bc3c but I always get:
CMakeFiles/pilight-control.dir/build.make:86: recipe for target 'pilight-control' failed
make[2]: *** [pilight-control] Error 1
CMakeFiles/Makefile2:95: recipe for target 'CMakeFiles/pilight-control.dir/all' failed
make[1]: *** [CMakeFiles/pilight-control.dir/all] Error 2
Makefile:133: recipe for target 'all' failed
make: *** [all] Error 2

I never had this problem before.
Should be all fixed again.
Works again, thanks
In nightly v7.0-30-g6becc0d there seems to be a bug in the handling of webgui commands.
When websockets = 0 flipping a switch in the gui does not result in sending the command.
When websockets = 1 everything works fine and also 7.0 stable is ok (even with websockets = 0).

I am facing a 404 error while trying to update:
W: Failed to fetch http://apt.pilight.org/dists/development/main/binary-armhf/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
Has the repo changed or something else?
No, there is just no development package available at the moment.

Possibly Related Threads...
Thread Author Replies Views Last Post
  Nightly versions less than 8.1.5-59 missing? felfert 4 231 07-28-2020, 07:50 PM
Last Post: felfert
  stable/nightly Release is no longer signed DSLeX 1 545 05-14-2020, 01:09 PM
Last Post: peteratoce
  MQTT cannot be disabled on nightly image ayeyebrazov 5 468 05-01-2020, 03:11 PM
Last Post: ayeyebrazov
  hardware module issues in nightly apartmedia 17 3,156 04-05-2019, 06:59 PM
Last Post: curlymo
  Update to v8.0.10-nightly-a1279212 Ulrich.Arnold 3 1,847 06-04-2018, 08:31 PM
Last Post: curlymo
  Updates for nightly Ulrich.Arnold 1 926 01-26-2018, 07:31 PM
Last Post: curlymo
  how to complete remove nightly terrar 8 6,348 04-03-2016, 07:04 PM
Last Post: mvasi90
  new install fails - dev/nightly gneandr 11 11,079 01-29-2016, 11:30 AM
Last Post: WEBcast
  pilight7 from Stable --> Nightly gneandr 10 4,399 01-19-2016, 04:15 PM
Last Post: gneandr
  Rest API in nightly Image seems not to work spooniester 2 2,342 06-25-2015, 10:07 AM
Last Post: spooniester

Forum Jump:

Browsing: 1 Guest(s)