• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
v6 --> V7 (Nightly) failed -- pl.help
#1
To support piSchedule for the changed API with pilight version 7 I have to upgrade my current vers.6 installations.

Following the pilight manual step-by-step it failed and I hope someone can point to the problem and have a solution.

Here are the logs (partial):
Code:
Preparing to replace pilight-webgui 6.0 (using .../pilight-webgui_7.3_armhf.deb) ...
Unpacking replacement pilight-webgui ...
Preparing to replace pilight 6.0 (using .../pilight_7.0.41-g1f93979_armhf.deb) ...
Unpacking replacement pilight ...
Setting up pilight-webgui (7.3) ...
Setting up pilight (7.0.41-g1f93979) ...
W: Duplicate sources.list entry http://apt.pilight.org/ nightly/main armhf Packages (/var/lib/apt/lists/apt.pilight.org_dists_nightly_main_binary-armhf_Packages)
W: You may want to run apt-get update to correct these problems
root@raspberrypi:/home/pi/piControl#

Running apt-get update again (did it before .. as request with the manual lines http://manual.pilight.org/en/installation):
Code:
root@raspberrypi:/home/pi/piControl# apt-get update    
Ign http://apt.pilight.org development Release.gpg
Hit http://apt.pilight.org nightly Release.gpg                                  
Hit http://mirrordirector.raspbian.org wheezy Release.gpg                        
Hit http://raspberrypi.collabora.com wheezy Release.gpg                          
Hit http://archive.raspberrypi.org wheezy Release.gpg                            
Ign http://apt.pilight.org development Release                                  
Hit http://raspberrypi.collabora.com wheezy Release
Hit http://mirrordirector.raspbian.org wheezy Release                
Hit http://archive.raspberrypi.org wheezy Release                    
Hit http://repository.wolfram.com stable Release.gpg                
Hit http://apt.pilight.org nightly Release                                      
Hit http://raspberrypi.collabora.com wheezy/rpi armhf Packages                  
Hit http://mirrordirector.raspbian.org wheezy/main armhf Packages                
Hit http://repository.wolfram.com stable Release                      
Hit http://mirrordirector.raspbian.org wheezy/contrib armhf Packages            
Hit http://mirrordirector.raspbian.org wheezy/non-free armhf Packages            
Hit http://archive.raspberrypi.org wheezy/main armhf Packages                    
Hit http://apt.pilight.org nightly/main armhf Packages                          
Hit http://mirrordirector.raspbian.org wheezy/rpi armhf Packages                
Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en                  
Hit http://repository.wolfram.com stable/non-free armhf Packages                
Err http://apt.pilight.org development/main armhf Packages                      
  404  Not Found
Ign http://apt.pilight.org development/main Translation-en                      
Ign http://archive.raspberrypi.org wheezy/main Translation-en                    
Ign http://apt.pilight.org nightly/main Translation-en                          
Ign http://repository.wolfram.com stable/non-free Translation-en                
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
W: Failed to fetch http://apt.pilight.org/dists/development/main/binary-armhf/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
root@raspberrypi:/home/pi/piControl#
 
Reply
#2
As i know there is currently no development version released at the moment.

Try to disable the dev. version in /etc/apt/sources.list
Code:
# deb http://apt.pilight.org/ development main
This should work and the latest v7 nightly will be installed

Dont forget to rerun apt-get update after changing the sources.list
Terrarium:  RPi Model B Rev 2 / pilight 8.1.2 / stretch
Aquarium: RPi Model B Plus Rev 1.2 / pilight 8.0.6 / jessie
 
Reply
#3
Right before shutting down for today (Friday) .. will try & report tomorrow.
Thanks
 
Reply
#4
What ever happened, only a new install of the RPI and pilight was the only way to "upgrade from version 6 to version 7"

Beside that what is the reason why installing the Nightly would fail?
Terrar wrote
Quote:there is currently no development version released at the moment.
Can it be following the Installation instructions for Nightly without a dev version will destroy the pilight/rpi installation at all?
 
Reply
#5
Need further HELP!

Calling http://192.168.178.50:5001/config gives all details of my setup including
Code:
{
  "devices": {
    "Stehlampe": {
      "protocol": [
        "pollin"
      ],
      "id": [
        {
          "systemcode": 17,
          "unitcode": 2
        }
      ],
      "state": "off"
    }

Switching that device from the webGui works perfect .. but using the "control?" call as outlined on the Nightly pages
Code:
http://192.168.178.50:5001/control?devices=Stehlampe&state=on
fails with
Code:
Not Found
The requested URL /control was not found on this server.

Any good reason? What is wrong here?

By the way .. as discussed in this thread installing the Nightly failed, so I have a pure version 7.0!
If the Nightly version is required .. how to solve the installation problem?

Günter (somehow frustrated, sorry)
 
Reply
#6
Nightly is required. What is the error with installing the nightly?
 
Reply
#7
See above!
 
Reply
#8
I don't see any nightly issues, only you using a apt branch that's currently not available (development).
 
Reply
#9
I don't understand the situation and unfortunately I can't review it because I did a complete RPI reinstall from scratch.
But it was the attempt to "upgrade" a running pilight v.6 to the Nightly version to have the very latest code base.
I remember I added to the "/etc/apt/sources.list.d/pilight.list" the required line as said on the installation manual:
Quote:If you want to install the nightly version of pilight then also add:
root@pilight:~# echo "deb http://apt.pilight.org/ nightly main" >> /etc/apt/sources.list.d/pilight.list
Based on that -- but not knowing about the real pilight.list content -- the installation process throw that error.

Conclusion:
I think it would be helpful to have the required content of the pilight.list for the different installation situation contained in the manual.
(Maybe it's just me ... but it's not the first time I'm struggling with that installations procedure .. see my posting before about this)
 
Reply
#10
Quote:Conclusion:
I think it would be helpful to have the required content of the pilight.list for the different installation situation contained in the manual.
(Maybe it's just me ... but it's not the first time I'm struggling with that installations procedure .. see my posting before about this)
All pilight documentation is still open source and editable by users. If you have suggestions for improvements, feel free to open a PR on the manual or to edit the wiki directly, as many users did before.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  uv__io_poll: Assertion `w->pevents != 0' failed monok 4 158 06-26-2020, 11:29 AM
Last Post: monok
  Assert error in v8.1.3-nightly-d2ee2d0d Ulrich.Arnold 4 948 10-24-2018, 09:28 PM
Last Post: curlymo
  pilight-raw working in nightly? Cipher 8 2,476 08-30-2017, 09:35 PM
Last Post: curlymo
  pilight nightly does not start up, no log entries PT-Biker 4 2,204 06-09-2017, 06:34 AM
Last Post: PT-Biker
  No Heartbeat in Nightly anymore? Cipher 1 947 05-22-2017, 10:02 AM
Last Post: pilino1234
  pilight development installation -- failed / what is the secret? gneandr 5 3,275 02-04-2017, 10:06 AM
Last Post: gneandr
  When do "Pull-Requests" show up (in Nightly or 'git clone') TheWheel 3 1,663 12-24-2016, 09:58 AM
Last Post: curlymo
  Update Error latest Nightly Alex 13 5,146 09-11-2016, 02:51 PM
Last Post: Alex
  Manually-Compiled Nightly | Rules not working Alex 18 7,488 08-20-2015, 06:29 AM
Last Post: Alex
  Error message when start of pilight failed. Landixus 8 7,915 07-25-2015, 06:53 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)