• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Disable adhoc network?
#1
Hi,

I have 2 Raspberries on the same LAN.
Thus, 2 pilight setups will automatically built an adhoc network.

However, I want to adress each Raspberry individually via FHEM2FHEM, so that I can decide which pilight should send the wanted signal.

How can I disable the adhoc feature, so that pilight just works locally and separately on each Raspberry in the same LAN.

Greetings,
Heiko
 
Reply
#2
You will find your answer here:
LINK
keyword: standalone
Terrarium:  RPi Model B Rev 2 / pilight 8.1.2 / stretch
Aquarium: RPi Model B Plus Rev 1.2 / pilight 8.0.6 / jessie
 
Reply
#3
Thank you very much, this is what I was looking for.

Heiko
 
Reply
#4
I think this is not working correctly.
Although "standalone": 1, ssdp is looking for a master.
Thus, I cannot use pilight as a standalone.
pilight-send always gives me:
no pilight ssdp connections found

config.json
Code:
{
    "devices": {},
    "rules": {},
    "gui": {},
    "settings": {
        "log-level": 6,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "standalone": 1,
        "port": 5000,
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight/",
        "webserver-http-port": 5001,
        "webserver-cache": 1
    },
    "hardware": {
        "433gpio": {
            "sender": 0,
            "receiver": 1
        }
    },
    "registry": {
        "pilight": {
            "version": {
                "current": "7.0"
            }
        }
    }
}

pilight-deamon -D:
Code:
[Sep 16 19:47:28:288427] pilight-daemon: DEBUG: webserver listening to port 5001
[Sep 16 19:47:28:291347] pilight-daemon: DEBUG: new thread webserver client, 9 threads running
[Sep 16 19:47:28:292462] pilight-daemon: DEBUG: new thread webserver broadcast, 10 threads running
[Sep 16 19:47:28:297660] pilight-daemon: DEBUG: ssdp sent search
[Sep 16 19:47:28:299755] pilight-daemon: DEBUG: cpu: 0.000000%, ram: 0.475231%
[Sep 16 19:47:28:381150] pilight-daemon: NOTICE: no pilight ssdp connections found
[Sep 16 19:47:28:383201] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 32836
[Sep 16 19:47:28:384001] pilight-daemon: DEBUG: client fd: 12
[Sep 16 19:47:28:385382] pilight-daemon: DEBUG: client id: 2
[Sep 16 19:47:28:386872] pilight-daemon: DEBUG: socket write succeeded: {"action":"identify","options":{"config":1},"media":"all"}

[Sep 16 19:47:28:391117] pilight-daemon: NOTICE: no pilight ssdp connections found
[Sep 16 19:47:28:393546] pilight-daemon: DEBUG: socket recv: {"action":"identify","options":{"config":1},"media":"all"}
[Sep 16 19:47:28:394716] pilight-daemon: DEBUG: socket write succeeded: {"status":"success"}

[Sep 16 19:47:28:396199] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 32837
 
Reply
#5
Standalone is standalone which means the SSDP server is disabled. Not the client. It will just not connect to another master. Because of the standalone setting, pilight-send can't automatically discover the daemon. Use the pilight-send server / port setting to point to where the standalone daemon is running.
 
Reply
#6
Indeed, this was the solution - adding "--server=127.0.0.1" to my pilight-send command.
This comes with having "standalone": 1 in the config.json.
It is documented in the manual, section "Disabling SSDP completely" however I didn't see it at first.

http://manual.pilight.org/en/faq#pf2
Quote:Add the standalone setting in the config.json and set it to 1. However, because all pilight clients use SSDP
to find the main pilight daemon, you need to pass the server and port arguments when you want to control
this standalone running daemon.

Thanks for this great tool, curlymo!!!
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Issue send actions over Socket API in AdHoc network ggtrts 10 780 03-13-2019, 06:32 AM
Last Post: curlymo
  AdHoc network with 2 Raspberry and 2 GPIO transmitter not working webdandy 29 6,548 09-06-2017, 02:39 PM
Last Post: wseifert
  BUG: BMP180 in AdHoc Network Alex 5 1,586 06-19-2016, 02:24 PM
Last Post: Alex
  AdHoc network with different senders Mr.Montesa 6 2,745 02-11-2016, 01:29 PM
Last Post: Karel
  cannot bind to the ssdp multicast network wo_rasp 1 2,890 09-22-2015, 12:10 PM
Last Post: curlymo
  Sending with 2 transmitters (AdHoc) tobid 11 4,409 08-23-2015, 05:12 PM
Last Post: curlymo
  AdHoc - Defining MainDaemon tobid 18 8,175 08-12-2015, 07:41 AM
Last Post: gregnau
  AdHoc bug with 3 or 4 raspberries causch 18 5,380 07-20-2015, 03:39 PM
Last Post: causch
Question More than one pilight-server in one network TiefDruckGebiet 1 1,761 02-25-2015, 09:47 AM
Last Post: pilino1234

Forum Jump:


Browsing: 1 Guest(s)