• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight does not start
#1
I try running pilight on my Raspberry Pi 2 with Osmc installed. I've tried builing pilight from git and also tried the deb package, the result seems always be the same (pilight does not start). I guess therefore I get an ssdp error when trying to send something...

Any ideas on this?

osmc@osmc:/usr/local/bin$ sudo service pilight start
osmc@osmc:/usr/local/bin$ sudo service pilight status
● pilight.service - LSB: Starts pilight-daemon
Loaded: loaded (/etc/init.d/pilight)
Active: active (exited) since Do 2015-11-12 00:05:51 CET; 1s ago
Process: 1888 ExecStop=/etc/init.d/pilight stop (code=exited, status=0/SUCCESS)
Process: 1921 ExecStart=/etc/init.d/pilight start (code=exited, status=0/SUCCESS)

Nov 12 00:05:51 osmc pilight[1921]: Starting : pilight failed!
 
Reply
#2
Try running pilight in debug mode, it will show you what's happening:
Code:
sudo pilight-daemon -D
Press Ctrl+C to stop it again.
 
Reply
#3
Got it, thanks, there was something wrong with the webserver configuration

The isses is that I've switched from Raspberry Pi V1 to V2 and with that also from pilight 5 to pilight 7. Since all my switches worked before I'm a little confused because nothing works anymore, neither sending nor receiving.

But pilight-daemon still starts with errors, too... any advice on this?

osmc@osmc:/etc/pilight$ sudo /usr/local/sbin/pilight-daemon -D
[Nov 12 17:46:29:489574] pilight-daemon: INFO: version 213fbaf
[Nov 12 17:46:29:490172] pilight-daemon: DEBUG: ssdp sent search
[Nov 12 17:46:29:586436] pilight-daemon: NOTICE: a pilight daemon was found @192.168.178.48, clientizing
[Nov 12 17:46:29:588827] pilight-daemon: DEBUG: new thread node, 1 thread running
[Nov 12 17:46:29:589876] pilight-daemon: DEBUG: new thread sender, 2 threads running
[Nov 12 17:46:29:590168] pilight-daemon: DEBUG: ssdp sent search
[Nov 12 17:46:29:590459] pilight-daemon: DEBUG: new thread broadcaster, 3 threads running
[Nov 12 17:46:29:591864] pilight-daemon: DEBUG: running on a raspberrypi
[Nov 12 17:46:29:594981] pilight-daemon: ERROR: raspberrypi->isr: Failed to set interrupt edge to both
[Nov 12 17:46:29:595971] pilight-daemon: ERROR: raspberrypi: error while calling isr
[Nov 12 17:46:29:597708] pilight-daemon: DEBUG: garbage collected wiringX library
[Nov 12 17:46:29:598834] pilight-daemon: ERROR: unable to register interrupt for pin 1
[Nov 12 17:46:29:600129] pilight-daemon: DEBUG: new thread 433gpio, 4 threads running
[Nov 12 17:46:29:602802] pilight-daemon: DEBUG: new thread receive parser, 5 threads running
 
Reply
#4
What kernel and OS version are you running?
Can you try to compile the wiringX examples and post the results here please?
 
Reply
#5
I compiled the wiringX examples from here: https://github.com/wiringX/wiringX

It seems that all examples (except the i2c one) work well, e.g.:

osmc@osmc:~/zeugs/wiringX/build$ sudo /usr/local/sbin/wiringx-blink 1
running on a raspberrypi
Writing to GPIO 1: High
Writing to GPIO 1: Low
Writing to GPIO 1: High
Writing to GPIO 1: Low

I forgot to mention my kernel version...

osmc@osmc:~/zeugs/wiringX/build$ uname -a
Linux osmc 4.2.3-2-osmc #1 SMP PREEMPT Mon Oct 12 01:58:40 UTC 2015 armv7l GNU/Linux
 
Reply
#6
Did you test the interrupt example? If that works, there shouldn't really be an error… But pilight works, you can send and receive codes properly?
 
Reply
#7
I did some more research and reactivated my old Raspberry Pi 1 again with my receiver attached to that. I noticed that I got the same errors as mentioned above when pilight tried to register the interrupt for the receiver pin (GPIO 1 in my case as per standard configuration). With changing the receiver pin to GPIO 2 in the pilight config the errors were gone and my Raspberry Pi 1 was able to receive.

After that I just changed the config the same way on my new Raspberry and - et voila - the sender works like a charm as well.

So it seems although the daemon was running all the time, the errors prevented pilight from both sending and receiving. Maybe you can find out why that happens.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight-control modify values coolinx 16 264 11-13-2019, 08:02 PM
Last Post: curlymo
  Bug: double free or corruption in pilight-send blackzombie 12 303 10-07-2019, 08:15 PM
Last Post: blackzombie
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 190 08-13-2019, 05:43 PM
Last Post: curlymo
  pilight Nano USB interface curlymo 228 100,213 07-10-2019, 06:14 PM
Last Post: curlymo
  problems compiling pilight on Odroid C2 WitchDoctor 101 10,847 03-14-2019, 09:01 PM
Last Post: curlymo
  pilight 8 what chages for custom protocols? polo 11 3,151 02-15-2019, 06:22 PM
Last Post: polo
  pilight-debug shows nothing minhdomanh 3 608 10-18-2018, 07:01 AM
Last Post: felfert
  pilight-send and pilight-daemon DieterK 0 610 06-20-2018, 12:44 AM
Last Post: DieterK
  Lights not switched on or off by rules in pilight 8.1.0 rorie 22 2,752 06-12-2018, 03:56 PM
Last Post: curlymo
  check API in pilight 8 stratege-0815 4 1,496 02-11-2018, 09:34 AM
Last Post: stratege-0815

Forum Jump:


Browsing: 1 Guest(s)