• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Found Bug?
#1
Dear all,

I think I found a bug in the pilight-daemon.

I want to run pilight on my raspberry pi. I connected my hardware with an arduino nano. But it is not receiving any messages, also raw is doing nothing.

To test the hardware I installed pilight on my laptop (windows 7). Here the receiving functionality is working as expected.

If I then close the daemon on the windows machine and connect the hardware on the pi again it is working again! But if I stop the daemon and start it again it is not working anymore.

So the TL;DR version:

Windows shutdown --> Windows start --> OK!
Windows shutdown --> Linux start --> OK!
Linux shutdown --> Linux start --> NOT OK!

Versions used (as I don't know how to compile manually on windows):

Linux: pilight-daemon version v7.0-13-g960219e (manually compiled development version)
Windows: pilight-daemon version v7.0-59-g6f3a679
 
Reply
#2
I use the nano as the main device for some time now and never had issues on linux.
 
Reply
#3
Is there any other way to check what is going wrong? Or other suggestions on what I can do to eliminate things?

I can reproduce this any time with the steps I explained above. I tried reflashing the arduino and rewire everything. But no luck.

I can also see the led on the arduino flashing when using on windows and on the first run when switching from windows to linux.

Otherwise the led is not flashing. But sending things is always working so the link towards the arduino seems to be fine
 
Reply
#4
Try another distro.
 
Reply
#5
I just wiped the SD-card and installed raspbian-jessie (the lite version) and manually installed pilight.

Unfortunately though, the problem still exists. Could the problem maybe be that the nano is a chinese clone?

It really seems to me that the deinit of the nano is incorrect on my linux box and correct on my windows box.

Because:

Linux deinit --> Linux init --> NOT OK
Linux deinit --> Windows init --> NOT OK
Linux deinit --> Windows init --> (NOT OK HERE!) Windows deinit --> Windows init --> OK
Windows deinit --> Linux init --> OK

As work around now I will deinit on my windowsbox if I want receive capabilities.
 
Reply
#6
Could be, i never had issues with the nano's i sell.
 
Reply
#7
The symptoms could be an indication that pilight is operating in adhoc network mode. As a 1st step i do propose that you rule out that possibility.

Start pilight in debug mode (pilight-daemone -D) and check the logged messages, pilight is clearly reporting in its log whenever it finds another pilight instance on the network.

Check https://manual.pilight.org/en/adhoc-network for more details.
 
Reply
#8
It does not seam like the instance is running in ad-hoc mode. This is from my linux box when receiving is not working:

Code:
[Dec 31 10:55:28:682867] pilight-daemon: INFO: version v7.0-13-g960219e
[Dec 31 10:55:28:684202] pilight-daemon: DEBUG: ssdp sent search
[Dec 31 10:55:28:777355] pilight-daemon: INFO: no pilight daemon found, daemonizing

EDIT:
After reading through the Arduino nano USB thread: I came to the conclustion that the CH340G chip is to blame. I have the same chip on my Arduino. Probably the windows driver work with this chip but the linux drivers will not work. At least that is my guess for now.
 
Reply
#9
UPDATE:

I now have a nano with an FTDI chip, this one works as expected. Maybe we should add a entry on the wiki? Or is this something that will be worked on?
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Solved] No ssdp connection found Hexcode 145 141,730 12-23-2017, 02:10 PM
Last Post: HuberDe
  Raspbian jessie - pilight 7 - no pilight ssdp connections found shirocko 20 15,515 01-29-2017, 10:23 PM
Last Post: gneandr
  no pilight ssdp connections found/failed to kill 3400 Xilinx64 3 3,261 02-13-2015, 12:57 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)