• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


[solved] pilight on Browser - no entrys
#1
Hello,

what can I do? I have as a test insert "openweathermap" and "datetime" in config.json. I think, now I must see the entrys of this objects in the browser. But i see nothing, only "pilight 7.0" and the CPU. What am I doing wrong?

In a shell i can see the output from pilight, so it works.
My Config File her:

Code:
{
    "devices" : {
        "outside" : {
            "protocol" : ["openweathermap"],
            "id" : [{
                    "country" : "de",
                    "location" : "berlin"
                }],
            "humidity" : 79.00,
            "temperature" : -2.02,
            "sunrise" : 8.40,
            "sunset" : 17.02,
            "sun" : "set",
            "update" : 0
        },
        "datetime" : {
            "protocol" : ["datetime"],
            "id" : [{
                    "longitude" : 1.2345,
                    "latitude" : 12.3456
                }],
            "year" : 2015,
            "month" : 1,
            "day" : 27,
            "hour" : 14,
            "minute" : 37,
            "second" : 8,
            "weekday" : 3,
            "dst" : 1
        }
    },
    "rules" : {},
    "gui" : {
        "outside" : {
            "name" : "Temperature",
            "group" : ["Outside"],
            "media" : ["all"]
        },
        "datetime" : {
            "name" : "Date & Time",
            "group" : ["Misc"],
            "media" : ["all"]
        }
    },
    "settings" : {
        "log-level" : 6,
        "pid-file" : "/var/run/pilight.pid",
        "log-file" : "/var/log/pilight.log",
        "webserver-enable" : 1,
        "webserver-root" : "/usr/local/share/pilight/",
        "webserver-http-port" : 5001,
        "webserver-cache" : 1
    },
    "hardware" : {
        "433gpio" : {
            "sender" : 0,
            "receiver" : 1
        }
    },
    "registry" : {
        "pilight" : {
            "version" : {
                "current" : "7.0"
            }
        }
    }
}

I ask for help, please.

Regards. Areon
 
Reply
#2

  1. Try putting spaces between the quotation marks and the square brackets, like [ "openweathermap" ] instead of ["openweathermap"]

  2. Device names may not be the same as protocol names (datetime).

 
Reply
#3
Hello,

i have changed the config.json. It does not work. I see on webgui "pilight V7.0" and "CPU..."

I have the latest version from pilight and i have no ideas. Where ist the error?

My config.json ist this:
Code:
{
    "devices": {
        "outside": {
            "protocol": [ "openweathermap" ],
            "id": [{
                "country": "de",
                "location": "berlin"
            }],
            "humidity": 93.00,
            "temperature": 2.00,
            "sunrise": 8.00,
            "sunset": 16.36,
            "sun": "set",
            "update": 1
        }
    },
    "rules": {},
    "gui": {
        "outside": {
            "name": "Temperature",
            "group": [ "Outside" ],
            "media": [ "all" ]
        }
    },
    "settings": {
        "log-level": 6,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight/",
        "webserver-http-port": 5001,
        "webserver-cache": 1
    },
    "hardware": {
        "433gpio": {
            "sender": 0,
            "receiver": 1
        }
    },
    "registry": {
        "pilight": {
            "version": {
                "current": "7.0"
            }
        }
    }
}
This is directly from the pilight-webside. I think this has to work.

Regards Areon
 
Reply
#4
Your config works perfectly well for me, so the problem is not the config.
Do you have javascript enabled in your browser?
 
Reply
#5
Hi,

it's like a miracle: I have the Pi today restarted and it works. Yesterday I updated to the latest version. It's like Windows: A reboot is always good.

Thank you.

Regards Areon
 
Reply
#6
HI Areon,

I experienced the same. I changed the config, but nothing would show up on webgui, altough I did a
Code:
sudo service pilight restart
.

It turned out you should end all instances of pilight-daemon befor changing the config, i.e.,
Code:
sudo killall pilight-daemon
.

After you change the config.json you can simply run
Code:
sudo pilight-daemon
to see your changes in action Smile
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight & piSchedule works fine but no webgui Sven 4 1,724 01-13-2019, 06:12 PM
Last Post: Sven
  [Android] illumina, a pilight remote phdd 62 50,493 08-02-2016, 05:56 PM
Last Post: curlymo
  Plenary - An alternative webGUI for pilight mitch187 20 18,119 03-29-2016, 06:25 AM
Last Post: curlymo
  webgui pilight 6.0 iphone / android browser Jeroenk 3 3,402 02-03-2016, 05:08 PM
Last Post: serge
  PiControl - Control Pannel for pilight [Work In Progress] Jurre 10 6,898 01-12-2016, 05:47 PM
Last Post: Jurre
  GUI for pilight ktams 32 15,451 10-28-2015, 12:24 PM
Last Post: ktams
  [solved] pilight not work with Config NowHere 5 4,683 06-09-2015, 04:33 PM
Last Post: NowHere
  [Android] pilight android 4.1+ UPDATED 5/5/15 Zatta 103 89,672 05-06-2015, 09:21 PM
Last Post: koos147
  [Android] pilight Wear schdef 3 5,523 04-14-2015, 04:48 PM
Last Post: schdef
  [Android] Tasker pilight Kiwi 6 10,585 04-01-2015, 03:37 PM
Last Post: bkmann

Forum Jump:


Browsing: 1 Guest(s)