• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SSDP error and or missing protocol
Hi all,

Received my 433mhz sender & receiver kit today. Thanks for that :-)

What i've done:
- installed windows version of pilight
- flash a arduino nano with the hex file in the folder of pilight
- edited config.json (attached below)
- started pilight-receive and got "no pilight ssdp connection"
- changed config.json and added "standalone": 1; didn't work

- started pilight-raw and got "[Jan 26 17:56:12:745604] pilight-raw: ERROR: config device #1 "hardware", missing protocol

    "devices": { "hardware": {
        "433nano": {
            "comport": "COM5"
    "gui": { },
    "rules": { },
    "settings": {
    "standalone":0,    "log-level": 6,
        "log-file": "c:/pilight/pilight.log",
        "webserver-enable": 1,
        "webserver-root": "c:/pilight/web/",
        "webserver-http-port": 5001,
        "webserver-cache": 1,
        "whitelist": ""
    "hardware": {
        "none": { }
    "registry": { }

What am I doing wrong? Can't find input in the web that solves these issues

(01-26-2016, 07:04 PM)rudig Wrote: What am I doing wrong?
Not using code tags on the forums Wink
Please edit your post to use code tags, it makes it easier to help in finding problems with your config.json. Thanks Smile
(01-26-2016, 07:04 PM)rudig Wrote:
   "devices": { "hardware": {
      "433nano": {
         "comport": "COM5"
   "hardware": {
      "none": { }
What am I doing wrong? Can't find input in the web that solves these issues
You have embraced the hardware section into the devices section.
And in the Hardware section you have disabled the USB nano.
Please check the pilight manual
Open the Menu,
- goto Devices to check what you have to put into that section, more information for individual devices is found in the pilight WIKI
- goto Hardware, select USB Nano, and check the USB nano configuration.

Thanks for the input, after bit of puzzling I solved the error on the config.json.
The error that is cannot identify the Firmware Version remains but as I understand is not to important.

Next hurdle is that I don't see any data comming in when starting pilight-raw or pilight-receive

To test if the receiver is working I made a simple arduino sketch which prints a 1 when digital pin 2 is high and a 0 when it is low. This sketch displays 001011010101 constantly. So it seems my receiver is receiving data. Receiver has a simple antenna on it as described.

When looking at the serial output of the nano once configured with the pilight-usb-nano.hex it just outputs the same character over and over.

What could I check to investigate some more?
It is pretty difficult to diagnose a communication problem with limited information on what is already checked.

In order to establish a common base of understanding:

A) Hardware Used:
I assume that you use Windows 10 / 64 Bit with an Intel CPU.
- If not, what version are you using ?
- What CPU (Intel / AMD; 32/64Bit)
- What type of mother board (PC BIOS / EFI BIOS, integrated USB, USB 2.0 / 3.0 ports)
- Do you use any virtualization environment ?

B) Networking Environment:
I assume that you have configured a networking environment and that the LOOPBACK adapter is working. To test the Loopback adapter open a CMD box and confirm:
-  that "netstat" is reporting an established TCP Link to your own computer (e.q. the Remote machine is identical with your computer),
- that you receive a response when you "ping".

C) USB Serial Link:
I further assume that you have used Windows Device Manager:
- to confirm that a USB link is established and visible
... e.q. you can monitor connecting / disconnecting the USB nano (with Device Manager / Control Panel)
- to conclude that Windows has assigned COM Port 5 to your USB nano connection.
- to identify the Hardware ID of your connected USB device, for example if it has the CH340 chip it should be something like USB\VID_1A86&PID_7523&REV_0254
- If your USB device is shown as an unknown device, have you tried:
... to update the driver, for example if it is a CH340 based chipset, the device should be identified as "USB-SERIAL CH340 (COM5)".
The COM port may differ, in this case you have to adjust the COM port setting in your config.json accordingly
- If you use a USB 3.0 port, do you have a USB 2.0 port on your computer you can use ?

D) USB nano Hardware Interface (Chipset):
If your Hardware ID differs, can you post the properties for:
- Hardware ID
- Device ID
- Status

Based on this information I would appreciate if we can update the FAQ section of the manual (on http://www.pilight.org).

I've got a nano with ch340 chip.
Yesterday I tested with another board with the FTDI chip and this works.
I'll further figure out if the nano is the issue.

But I've been able to received data with the FTDI Arduino and pilight-raw, so issue solved.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Nightly versions less than 8.1.5-59 missing? felfert 4 132 07-28-2020, 07:50 PM
Last Post: felfert
  ERROR: failed to read config. stack: 2 Stefan 6 577 02-03-2020, 09:37 PM
Last Post: curlymo
  Raspberry 4B installation error royw 3 607 12-05-2019, 10:58 AM
Last Post: royw
  pilight error after update to 8.1.5 on Odroid C2 WitchDoctor 3 820 11-29-2019, 09:56 PM
Last Post: curlymo
  "FOR '2 MINUTE' FROM off" resulting in error hansrijn2 5 635 11-15-2019, 02:04 PM
Last Post: hansrijn2
  433gpio platform error after raspbian dist upgrade HuberDe 2 785 10-12-2019, 07:35 PM
Last Post: HuberDe
  Starting pilight on boot: "cannot bind to the SSDP multicast network" pilino1234 4 1,085 09-29-2019, 02:08 PM
Last Post: tomk
Sad Raspberry Pi: "NOTICE: no pilight ssdp connections found" abusch 8 1,896 04-30-2019, 09:10 PM
Last Post: curlymo
  Compile with Optimization fails / timedate missing fourty2 6 1,068 04-29-2019, 12:27 PM
Last Post: fourty2
  Protocol Program PID AdHoc-Client Bigmama 12 1,922 01-26-2019, 07:36 PM
Last Post: Bigmama

Forum Jump:

Browsing: 1 Guest(s)