• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspberry pi 2, pilight 7.0 problems eurodomest
#1
Hello all,

I am new to pilight and can't get it to work with eurodomest switches, I dont know what i'm doing wrong and can't find similar threads. I am using an raspberry pi 2 with the latest RASPBIAN WHEEZY kernel 3.18 and I also tried RASPBIAN JESSIE kernel 4.1. Am I the only one with difficulties? I am going to explain all the steps, maybe it will help others with the installation.

These are the problems:

1.I dont know if I installed and configured it the right way

2.pilight-receive doesn't pick up a signal
maybe because the cheap receiver or eurodomest remote.

3.eurodomest switch doesn't pick up a signal

Does my transmitter work with pilight? or is it the settings?
I tried lirc and gpio hardware settings.

This is how I installed pilight 7.0:

Because I use a rpi 2 I started with adding lirc-rpi to /boot/config.txt

Code:
sudo nano /boot/config.txt

I only needed to remove the "#" before lirc-rpi.
Then I updated with:
Code:
sudo rpi-update

Afther the update I used the following command to test for errors:
Code:
sudo modprobe lirc_rpi gpio_in_pin=17 gpio_out_pin=18
This command didn't give any error's

Next I installed pilight by the apt repository method:

https://www.pilight.org/getting-started/...stable_apt

Only installed the stable version.

Then I started pilight:
Code:
sudo service pilight start
went to the webui and beside the header with title, version,CPU AND ram the webui was empty.

stopped pilight:
Quote:sudo service pilight stop

Now it's time to add settings, of course in the config.json file.
I used the example from the manual and changed some things:

Code:
sudo nano /etc/pilight/config.json

Code:
{
        "devices": {
                "Lamp": {
                        "protocol": [ "kaku_switch_old" ],
                        "id": [{
                                "id": 10,
                                "unit": 0
                        }],
                        "state": "off"
                }
        },
        "rules": {},
        "gui": {
                "Lamp": {
                        "name": "just a lamp",
                        "group": [ "Lamps" ],
                        "media": [ "all" ]
                }
        },
"settings": {
                "log-level": 6,
                "pid-file": "/var/run/pilight.pid",
                "log-file": "/var/log/pilight.log",
                "webserver-enable": 1,
                "webserver-root": "/usr/local/share/pilight/",
                "webserver-http-port": 5001,
                "webserver-cache": 1
        },
        "hardware": {
                "433gpio": {
                        "sender": 0,
                        "receiver": 1
                }
        },
        "registry": {
                "pilight": {
                        "version": {
                                "current": "7.0"
                        }
                }
        }
}

And now when I start pilight there is one Lamp that I can switch on and off.
But my eurodomest doesn't pick up the signal.

Also tried this command:
Code:
pilight-send -p kaku_switch_old -i 3 -u 0 -t

I know that my transmitter and switch work because of an old tutorial with wiringpi. Not using pilight.

Thanks!
 
Reply
#2
Hi Marty,

I'm not sure what you need lirc for, do have an IR remote that you want to use? What GPIOs did you connect the 433MHz sender and receiver to, if you configured 17 and 18 for IR? You should check this first.

Anyhow, then you probably want to make sure the "unit" and "id" you use match those of the socket you want to switch. Your pilight-send command and config have differing values. Do you have suitable antennas attached to your sender and receiver? Does

Code:
sudo pilight-raw -L

return anything?

Cheers,
ramyres
 
Reply
#3
Thanks for the reply!

First the eurodomest switch can listen to a signal and then match with the transciever. The different values doesn't mather for testing I think.

I don't have and don't want to use a remote. I saw this in an pilight tutorial:

http://koffie.tweakblogs.net/blog/10251/...eel-2.html

My receiver is connected to pin11(GPIO 17) en transmitter pin12(GPIO 18)

Only have an antenna connected with the transmitter

The code
Code:
sudo pilight-raw -L
Give this result
Code:
pilight-raw: NOTICE: pilight-daemon instance found (3229)

I also switched receiver 1 and sender 0 in the hardware section
 
Reply
#4
Stick with the wheezy distribution until you have everything working.
(01-29-2016, 02:24 PM)Marty Wrote: ... Went to the webgui and beside the header with title, version,CPU AND ram the webgui was empty.
That is okay, you do need to define the settings for a protocol in the device section and a GUI element in the GUI section. Once that is done, you should see the GUI elements in your browser.
Remember that you do need to stop the pilight service before you edit the config.json file.

I assume that you have read the WIKI for more details on the Eurodomest configuration.
 
Reply
#5
(01-29-2016, 03:14 PM)Marty Wrote:
Code:
pilight-raw: NOTICE: pilight-daemon instance found (3229)

Note that you have to stop the pilight-daemon before you can use pilight-raw or pilight-debug. You might need an antenna for the receiver in order to pick up something useful.

The blog is on configuring version 3.0 (my dutch is not very good...). You better stick to the Wiki and manual.

Cheers,
ramyres
 
Reply
#6
(01-29-2016, 03:14 PM)Marty Wrote: a) ... The different values doesn't mather for testing I think.
b) ... My receiver is connected to pin11(GPIO 17) en transmitter pin12(GPIO 18)
c) ... I also switched receiver 1 and sender 0 in the hardware section
a) Depends - if you expect results on the GUI the id used with pilight-send has to match with the id defined in the device section of config.json, otherwise different devices are addressed.
b) pin 11 corresponds with wiringx GPIO 0, pin12 with GPIO 1, You will find all information in the WiKI.
c) See my answer to b), if you connected your receiver to pin 11, the correct configuration here is: "receiver": 0 and if you connected your transmitter to pin 12 it has to be "sender": 1
.
 
Reply
#7
Wow thanks guys!
What a geat forum with the fast reply's!

I rechecked al de settings and pins according to wo_rasp reply and it's working now Big Grin
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Real 433Mhz Remote is disturbed by pilight service henne111 2 134 10-06-2019, 06:18 PM
Last Post: wo_rasp
Tongue (solved) pilight 8.1.5-1-gc0a175e0 Chrashes fleisch 5 551 10-03-2019, 01:15 PM
Last Post: fleisch
  Starting pilight on boot: "cannot bind to the SSDP multicast network" pilino1234 4 325 09-29-2019, 02:08 PM
Last Post: tomk
  pilight for Raspbian Buster (raspberry pi 4) ? starob 29 2,381 07-15-2019, 08:45 PM
Last Post: curlymo
  pilight-receive Filteroption not working Alex 2 556 07-14-2019, 08:35 AM
Last Post: Alex
  pilight usb nano format conversion ettman8 2 441 07-14-2019, 08:32 AM
Last Post: curlymo
  pilight7_oregon on Raspberry pi3 Tueftler1983 0 221 07-04-2019, 01:49 PM
Last Post: Tueftler1983
  pilight 8.1.4 crashes after some hours Ulrich.Arnold 47 2,652 06-29-2019, 08:58 PM
Last Post: curlymo
  Raspberry PI, gpio-ir-tx and pilight not starting lordslash 5 845 06-11-2019, 05:19 PM
Last Post: curlymo
  pilight fails starting on boot Alex 5 739 06-09-2019, 06:02 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)