• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight-send doesn't seem to work - maybe wrong codes?
#1
Hi there,

first of all a big thanks for this really cool project.

I am currently taking my first steps using a raspy 2 running raspbian jessie.

I bought some cheap sender and receiver and wired them to my raspi.

Using pilight-receive I discovered the following codes when pressing 'on' on the remote control:

Code:
{
    "message": {
        "id": "F15",
        "unit": 63,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "rev2_switch",
    "uuid": "0000-b8-27-eb-c94918",
    "repeats": 1
}
{
    "message": {
        "id": "F15",
        "unit": 63,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "clarus_switch",
    "uuid": "0000-b8-27-eb-c94918",
    "repeats": 1
}
{
    "message": {
        "id": "F15",
        "unit": 63,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "rev2_switch",
    "uuid": "0000-b8-27-eb-c94918",
    "repeats": 2
}
{
    "message": {
        "id": "F15",
        "unit": 63,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "clarus_switch",
    "uuid": "0000-b8-27-eb-c94918",
    "repeats": 2
}
{
    "message": {
        "id": "F15",
        "unit": 63,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "rev2_switch",
    "uuid": "0000-b8-27-eb-c94918",
    "repeats": 3
}
{
    "message": {
        "id": "F15",
        "unit": 63,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "clarus_switch",
    "uuid": "0000-b8-27-eb-c94918",
    "repeats": 3
}
{
    "message": {
        "id": "F15",
        "unit": 63,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "rev2_switch",
    "uuid": "0000-b8-27-eb-c94918",
    "repeats": 4
}
{
    "message": {
        "id": "F15",
        "unit": 63,
        "state": "on"
    },
    "origin": "receiver",
    "protocol": "clarus_switch",
    "uuid": "0000-b8-27-eb-c94918",
    "repeats": 4
}

So far so good, but using pilight-send providing the discovered parameters does not work:

Neither
Code:
pilight-send -p clarus_switch --uuid=0000-b8-27-eb-c94918 --unit=63 --id=F15 --on
nor
Code:
pilight-send -p rev2_switch --uuid=0000-b8-27-eb-c94918 --unit=63 --id=F15 --on
did the trick.

Now I used pilight-debug to get:
Code:
--[RESULTS]--

time:        Mon Feb  1 19:01:02 2016
hardware:    433gpio
pulse:        12
rawlen:        50
pulselen:    184

Raw code:
216 612 234 594 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 234 612 216 612 216 612 234 612 216 612 216 612 216 612 216 612 216 612 216 612 630 198 630 198 612 216 612 198 216 6264
--[RESULTS]--

time:        Mon Feb  1 19:01:03 2016
hardware:    433gpio
pulse:        12
rawlen:        50
pulselen:    184

Raw code:
216 612 216 612 216 612 198 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 612 216 612 216 612 216 612 216 216 6264
--[RESULTS]--

time:        Mon Feb  1 19:01:03 2016
hardware:    433gpio
pulse:        12
rawlen:        50
pulselen:    184

Raw code:
216 612 216 612 216 612 216 612 234 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 630 216 612 234 594 216 612 216 612 216 612 216 612 612 216 612 216 612 216 612 198 216 6264
--[RESULTS]--

time:        Mon Feb  1 19:01:03 2016
hardware:    433gpio
pulse:        12
rawlen:        50
pulselen:    184

Raw code:
216 612 216 612 216 612 216 612 216 630 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 630 198 612 216 630 216 612 216 612 216 612 612 216 612 216 612 216 612 216 216 6264

Using
Code:
pilight-send -p raw -c "216 612 216 612 216 612 216 612 216 630 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 612 216 630 198 612 216 630 216 612 216 612 216 612 612 216 612 216 612 216 612 216 216 6264
works!

now my question: how can this be "integrated" so that I might use config.json?

Why isn't pilight-send not working when using rev2 or clarus?

Thanks for your support,

B

PS: Using V7.0
 
Reply
#2
Without more information on the remote control and the actual switch used, we can only guess.
 
Reply
#3
This is what I can tell:

Both switch and remote are labelled:

unitec 48113
Modell: EIM-827
3V 433,92 MHz
Inter-Union, 76828 Landau
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  apt.pilight.org stable Release' is not signed. thomasol 1 115 01-20-2020, 12:48 PM
Last Post: Mort
  pilight and SIGNALduino cc1101 Caleus 0 54 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 487 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 122 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 633 12-18-2019, 11:09 AM
Last Post: vanillaice30
  pilight error after update to 8.1.5 on Odroid C2 WitchDoctor 3 300 11-29-2019, 09:56 PM
Last Post: curlymo
  pilight crashing randomly PatiB 7 485 11-16-2019, 10:50 PM
Last Post: curlymo
  NOTICE: 433gpio send buffer full HuberDe 3 256 10-31-2019, 12:10 PM
Last Post: curlymo
  [Fixed] RaspberryPi4 pilight 8.1.5 - Send isn't working DominikB1993 4 515 10-18-2019, 10:25 PM
Last Post: DominikB1993
  Real 433Mhz Remote is disturbed by pilight service henne111 2 441 10-06-2019, 06:18 PM
Last Post: wo_rasp

Forum Jump:


Browsing: 1 Guest(s)