• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[solved] ds18b20 working but no temperature readout
#1
Hi all,
I'm using V7.0 of pilight and have a working temperature sensor connected to GPIO4
Code:
cat /sys/bus/w1/devices/10-00080299ab1e/w1_slave
2e 00 4b 46 ff ff 0b 10 6e : crc=6e YES
2e 00 4b 46 ff ff 0b 10 6e t=23062

the relevant part of my config.json is

Code:
"devices": {
                "temperature": {
                        "protocol": [ "ds18b20" ],
                        "id": [{
                                "id": "00080299ab1e"
                        }],
                        "poll-interval": 10,
                        "temperature": 11.456
                }
        },
        "rules": {},
        "gui": {
                "temperature": {
                        "name": "Temp-Sensor 1",
                        "group": [ "Wohnzimmer" ],
                        "media": [ "all" ],
                        "temperature-decimals": 1,
                        "show-temperature": 1
                }
        },

Unfortunately the pilight web-server just displays the default value "11.5" and never reads out the sensor values

Any idea what could be wrong?

THX and kind regards
 
Reply
#2
In my opinion, you do need to use the ds18s20 protocol, not ds18b20.
Please report back if this is the solution, so that i can update the WIKI.
 
Reply
#3
Thank you for this hint,
problem solved!

The sensor is named "DS1820" so I thought it is a 18b20, but I was wrong.

Kind regards
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  After upgrading 7.0 to 8.1.5 my flamingo SF-501P switches stopped working. gerrit312 23 2,543 04-30-2020, 02:58 PM
Last Post: ayeyebrazov
  tfa30 temperature-offset not working wseifert 2 786 04-09-2020, 02:46 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 1,045 03-08-2020, 12:14 AM
Last Post: beejayf
  filter stopped working after update to pilight 8.1.5 zlin50 19 2,519 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 943 01-01-2020, 06:45 PM
Last Post: Seebueb
  8.1.5 quietly stops working hepcat72 4 659 12-23-2019, 03:24 PM
Last Post: hepcat72
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 1,996 12-18-2019, 11:09 AM
Last Post: vanillaice30
  [Fixed] RaspberryPi4 pilight 8.1.5 - Send isn't working DominikB1993 4 1,146 10-18-2019, 10:25 PM
Last Post: DominikB1993
Tongue (solved) pilight 8.1.5-1-gc0a175e0 Chrashes fleisch 5 1,473 10-03-2019, 01:15 PM
Last Post: fleisch
  Solved - On / Off Command is the same command tigrablue 11 1,683 07-23-2019, 11:24 AM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)