• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Gui missing Protocol
#1
Shocked 
Hello,

to search for fails in my config i use:

pilight-daemon -D

and i have sort out all fails from my side,
BUT here comes a fail :

-> pilight-daemon: ERROR: config device #2 "gui", missing protocol <-

I don't understand that, wants he another protocol for the "guy"?:0
I try to fix that for a few hours...

my "gui" seems like the example here in the forum.

I hope we can find a solution Smile

Bastian
 
Reply
#2
Can you post your config.json (in code tags!) so that we can have a look?
 
Reply
#3
here ist my config.json:

Code:
{
{
        "devices": {
      "Regal": {
      "protocol": [ "heitech" ],
      "id": [{
                "systemcode": 23,
                "unitcode": 1
        }],
      "state": "on"
    },
        "gui": {
                "regal": {
            "name": "Regal",
            "group": [ "Basti" ],
            "media": [ "all" ],
            "readonly": 0
        }
},
        "settings": {
                "log-level": 6,
                "pid-file": "/var/run/pilight.pid",
                "log-file": "/var/log/pilight.log",
                "webserver-enable": 1,
                "webserver-root": "/usr/local/share/pilight/",
                "webserver-http-port": 5001,
                "webserver-cache": 1
        },
        "hardware": {
                "433gpio": {
                        "sender": 0,
                        "receiver": 1
                }
        },
        "registry": {
                "pilight": {
                        "version": {
                                "current": "7.0"
                        }
}
}
}
}
}

thanks for your fast answer Smile

Basti Angel
 
Reply
#4
Code:
{
"devices": {
"Regal": {
....
....
},
"gui": {
"regal": {
"name": "Regal",
Your device is "Regal", you do need to reference that one in the GUI section again, but you do reference: "regal" (with a lowercase r, change that to an Uppercase R and it will work.

The string you specify in the GUI section after "name": is the string printed on the GUI and not the device name.
 
Reply
#5
(02-09-2016, 08:03 PM)pilino1234 Wrote: (in code tags!)
Please do this, it makes it easier to find problems. As wo_rasp said, you need to use the exact same capitalization in your devices and gui sections.
 
Reply
#6
You can edit your post, put \[code\] and \[/code\] (without the \) before and after your config.json contents, respectively, and it will show in a code box, like this:
Code:
code shows up here
 
Reply
#7
Code:
{

        "devices": {
      "regal": {
      "protocol": [ "heitech" ],
      "id": [{
                "systemcode": 23,
                "unitcode": 1
        }],
      "state": "on"
    },
        "gui": {
                "regal": {
            "name": "regal",
            "group": [ "Basti" ],
            "media": [ "all" ],
            "readonly": 0
        }
},
        "settings": {
                "log-level": 6,
                "pid-file": "/var/run/pilight.pid",
                "log-file": "/var/log/pilight.log",
                "webserver-enable": 1,
                "webserver-root": "/usr/local/share/pilight/",
                "webserver-http-port": 5001,
                "webserver-cache": 1
        },
        "hardware": {
                "433gpio": {
                        "sender": 0,
                        "receiver": 1
                }
        },
        "registry": {
                "pilight": {
                        "version": {
                                "current": "7.0"
                        }
}
}
}
}


}

Thats in the Debug mode from the daemon the fail massage:


Code:
{ERROR: config device #2 "gui", missing protocol}

:X
 
Reply
#8
It also means fixing previous posts.
 
Reply
#9
no ideas? :S
 
Reply
#10
(02-10-2016, 01:48 AM)wo_rasp Wrote:
Code:
{
"devices": {
"Regal": {
....
....
},
"gui": {
"regal": {
"name": "Regal",
Your device is "Regal", you do need to reference that one in the GUI section again, but you do reference: "regal" (with a lowercase r, change that to an Uppercase R and it will work.

The string you specify in the GUI section after "name": is the string printed on the GUI and not the device name.
You need to make sure that capitalization is the same in the gui and devices sections of config.json
So, both entries need to be called "regal": { …
But the "name": key in the gui section can be anything, it is independent from the internal device name - it's what is shown in the WebGUI
 
Reply
  


Forum Jump:


Browsing: 1 Guest(s)