• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[solved] can't get GUI configured, error "...config gui element #1 "xyz", device not
#1
can't get GUI configured, get always error "...config gui element #1 "xyz", device not configured

this is my config.json for my weather device
Code:
.....
"device": {
        "wetter1": {
                "protocol": [ "alecto_wsd17" ],
                "id": [{
                        "id": 4095
                }],
                "temperature": 409.5
        }
},
        "rules": {},
"gui": {
        "wetter1": {
                "name": "Weather Station",
                "group": [ "Outside" ],
                "media": [ "all" ]
        }
},
.....
Do you have an idea why i do get that error?
[Feb 19 22:40:44:974946] pilight-daemon: ERROR: config gui element #1 "wetter1", device not configured

thanks in advanced for your help.
 
Reply
#2
Can you use code tags to format your post please? Otherwise it's really difficult to find problems with your config. Thanks Smile
 
Reply
#3
The [ ] and the {} brackets for the id do not embrace the term correctly.



(neither do the code tags of your post)

send from tapatalk
-- edit: is correct now
 
Reply
#4
Thanks for your help, but i really don't get it what do you mean with the brackets. i have used the same syntax, which i have found here -
https://wiki.pilight.org/doku.php/alecto_wsd17_v7_0
 
Reply
#5
No, you didn't.
The underlying problem is the missing understanding of the json syntax. The brackets i have mentioned arount the id parameter are not set correctly.
If you can't find it yourself there is a website to diagnose problems with json configuration syntax called jsonlint.com, hosting the jsonlint validator. Copy your config and let it validate your file.

send from tapatalk
 
Reply
#6
I think your problem is that you have "device" instead of "devices" in your config.
 
Reply
#7
@niek
you are right, it has to be devices, and

@pitpat
you are right as well, the wiki is not correct, it should state "devices" as well.
 
Reply
#8
Hello guys,

thanks for helping. Indeed, after using "devices" its working fine.
Really appreciate all your help.

Best regards,
Peter

Code:
...
"devices": {
        "wetter1": {
...
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 122 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 633 12-18-2019, 11:09 AM
Last Post: vanillaice30
  Raspberry 4B installation error royw 3 225 12-05-2019, 10:58 AM
Last Post: royw
  pilight error after update to 8.1.5 on Odroid C2 WitchDoctor 3 300 11-29-2019, 09:56 PM
Last Post: curlymo
  "FOR '2 MINUTE' FROM off" resulting in error hansrijn2 5 271 11-15-2019, 02:04 PM
Last Post: hansrijn2
  433gpio platform error after raspbian dist upgrade HuberDe 2 356 10-12-2019, 07:35 PM
Last Post: HuberDe
Tongue (solved) pilight 8.1.5-1-gc0a175e0 Chrashes fleisch 5 949 10-03-2019, 01:15 PM
Last Post: fleisch
  Solved - On / Off Command is the same command tigrablue 11 848 07-23-2019, 11:24 AM
Last Post: curlymo
  Config migration from pilight 7 .0 to 8.1.3 "Rules" Nonaamee 4 1,026 11-17-2018, 08:35 PM
Last Post: Nonaamee
  error pilightsend, recieve and control hansipi 2 559 11-04-2018, 03:46 PM
Last Post: hansipi

Forum Jump:


Browsing: 1 Guest(s)