• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AdHoc network with 2 Raspberry and 2 GPIO transmitter not working
#21
And all pilight versions are the same?
 
Reply
#22
Yes, did a fresh git clone --depth 5 -b development https://github.com/pilight/pilight.git on all three Raspis today.

Werner
 
Reply
#23
Can you try with the latest commit?
 
Reply
#24
after compiling with the latest commit (fresh clone) pilight does not start:

/var/log/messages:
Quote:Sep 3 16:53:46 pilight kernel: [357546.048212] Program pilight-daemon tried to access /dev/mem between 20200000->20201000.
Sep 3 16:53:46 pilight kernel: [357546.055612] pilight-daemon[17609]: segfault at d ip b6e36ffb sp bff9e140 error 4 in liblua5.1.so.0.0.0[b6e2c000+31000]

/etc/init.d/pilight status:
Quote:● pilight.service - LSB: Starts pilight-daemon
Loaded: loaded (/etc/init.d/pilight)
Active: active (exited) since Son 2017-09-03 16:53:46 BST; 3min 39s ago
Process: 17600 ExecStart=/etc/init.d/pilight start (code=exited, status=0/SUCCESS)

Sep 03 16:53:46 pilight systemd[1]: Starting LSB: Starts pilight-daemon...
Sep 03 16:53:46 pilight pilight[17600]: Starting : pilightSegmentation fault
Sep 03 16:53:46 pilight pilight[17600]: failed!
Sep 03 16:53:46 pilight systemd[1]: Started LSB: Starts pilight-daemon.
 
Reply
#25
Do you have the right platform configured?
 
Reply
#26
The master does not have GPIO capability because pilight is installed on a virtualized raspberry pi system (Debian + Pixel for PC & Mac), so which platform should I use for the master?
The slaves are raspberry pi 2 & 3 and have "gpio-platform": "raspberrypi2" resp. "gpio-platform": "raspberrypi3".

OK, used "gpio-platform": "none", works now. Have to compile & test, in a few minutes I report if success or not.

Werner


changes you made do not resolve the issue. Stil having interferences.

Werner
 
Reply
#27
Can you actually test if the nodes are sending or not with a LED?
 
Reply
#28
If you tell me how to connect the LED I can test it tomorrow.

Did instead a simple test:
Stopped pilight on one of the two nodes, switching lights on/off works on a device not working with both nodes enabled. Now enabled pilight on this node, disabled on the other node, switching lights on/off works again (tested with two different switches). So for me its clear, uuid config does not work.

Last week I was able to compile rewrite branch on my devices, tested uuid config and was pleased that with both nodes active not interference. But had problems with rules and switched back to development branch.

Werner
 
Reply
#29
What you do is the following:
1. Set UUID for 433.92 devices for one of the nodes.
2. Connect that node and when switching only the matching UUID node should sent.

I will test myself in the upcoming week.
 
Reply
#30
Did a git pull today in development branch and now UUID for 433.92 devices is working.
Thank you for fixing. Smile

Werner
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  ERROR: The Broadcom 2835 GPIO 0 is not set to output mode stuckinger 10 762 05-07-2019, 09:11 PM
Last Post: curlymo
  Issue send actions over Socket API in AdHoc network ggtrts 10 777 03-13-2019, 06:32 AM
Last Post: curlymo
  433 mhz receiver working on Raspberry pi with a hack knex 3 1,880 01-21-2018, 06:28 PM
Last Post: curlymo
Bug Bug report: WIFI dongle stops when gpio_switch.gpio = 20 woutput 16 5,028 01-03-2018, 10:11 PM
Last Post: zackdvd
  pilight on RPi with latest Arch stopped working Ypsilon 12 4,706 12-17-2017, 12:43 PM
Last Post: tinusv
  pilight-raw working in nightly? Cipher 8 1,703 08-30-2017, 09:35 PM
Last Post: curlymo
  development, orangepi pc+, "no gpio-platform configured" Twain 1 2,198 06-01-2017, 05:51 PM
Last Post: curlymo
  glibc 2.24 / kernel 4.8.x breaks things on raspberry pi? Forumkel 0 804 12-11-2016, 02:25 PM
Last Post: Forumkel
  Reset of GPIO ports / Detection of mobile phone NormBot 1 1,345 09-02-2016, 08:30 AM
Last Post: wo_rasp
  BUG: BMP180 in AdHoc Network Alex 5 1,581 06-19-2016, 02:24 PM
Last Post: Alex

Forum Jump:


Browsing: 1 Guest(s)