• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
brennenstuhl RCS 1000SN remote control not recognized by receiver
#1
Question 
I have the current pilight release running on my RasPi3 (using OSMC/Kodi as OS).

I bought these sender/receiver kit: KKmoon 5 Sets Alarmmodul 433MHz Wireless Transmitter Empfänger Alarmmodul
And these kit from Brennenstuhl for 12.99 EUR: Brennenstuhl Funkschalt-Set RCS 1000 N Comfort, 1507450

Until now, I just used the sender and everything is working fine Smile

Now I also connected the receiver. But `pilight-receive` doesn't get any information when I press a button on the original remote control (even not when the remote control is extremely close to the receiver's antenna).

When I toggle a switch in pilight's web GUI or app `pilight-receive` gets data:

Code:
{
       "origin": "sender",
       "protocol": "elro_800_switch",
       "message": {
               "systemcode": 24,
               "unitcode": 6,
               "state": "on"
       },
       "repeat": 1,
       "uuid": "0000-b8-27-eb-1b5325"
}

So the receiver is working properly. So what is wrong?

I can switch the wall sockets using pilight and the remote control. pilight receives data from it's own sender but not from the remote control. Any ideas?
 
Reply
#2
No, not necessarily. Currently pilight is either sending data or receiving data, but it is not performing both tasks at the same time.

As you can see the origin of the message received by pilight-receive is "sender", that means, pilight-receive is reporting the information transmitted.

You previously posted that you are using a sender but no receiver.
Is this your 1st time test with a receiver ?

If pilight-receive is not reporting anything at all, there is a good chance that your receiver or your GPIO Pin is defective, there is a configuration mismatch (e.q. software configuration in the settings section of config.json and the hardware wiring of your receivers output signal to the GPIO hardware pin is not matching), or the receiver won't work together with pilight.

You do need to post more details on your receiver / hardware environment / setup, to enable others to provide hints and suggestions and/or to diagnose the subject.
 
Reply
#3
Until last week I was using my RasPi2 with pilight and a sender only. Now, I installed my new RasPi3 with the same configuration and added the receiver. So yes, it is the 1st time testing a receiver.

Here you can see how I connected both to the RasPi's pins:

https://picload.org/image/rrdgwwid/pilight-receive.jpg

Sender: DATA (orange) to pin #11, VCC (yellow) to +5V pin #2, GND (green) to pin #39.

Receiver: DATA (red) to pin #12, VCC (black) to +5V pin #4, GND (brown) to pin #34. The 2nd DATA pin is not used.

The pins #5+6 (blue & lila) are used for an on/off switch.

config.json "settings" section (default, unchanged):
Code:
       "settings": {
               "log-level": 6,
               "pid-file": "/var/run/pilight.pid",
               "log-file": "/var/log/pilight.log",
               "webserver-enable": 1,
               "webserver-root": "/usr/local/share/pilight/",
               "webserver-http-port": 5001,
               "webserver-cache": 1
       },

Here's an image of the back side of my receiver:

http://picload.org/image/rrdrgicd/_20160707_232518.jpg

I have no more idea... anything else you need to know?

Is there a way I can check if my receiver module is working? I bought a set of 5 Wink so it would be easy to replace it. But before doing that I'd like to know if my connections are correct.

Thank you!
 
Reply
#4
I tried to switch the DATA pin on the receiver (web says no matter which one to use) and checked 4 of my receivers.

None of them did it.
 
Reply
#5
I made an error, i do not need the settings, but the hardware section of config.json, however i assume that it looks like this:
Code:
"hardware": {
   "433gpio": {
      "sender": 0,
      "receiver": 1
   }
}

I have one of your receivers YX-MK-5V in my drawer - retired, it is a bit difficult to get that type of receivers to work properly, one of the problems is to ensure that the voltage is 5 to 5.1V for that board.
I would be a bit hesitant to connect the data lines directly to the GPIO pins, i do recommend adding a 1 kOhm resistor between data I/O of the boards and the GPIO pins.

To get started you should get one of the receivers with an quarz oscillator and an antenna integrated on the PCB, like with the RXB6.

You can use pilight-raw to see if there is any incoming data or noise detected.

With pilight-raw you should see a major difference in the amount of data reported, when you connect the RxD data line to the PI. If you detect none, there is a chance that your PI's GPIO pin is defective, or simply the receiver is not working.
 
Reply
#6
Yes, the "hardware" section looks like you said (default).

What happens if I don't use a resistor for the DATA pin?

First, I tried `pilight-raw` but console says "command not found". I finally found it at `/usr/local/sbin/pilight-raw` and it didn't report anything.

How can I check if either the GPIO pin or the receiver is working (technically)? Couldn't I just connect a LED (+ resistor) to GPIO18 like shown here?
 
Reply
#7
Max voltage rating for the GPIO pins is 3.3V.
Not using a resistor can cause damage to the GPIO ports, the resistor limits the current drawn, together with the (programable) resistors of the PI that resistior acts as a voltage divider.

If pilight-raw reposts nothing, than there is no data detected on that GPIO pin.

With the wiringX libarary there is a program called pintest that will test the input functionality of your GPIO pins. You do need to remove all cables from the GPIO and do a reboot after the test. If that test reports that the GPIO pins are okay, the problem is with your receiver.
 
Reply
#8
I tried something different: I disconnected the receiver and switched the DATA cable of the sender to pin #18 (wiringX pin #1) and changed the config.json as follows:
Code:
"hardware": {
   "433gpio": {
      "sender": 1,
      "receiver": -1
   }
}

The sender still worked so the GPIO pin is not defect.

By the way here's my complete config.json with the original (recommended) connections: http://pastebin.com/x1yR14qW
 
Reply
#9
Can you explain in more detail why you want to use GPIO #18 ?
 
Reply
#10
I don't want to use pin #18. I just switched the sender from #17 to #18 to check if the pin is defect. I thought this test is quicker than the `pintest` tool which I haven't used before (and which istn't installed by default).

Result: sending works at pin #17 as well as #18 so both are working properly (not defect).

I guess - as you already remarked - the receiver doesn't get not enough power. Maybe at the Pi's 5V pins there's not exactly or not a stable 5V power supply and therefore the receiver cannot switch its power to "on".

Next test is to measure if there's 5V supply at the 5V pins. But I don't have the tools to do this so I need the help of my father. If less than 5V then I'll cut off a USB cable and use the power wires to supply the receiver with 5V - just to check if the receivers are working.

But actually, this seems to me like to much handicraft work... I'd rather like to "plug" in cables instead of soldering :-) Sorry.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Real 433Mhz Remote is disturbed by pilight service henne111 2 134 10-06-2019, 06:18 PM
Last Post: wo_rasp
  Remote with two crystals 10.000mhz and 7.3728 MSTNGSPRTS 0 149 04-18-2019, 10:33 PM
Last Post: MSTNGSPRTS
  error pilightsend, recieve and control hansipi 2 451 11-04-2018, 03:46 PM
Last Post: hansipi
Exclamation Brennenstuhl 433MHz RC C1 - pilight not work pitje87 0 569 10-31-2018, 12:38 PM
Last Post: pitje87
  [solved] kwmobile: repeating the remote signal doesn't work dawncrow 9 937 10-25-2018, 03:46 PM
Last Post: dawncrow
  ["SOLVED"] Not able to control intertechno ITR-1500 Kambaramba 12 1,511 10-03-2018, 05:52 PM
Last Post: curlymo
Rainbow Trying to control RF Celling FAN bennyboy 0 373 06-23-2018, 05:49 PM
Last Post: bennyboy
  Howto use GT-FSA-04 sockets with GT-3000 remote zackdvd 0 359 04-30-2018, 09:43 PM
Last Post: zackdvd
  deleyCON remote plug socket (arctec_screen_old protocol) itsMe 6 1,181 04-01-2018, 08:35 PM
Last Post: itsMe
  433MHz sender - receiver problem EndruK 1 755 02-17-2018, 02:24 PM
Last Post: EndruK

Forum Jump:


Browsing: 1 Guest(s)