• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] pilight 7.0 LAN interact connection - 2 Raspberrys
#1
Hello,

I'm using 2 Raspberry PI 3. I have installed the "Raspbian Jessie Lite" on the first Raspberry and, after installing pilight with "git clone master branch", i have cloned the entire operating system to the second Raspberry.

All works well but the first time when i'm connecting both Raspberrys, i believe that the first is connecting to the second.

Raspberry 1:
sudo pilight-receive

Raspberry 2:
sudo service pilight restart

And the raspberry 1 auto disconnect the pilight-receive listener.

This can be because it's a clone? I want to use 3 raspberrys.

Now i understand. The process pilight-receive is scanning for UPNP service. I'll read more about pilight configuration.
I will write when I have a solution.
 
Reply
#2
When i'm putting the option: "whitelist": "localhost" or "127.0.0.1" the pilight drops all input connections out of the box; but the pilight-receive don't connect to localhost.

I tried it with the "--server" option but dont works. 

The solution is:

add to file /etc/pilight/config.json, in the section settings:
"whitelist": "Raspberry IP" <- for example: 192.168.1.250

Note: stop the pilight service before modifying this file.
 
Reply
#3
How to disable the SSDP protocol and force the local connection?
with the parameter --server=localhost don't work.
Which is the pilight service port? With UPNP every time gets new port.

I want to disable UPNP and use common socket listener without publish it on UPNP.

Is possible?
 
Reply
#4
Hey,

use the standalone and the port parameter in the config.json (link). And for the pillight-receive/send the parameter -S for daemon-IP and -P for daemon-port (link

Greetings,
tobid
 
Reply
#5
(07-10-2016, 03:11 PM)tobid Wrote: Hey,

use the standalone and the port parameter in the config.json (link). And for the pillight-receive/send the parameter -S for daemon-IP and -P for daemon-port (link

Greetings,
tobid

Thank you very much.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight-control TML 13 325 05-27-2020, 07:51 AM
Last Post: curlymo
  API Requests by HTTP from other devices fore use in pilight scootermacro 2 161 05-10-2020, 08:19 AM
Last Post: scootermacro
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 2,032 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 508 03-08-2020, 12:14 AM
Last Post: beejayf
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 530 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 650 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 444 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 1,358 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 545 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 1,418 12-18-2019, 11:09 AM
Last Post: vanillaice30

Forum Jump:


Browsing: 1 Guest(s)