• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight not starting with edited config
#1
Hey there!
Today i was experimenting with my pi and started to get the 433mhz sender and receiver running with our rc-switches. After getting everything to work using pilight i tried to get the switches into the webview. After entering only 1 device into the devices section and also the gui section pilight stopped starting. My current not working config is the following: LINK
After entering the sudo service pilight start command the bash just jump into a new line as it would when working. I can't get into the webview nor can i enter and send or receive commands. If i replace the new config with the default one which i had a backup from it's working as intended.
Am i missing anything? I am running the newest apt-get version on a newly installed raspberry pi2 osmc.

Thanks in advance for any kind of help,
Departet
 
Reply
#2
It's not a good idea to post an 'image' of your json file! That makes it hard to check it and nearly impossible to use an syntax checker .. maybe you did that already? Result?
 
Reply
#3
I can't find any. Uploaded the text if you want to check it yourself.
http://pastebin.com/vqehjVt1
 
Reply
#4
The syntax is ok.

By the way here you can find the JSON validator:
http://jsonlint.com/

The device you inserted is not conform with the settings in the wiki.

You should read the WIKI specially THIS
and also the MANUAL and correct your settings
Terrarium:  RPi Model B Rev 2 / pilight 8.1.2 / stretch
Aquarium: RPi Model B Plus Rev 1.2 / pilight 8.0.6 / jessie
 
Reply
#5
Thumbs Up 
Thank you sooo much! I knew i had systemcodes but i didn't find any info for specific settings on my own. I was on the supported devices page and even googled stuff like "pilight devices systemcode" but couldnt find the right answer.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  ERROR: failed to read config. stack: 2 Stefan 6 216 02-03-2020, 09:37 PM
Last Post: curlymo
  raspberry pi 4 config.json Stefan 2 183 02-02-2020, 09:59 AM
Last Post: Stefan
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 163 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 272 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 155 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 649 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 177 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 823 12-18-2019, 11:09 AM
Last Post: vanillaice30
  pilight error after update to 8.1.5 on Odroid C2 WitchDoctor 3 384 11-29-2019, 09:56 PM
Last Post: curlymo
  pilight crashing randomly PatiB 7 629 11-16-2019, 10:50 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)