• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight-daemon fails to start 2 of 3 times
#1
Hi,

I followed a tutorial so I can switch some wireless sockets using the pi.

When I try to start the pilight daemon using:
sudo pilight-daemon

I don't get any error message from that.

But when I then use
sudo pilight-send ...

I get the error message
[ Nov 30 20:10:27:57369] pilight-send: NOTICE: no pilight ssdp connections found

but when I try sudo pilight-daemon again and again, pilight-send works sometimes. So most of the times it works after starting the daemon 3 times.

Does someone have any idea what could be the problem?

Thank you and kind regards,
tietze111

Do you know I can't post on this forums when I don't input the message manually in the post request using tamper data? The post doesn't send the message with it, I have to put it in there again. Can anyone even answer me?
 
Reply
#2
Did you try the suggestions in the FAQ?

About the forum issues, can you open a new thread about it?
 
Reply
#3
Thank you, didn't know that it was a frequently asked question, should've thought about that. I already checked the interfaces to be set correctly, since I found that using google.

But I didn't try this yet, will do when I'm at home:
Quote:sudo iptables -A INPUT -s 127.0.0.1 -j ACCEPT

Also, I use Lirc on the same Pi to control my TV using a infrared lamp. Can that be the reason?

I thought about building my own webui, so I have Lirc and pilight on the same frontend. So can I just disable SSDP completely and execute the signals using command line (pilight send ...)? I will probably use node.js
 
Reply
#4
(12-02-2016, 01:28 PM)tietze111 Wrote: I thought about building my own webui, so I have Lirc and pilight on the same frontend. So can I just disable SSDP completely and execute the signals using command line (pilight send ...)? I will probably use node.js

It would be better to use the socket API for this, see https://manual.pilight.org/en/api for documentation.
 
Reply
#5
Setting a static ip address in the file /etc/network/interfaces fixed my problems.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  hardware info lost after pilight restart Rschnauzer 3 139 03-17-2021, 11:44 AM
Last Post: Rschnauzer
Question pilight stopped working sl4m01 3 799 11-26-2020, 09:17 PM
Last Post: PPacman
  pilight-raw changes output format from 7 to 8 Rschnauzer 1 561 11-26-2020, 01:52 PM
Last Post: curlymo
Question pilight nightly webgui offline after some hours fleisch 4 549 10-26-2020, 05:19 PM
Last Post: fleisch
  pilight bugs Ascenion 1 583 03-23-2020, 06:29 PM
Last Post: curlymo
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 4,014 12-21-2019, 09:46 AM
Last Post: curlymo
  pilight-control modify values coolinx 16 3,210 11-13-2019, 08:02 PM
Last Post: curlymo
  Bug: double free or corruption in pilight-send blackzombie 12 2,771 10-07-2019, 08:15 PM
Last Post: blackzombie
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 907 08-13-2019, 05:43 PM
Last Post: curlymo
  pilight Nano USB interface curlymo 228 143,174 07-10-2019, 06:14 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)