• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Webserver unavailable after default installation
#11
@crashoverride01
The wiringX crash is due to using Kernel 4.9.x.

You are using the branch v7_oregon from my github repository.
That is the branch i am using for development of various additonal protocol modules (in this case Oregon V2.1), the wiringX library used within this branch is not compatible with Kernel 4.9.13.
The stable pilight branch is not supporting Kernel 4.9.13 either.

Please use instead from my repository the branch test_dev_stable if you need the oregon protocol or the latest version of the main pilight development branch. .

I keep the test_dev_stable branch updated with the V7 pilight development branch and integrate support for several additional protocols not supported by the main development branch into it as well. On a regular base I test this branch for compatibility using pi1, pi2 and pi3 hardware using raspbian and the most recent linux kernels.
I am not aware of wiringX or webgui related problems with this branch.
 
Reply
#12
@wo_rasp
Thanks for informations.

i have taken the nighly build repo and installed with apt-get update.
it updated also the kernel.

Code:
sudo uname -a
Linux homeboxpi 4.4.50+ #970 Mon Feb 20 19:12:50 GMT 2017 armv6l GNU/Linux
Code:
sudo pilight-daemon --version
pilight-daemon version v7.0-176-g8a9fc4f
In last step i remove the https of the config.json and now it works that the webserver is running.

Thnks for help @all
 
Reply
#13
(03-08-2017, 02:58 PM)crashoverride01 Wrote: In last step i remove the https of the config.json and now it works
Yes, that would have caused pilight to start a HTTPS server, which won't work by default due to the lack of a SSL certificate.
 
Reply
#14
i got another problem:

starting the daemon mode is working but if i opened the webgui by browser i get the message "Connection lost! Touch for reload" and the following by daemon tail

Code:
[Mar 08 15:13:06:976110] pilight-daemon: DEBUG: broadcasted: {"values":{"cpu":11.2228329537480835,"ram":0.8366884750880724},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-6e358d"}
[ Mar 08 15:13:07:44996] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51668
[Mar 08 15:13:08:558320] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51668
[Mar 08 15:13:08:579107] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51673
[Mar 08 15:13:08:676385] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51675
[Mar 08 15:13:08:896321] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51677
[Mar 08 15:13:08:958451] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51679
[  Mar 08 15:13:09:1061] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51681
[ Mar 08 15:13:09:75529] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51684
[ Mar 08 15:13:09:93776] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51686
[Mar 08 15:13:09:192285] pilight-daemon: INFO: client connected, ip 192.168.1.25, port 51688
[Mar 08 15:13:09:982369] pilight-daemon: DEBUG: cpu: 5.252448%, ram: 0.836688%
[Mar 08 15:13:09:984958] pilight-daemon: DEBUG: socket write succeeded: {"values":{"cpu":5.2524482470110412,"ram":0.8366884750880724},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-6e358d"}

[Mar 08 15:13:09:987549] pilight-daemon: DEBUG: broadcasted: {"values":{"cpu":5.2524482470110412,"ram":0.8366884750880724},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-6e358d"}
[Mar 08 15:13:12:993494] pilight-daemon: DEBUG: cpu: 0.189932%, ram: 0.836688%
[Mar 08 15:13:12:996123] pilight-daemon: DEBUG: socket write succeeded: {"values":{"cpu":0.1899319228688715,"ram":0.8366884750880724},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-6e358d"}

[Mar 08 15:13:12:998624] pilight-daemon: DEBUG: broadcasted: {"values":{"cpu":0.1899319228688715,"ram":0.8366884750880724},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-6e358d"}
[  Mar 08 15:13:16:3953] pilight-daemon: DEBUG: cpu: 0.191146%, ram: 0.836688%
[  Mar 08 15:13:16:6535] pilight-daemon: DEBUG: socket write succeeded: {"values":{"cpu":0.1911458864539069,"ram":0.8366884750880724},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-6e358d"}

[  Mar 08 15:13:16:9316] pilight-daemon: DEBUG: broadcasted: {"values":{"cpu":0.1911458864539069,"ram":0.8366884750880724},"origin":"core","type":-1,"uuid":"0000-b8-27-eb-6e358d"}
 
Reply
#15
Which browser are you using? Depending on the browser, you may need to turn off websockets and use AJAX instead. The pilight manual about webserver settings documents this. The settings is called "webgui-websockets".
 
Reply
#16
After i put the command on cli
Code:
sudo iptables -A INPUT -s 127.0.01 -j ACCEPT
then i can restart the pilight service!!!! Than it works.
 
Reply
#17
Exclamation 
Hi,
I bumped into the same problem after my system upgrade today
(..., apt-get deselect-upgrade, etc).

I had pilight running fine for a few months, but after the upgrade, the webinterface on port 5001 bhad dissappeared, which induced some confusion for me.

I Studied this and some other discussions, looked into kernel downgrades, etc which were to complex for a quick fix, and the solution appeared relatively simple (for me at least, in the end)

An additional strange thing which misguided me for a while, was that the errors eere parsed into the log file (/var/log/pilight.log) instead of the file
/var/log/pilight.err:

Code:
[Jun 02 13:46:11:878550] pilight-daemon: ERROR: no gpio-platform configured                                                                    
[Jun 02 13:46:11:879552] pilight-daemon: ERROR: could not initialize 433gpio hardware module

However, in the end I got pilight (and webinterface) running again by adding the explicitly configuration of the gpio-platform in the /etc/config.json file:
Code:
"gpio-platform": "raspberrypi2",
inside the settings section:
Code:
"settings": {
...,
"gpio-platform": "raspberrypi2",
...
}

Looks like a Xwiring connected thing, which was not so strict enforced in the previous version I had been using upto today.
I could not find a documented list of valid platforms easily, fortunately a misspell in the option is sufficient to get a list of valid options, for example in my case today:

Code:
[Jun 02 15:44:53:910078] pilight-daemon: ERROR: The raspberrypi2b2 is an unsupported or unknown platform                                                                                                                                
        supported wiringX platforms are:
        - odroidxu4
        - odroidc2
        - odroidc1
        - raspberrypi3                                          
        - raspberrypi2
        - raspberrypizero
        - raspberrypi1b+
        - raspberrypi1b2
        - raspberrypi1b1
        - hummingboard_edge_dq
        - hummingboard_gate_dq
        - hummingboard_edge_sdl
        - hummingboard_gate_sdl
        - hummingboard_base_dq
        - hummingboard_pro_dq
        - hummingboard_base_sdl
        - hummingboard_pro_sdl
        - orangepipc+
        - bananapim2                                                                        
        - bananapi1
        - pcduino1

I hope this helps other people that might bump into the same problem,

Cheers
Hans
 
Reply
#18
After adding
Code:
"settings": {
...,
"gpio-platform": "raspberrypi3",
...
}

everything works fine again... I could have saved hours of my life reading your hint before ;-)

Thank you!
 
Reply
#19
Thanks a lot!

By default the config.json contained the following:

Code:
"gpio-platform": "none",

Changing it to:

Code:
"gpio-platform": "raspberrypi3",

solved the problem for me as well!
Cheers
 
Reply
#20
Today I made an update on my RPi

Code:
sudo apt-get update
sudo apt-get dist-upgrade

pilight is now on 8.1.

Code:
pilight-daemon version v8.1.0-nightly-f6b8db0e

After this update my webinterface is no langer reachabel.
When I try to get it up in the browser, I receive 404 Not Found.

So I found this entry in the forum here that I have to add gpio-platform to my config (which ist still from version 7.0 of pilight!).
But the webserver is still not working.
So I made a rpi-update to kernes 4.14 because pilight 7 was not working with actually kernel.

But nothing helped to bring back the webgui......

The debug calls me that the webgui is running:

Code:
[May 19 14:17:27:797200] pilight-daemon: INFO: version v8.1.0-nightly-f6b8db0e
[May 19 14:17:27:797854] pilight-daemon: DEBUG: ssdp sent search
[May 19 14:17:27:899629] pilight-daemon: INFO: no pilight daemon found, daemonizing
[May 19 14:17:27:925236] pilight-daemon: INFO: daemon listening to port: 42097
[May 19 14:17:27:926472] pilight-daemon: DEBUG: new thread socket, 1 thread running
[May 19 14:17:27:926659] pilight-daemon: DEBUG: new thread ssdp, 2 threads running
[May 19 14:17:27:926826] pilight-daemon: DEBUG: new thread sender, 3 threads running
[May 19 14:17:27:926971] pilight-daemon: DEBUG: new thread broadcaster, 4 threads running
[May 19 14:17:27:935046] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 50258
[May 19 14:17:27:935405] pilight-daemon: DEBUG: client fd: 14
[May 19 14:17:27:935463] pilight-daemon: DEBUG: client id: 1
[May 19 14:17:27:937200] pilight-daemon: [b]INFO: secured webserver started on port: 5002 (fd 15)[/b]
[May 19 14:17:27:937270] pilight-daemon: DEBUG: new thread receive parser, 5 threads running
[May 19 14:17:27:937332] pilight-daemon: [b]INFO: regular webserver started on port: 5060 (fd 16)[/b]
[May 19 14:17:27:937571] pilight-daemon: DEBUG: new thread events client, 6 threads running
[May 19 14:17:27:938012] pilight-daemon: DEBUG: new thread events loop, 7 threads running
[May 19 14:17:27:939174] pilight-daemon: DEBUG: ssdp sent notify
[May 19 14:17:27:939657] pilight-daemon: DEBUG: ssdp sent search
[May 19 14:17:27:940020] pilight-daemon: DEBUG: ssdp sent notify
[ May 19 14:17:28:49847] pilight-daemon: INFO: new client, ip: 192.168.168.190, port: 54248
[ May 19 14:17:28:49910] pilight-daemon: DEBUG: client fd: 18
[ May 19 14:17:28:49936] pilight-daemon: DEBUG: client id: 2

So I need help to get my pilight working again!!

EDIT:
Found it!!!

I have to change this path in the config:

Code:
"webserver-root": "/usr/local/share/pilight",

to:

Code:
"webserver-root": "/usr/local/share/pilight/webgui",

Now the webgui is reachable again!
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Webserver/GUI not running / no access Sisko4 2 1,649 03-21-2017, 03:05 PM
Last Post: pilino1234

Forum Jump:


Browsing: 1 Guest(s)