• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Webserver unavailable after default installation
#21
(05-19-2018, 03:29 PM)Pikeman Wrote: Today I made an update on my RPi

Code:
sudo apt-get update
sudo apt-get dist-upgrade

pilight is now on 8.1.


Code:
"webserver-root": "/usr/local/share/pilight",

to:

Code:
"webserver-root": "/usr/local/share/pilight/webgui",

Now the webgui is reachable again!




Hi there, i tried what you said.
The webserver-root is default, so i hadn't to change.

I ve a fresh installed raspberry 1b with raspbian an installed the stable pilight (v8.1.0-nightly-f6b8db0e).
Yesterday the webgui worked, but i had a problem so i reinstalled it.
Raspberry got a dynamic ip from rooter and webgui doesnt works.

Here is my config, maybe somebody can help me.

Quote:{
"devices": {},
"rules": {},
"gui": {},
"settings": {
"log-level": 6,
"pid-file": "/var/run/pilight.pid",
"log-file": "/var/log/pilight.log",
"webserver-enable": 1,
"webserver-root": "/usr/local/share/pilight/webgui",
"webserver-http-port": 5001,
"webserver-cache": 1
},
"hardware": {
"433gpio": {
"sender": 0,
"receiver": 1
}
},
"registry": {}
}

Interesting... i changed something now. Deleted the things in hardware and now webgui works.

Quote:"webserver-cache": 1
},
"hardware": {
},
"registry": {}
}
so where is the fault?
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Webserver/GUI not running / no access Sisko4 2 1,497 03-21-2017, 03:05 PM
Last Post: pilino1234

Forum Jump:


Browsing: 1 Guest(s)