• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight without LAN/WLAN on Raspberry Pi
#1
Hello,
after configuration of pilight on a headless Raspberry Pi Zero via WLAN I want to run the actual application without any network connection.
Is that possible?
Maybe some kind of configuration?
Regards
Hans
 
Reply
#2
Sure it's possible, the 433 MHz sending will still work. However, lots of features will be unavailable, such as the webgui, the socket API, any network related protocols (such as weather services), and the SSDP adhoc network. If you don't need any of these, you should be fine.
 
Reply
#3
You mentioned 433 MHz sending is still possible, but what about receiving? Without a network connection my motion detector will not be received.
I do not need any network related functions.
 
Reply
#4
You do need to configure a network and the loopback adaptor (typically 127.0.0.1), otherwise pilight won't start


Gesendet von iPhone mit Tapatalk
 
Reply
#5
Hopefully I'm able to configure this loopback adapter. But I'll give it a try.
Thanks for your support meanwhile.
 
Reply
#6
Unfortunately I was not able to run pilight without a network connection after making all the changes which are recomended in the pilight manual in the section "Fixing SSDP connection issues".
Is that the part which also establishes the loopback adapter which you mentioned?
The error message in pilight.log is: ERROR: cannot bind to the ssdp multicast network.
 
Reply
#7
Photo 
For some reason pilight keeps running when I start without a network.
Also the incomming events from the moving sensor will be recognized. But the expected actions - starting a program- will not be executed.
The only change in config.json is taking out every network reference in the settings section (webserver=0, standalone=1)
Here is pilight.log:
Code:
[Apr 19 17:46:53:160928] pilight-daemon: INFO: rule #1 BWMEin was parsed in 0.000740 seconds
[Apr 19 17:46:53:161677] pilight-daemon: INFO: rule #2 BWMAus was parsed in 0.000638 seconds
[Apr 19 17:46:53:165080] pilight-daemon: INFO: version v7.0
[Apr 19 17:46:53:166131] pilight-daemon: INFO: daemon listening to port: 42862
[Apr 19 17:46:53:239718] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 38100
[Apr 19 17:46:53:379212] pilight-daemon: NOTICE: no pilight ssdp connections found
[Apr 19 17:46:53:380539] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 38102
[Apr 19 17:47:12:577599] pilight-daemon: INFO: executed rule: BWMEin
[Apr 19 17:47:12:584738] pilight-daemon: INFO: started "switch" action for device "Program1"
[Apr 19 17:47:12:587101] pilight-daemon: INFO: stopped "switch" action for device "Program1"
[Apr 19 17:47:17:693157] pilight-daemon: INFO: executed rule: BWMAus
[Apr 19 17:47:17:701058] pilight-daemon: INFO: started "switch" action for device "Program0"
[Apr 19 17:47:17:703517] pilight-daemon: INFO: stopped "switch" action for device "Program0"
[Apr 19 17:47:41:517157] pilight-daemon: INFO: removed stale pid_file /var/run/pilight.pid
And this is my config.json:
Code:
{
    "devices": {
        "BWM3": {
            "protocol": [ "elro_400_switch" ],
            "id": [{
                "systemcode": 21,
                "unitcode": 13
            }],
            "state": "off"
        },
        "buzzer": {
            "protocol": [ "relay" ],
            "id": [{
                "gpio": 13
            }],
            "state": "on",
            "default-state": "on"
        },
        "Program0": {
            "protocol": [ "program" ],
            "id": [{
                "name": "test0"
            }],
            "program": "/bin/bash",
            "arguments": "/home/pi/gpio0.sh",
            "stop-command": "kill $(prep gpio0.sh)",
            "start-command": "/home/pi/gpio0.sh &",
            "state": "stopped",
            "pid": 0
        },
        "Program1": {
            "protocol": [ "program" ],
            "id": [{
                "name": "test1"
            }],
            "program": "/bin/bash",
            "arguments": "/home/pi/gpio1.sh",
            "stop-command": "kill $(prep gpio1.sh)",
            "start-command": "/home/pi/gpio1.sh &",
            "state": "stopped",
            "pid": 0
        }
    },
    "rules": {
        "BWMEin": {
            "rule": "IF BWM3.state IS on THEN switch DEVICE Program1 TO running",
            "active": 1
        },
        "BWMAus": {
            "rule": "IF BWM3.state IS off THEN switch DEVICE Program0 TO running",
            "active": 1
        }
    },
    "gui": {},
    "settings": {
        "log-level": 6,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "standalone": 1,
        "webserver-enable": 0
    },
    "hardware": {
        "433gpio": {
            "sender": 0,
            "receiver": 1
        }
    },
    "registry": {
        "pilight": {
            "firmware": {
                "version": 3,
                "lpf": 80,
                "hpf": 16000
            },
            "version": {
                "current": "7.0"
            }
        }
    }
}

Well, somebody might think pilight without a network connection makes no sense. But I think the most important thing of pilight is the support of the uge count of sensors.
And recognizing of a sensor does not absolutly requiring a "signal" into a network.
I my case the noise of a buzzer is enough.
 
Reply
#8
Hello,
may be my last posting was a little bit missunderstanding. So I will give it another try.
I am running pilight without a network connection.
The expected event from the motion detector will be recognized by pilight, which is documented by the log entry "INFO: started "switch" action for device "Program1". But the Program1 does not start, although no error messages is befor the next log entry "INFO: stopped...".
The same happens when I direct the rule to a buzzer device with the relay protocol. The associated GPIO will not switch.
But everything works fine with a network connection.
Can somebodey please help me?
Regards
Hans
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Can't send or receive on Raspberry Pi Zero W ChristophH 6 35 9 hours ago
Last Post: ChristophH
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 1,141 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 203 03-08-2020, 12:14 AM
Last Post: beejayf
  raspberry pi 4 config.json Stefan 2 253 02-02-2020, 09:59 AM
Last Post: Stefan
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 275 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 335 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 235 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 833 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 268 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 991 12-18-2019, 11:09 AM
Last Post: vanillaice30

Forum Jump:


Browsing: 1 Guest(s)