• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight stopped working after updating RPi3
#1
I have been using pilight successfully and it worked perfectly. Today I ran:

Code:
sudo apt-get update
sudo apt-get upgrade

to update my RPi3 and suddenly pilight doesn't work anymore. I am using RPi3 and running Raspbian.

I get the following errors in my log:

Code:
[Apr 28 19:26:39:584493] pilight-daemon: INFO: version v7.0
[Apr 28 19:26:39:688755] pilight-daemon: INFO: no pilight daemon found, daemonizing
[Apr 28 19:26:39:689108] pilight-daemon: INFO: daemon listening to port: 5000
[Apr 28 19:26:39:691128] pilight-daemon: ERROR: hardware not supported
[Apr 28 19:26:39:692609] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 34582
[Apr 28 19:26:39:692932] pilight-daemon: ERROR: could not initialize 433gpio hardware module

Does anybody know how to solve my problem? Is there a way to revert RPi3 software to the state before I updated?

Any help would be greatly appreciated.

Ok, I figured it out. The problem is in firmware. I downgraded with:

rpi-update 52241088c1da59a359110d39c1875cda56496764

and it's all working now.
 
Reply
#2
Use the development branch, the newer 4.9 kernel requires an update of the wiringX lib.


Gesendet von iPhone mit Tapatalk
 
Reply
#3
Hi,

I have the same problem.
After an "apt-get update && apt-get upgrade" and after installing the new updates my pilight installation doesn't work anymore. I have already installed the nightly version but thats not the solution.

What can I do?

Thank you very much!

Best regards
 
Reply
#4
Same here.
After updating RPI3 today pilight is no longer working.
Nightly branch didn't help:
deb http://apt.pilight.org/ nightly main

Greetings,
Heiko
 
Reply
#5
As said already, you either do need to switch back to an older Kernel or use the latest nightly respectively development version.
pilight V7 main master branch will not work with 4.9 kernels.
To determine which Kernel you have run the shell command: uname -a


Gesendet von iPhone mit Tapatalk
 
Reply
#6
Hi,

I don't understand you. You sayed we should install the latest nightly? We have already installed the latest nightly (pilight-daemon version v7.0-184-ga40f146), but it doesn't works! Is it the only solution to switch back to an older kernel or should the nightly build run with the kernel 4.9?!

Thank you!

Best regards
 
Reply
#7
I want to know as well!
 
Reply
#8
It could be that v7.0-184-ga40f146 is not compatible with Kernel 4.9.x (e.q. the latest github version of the development branch won't work with Kernel 4.9.x either).
I am relatively sure that v7.0-176-g8a9fc4f is compatible.
 
Reply
#9
Hi,

how is it possible to install exactly the version v7.0-176-g8a9fc4f ?

Thank you!

BR
 
Reply
#10
I would use the git checkout command and manually compile it, however a fix is under development and a new version will be available soon.


Gesendet von iPhone mit Tapatalk
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  update pilight Traeumer 3 521 10-08-2021, 09:19 PM
Last Post: Manitu
  pilight does not start, Deamon is not found. Dekkertje 7 1,048 10-08-2021, 07:49 PM
Last Post: DesmondOrask
  pilight-flash not working danny 15 3,957 10-05-2021, 11:36 PM
Last Post: DesmondOrask
  problem publish to pilight MQTT server Emiks5 9 2,043 09-12-2021, 07:27 AM
Last Post: DesmondOrask
  Hardware Switch and pilight-send/-control iTommix 3 713 02-14-2021, 09:25 PM
Last Post: iTommix
  pilight error after update to 8.1.5 on Odroid C2 WitchDoctor 4 1,928 02-07-2021, 09:50 PM
Last Post: pilightalpine
  pilight in Docker not accepting connections due to possible SYN flooding akloeckner 3 618 02-07-2021, 04:22 PM
Last Post: akloeckner
  ping not working, am I missing something? steffeneilers 2 435 02-03-2021, 08:09 PM
Last Post: steffeneilers
Lightbulb working MQTT in version v8.1.5-nightly-1af4c284 fleisch 1 792 12-28-2020, 05:04 PM
Last Post: psbest
  pilight-debug format Rschnauzer 2 591 12-17-2020, 07:09 PM
Last Post: Rschnauzer

Forum Jump:


Browsing: 1 Guest(s)