• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Fantasia ceiling fan / light
Hi all

I'm new to this, so I'll try and stick to the rules. I've searched the forums but I can't find anything which works for me.

I have a pair of ceiling fans with integrated lights, remote controlled of course. They are identical and are made by Fantasia, though I believe they are related to Westinghouse. I have managed to capture the raw codes sent by the remote control but sending them with pilight-send doesn't turn the fan or light on. I read this thread and this thread and I note the poster had some success after capturing 3 raw codes, and trying each one. I have tried the same but none of the codes work for me. I have tried the following two (there is a third but I can't find it in my history right now)

pilight-send -p raw -c "354 354 708 354 708 354 708 708 354 354 708 708 354 708 354 708 354 708 354 708 354 708 354 354 708 12036"

pilight-send -p raw -c "355 355 710 355 710 355 710 710 355 355 710 710 355 710 355 710 355 710 355 710 355 710 355 355 710 12070"

It's definitely not a range problem, I've placed the pi directly next to the receiver. And I have a couple of remote control sockets which do work using the raw codes and pilight-send. The only difference is, the remote sockets are picked up by pilight-receive whereas the fan remote is not. That said, I am not using the protocol received by pilight-receive, I am using the raw codes only. Does it make a difference that the remote is supported by a protocol? I don't really need a protocol creating for this (but I am happy to assist if it's wanted by the community), I am happy to use raw codes only. But right now, I am unable!

Hi Simon, welcome to the forums!

What RF hardware are you using with your Pi? As in, what receiver are you using, and are you using a ATTiny filter?
There are some receivers which are notoriously bad at picking up working raw pulsetrains. The ones in the pilight shop are the ones that have proven to be the most successful.
Sending raw codes does not require implementation of a protocol.
Successful transmission of raw codes is the base for a protocol implementation.

There are several possibilities:
1. You have not captured all raw Pulses required
2. The pulses change from pulsetrain to pulsetrain e.q. With each press of a button, different pulses are sent

Gesendet von iPhone mit Tapatalk

Thank you for the welcome and for the replies.

The receiver I am using is in the picture here. It came with a Lloytron doorbell kit for Raspberry Pi and I've only just started playing with the pilight software. I am not using a filter at the moment. The sender is admittedly one of the cheap ones labelled FS1000A. As I said I am new to this and the sender was dirt cheap so I didn't mind buying one to experiment. In my defence, it works very well switching the remote sockets and triggering the doorbell (excellent tool to get you out of an awkward conversation I might add...) and I was surprised at the range even without an aerial. It'll switch a socket on and off 7-8 metres away through closed doors! However, if an upgrade is required I'll take the plunge.

Thinking about the comment "with each press of a button, different pulses are sent"... I've attached a couple of text files. One is the result of pressing and holding the Low Fan setting, and the other is the result of repeatedly pressing the Low Fan setting. I've tried using each code with pilight-send but with no movement. I notice with repeated presses the code stays relatively similar, albeit with a few anomalies. Pressing and holding give many more codes.


Attached Files
.txt   press repeatedly - fan low.txt (Size: 7.9 KB / Downloads: 3)
.txt   press and hold - fan low.txt (Size: 7.18 KB / Downloads: 1)
since I have a similar problem, I think that my post is right here.
I have a ceiling fan with manual operation. For this I have now brought me a Pepeo remote control. That works too.
I installed the pilight version under Windows pilight-v7.0-win32.
That works too. I tried all pilight programs with an ELRO switch, everything was working.
I have the pilight USB Nano Full kit from the pilight Shop.
Now I wanted to read the raw codes of the Pepeo remote control with pilight-raw.
I just can not see anything when I press the Pepeo.
If I switch the ELRO, something will come.
The Pepeo remote is 433,9 MHz.
I just sent the above Raw, but it does not work either.
This looks like the Holtek HT15E protocol and I thought that the Pepeo also responds to it.

I have change the adress codes, the last four to my codes. But it down't work.
On the chip of the remote control is unfortunately not on it.
Which area does the nano read, this is exactly at 433.92 MHz.
Is it possible to change the frequency of the nano and if so how?
I do not know right now?
Does anyone else have an idea?
Thank you in advance
Sorry for my English, it has gone through the translator

has nobody any idea how to go on.
Here are some pictures of the Pepeo remote control.
As described above, I can not receive anything with pilight-raw.exe or pilight-debug.exe.

thanks for an answer


Attached Files Thumbnail(s)

Possibly Related Threads...
Thread Author Replies Views Last Post
  CasaFan Ceiling Fan Swot 0 430 08-08-2022, 03:49 PM
Last Post: Swot
  Ceiling Fan (e.g. Westinghouse) gadget 0 4,071 12-12-2015, 05:17 PM
Last Post: gadget

Forum Jump:

Browsing: 1 Guest(s)